summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9888601..f0707a76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -596,11 +596,11 @@ endif()
596# 596#
597################################################################################ 597################################################################################
598 598
599find_program(SH NAMES sh dash bash zsh) 599find_program(SHELL NAMES sh dash bash zsh)
600 600
601if(SH) 601if(SHELL)
602 execute_process( 602 execute_process(
603 COMMAND ${SH} ${toxcore_SOURCE_DIR}/other/version-sync 603 COMMAND ${SHELL} ${toxcore_SOURCE_DIR}/other/version-sync
604 ${toxcore_SOURCE_DIR} 604 ${toxcore_SOURCE_DIR}
605 ${PROJECT_VERSION_MAJOR} 605 ${PROJECT_VERSION_MAJOR}
606 ${PROJECT_VERSION_MINOR} 606 ${PROJECT_VERSION_MINOR}
@@ -615,7 +615,7 @@ endif()
615 615
616function(make_version_script header ns lib) 616function(make_version_script header ns lib)
617 execute_process( 617 execute_process(
618 COMMAND ${SH} -c "egrep '^\\w' ${header} | grep '${ns}_[a-z0-9_]*(' | grep -v '^typedef' | grep -o '${ns}_[a-z0-9_]*(' | egrep -o '\\w+' | sort -u" 618 COMMAND ${SHELL} -c "egrep '^\\w' ${header} | grep '${ns}_[a-z0-9_]*(' | grep -v '^typedef' | grep -o '${ns}_[a-z0-9_]*(' | egrep -o '\\w+' | sort -u"
619 OUTPUT_VARIABLE ${lib}_SYMS 619 OUTPUT_VARIABLE ${lib}_SYMS
620 OUTPUT_STRIP_TRAILING_WHITESPACE) 620 OUTPUT_STRIP_TRAILING_WHITESPACE)
621 string(REPLACE "\n" ";" ${lib}_SYMS ${${lib}_SYMS}) 621 string(REPLACE "\n" ";" ${lib}_SYMS ${${lib}_SYMS})
@@ -641,7 +641,7 @@ if(WIN32 OR APPLE)
641 set(STRICT_ABI OFF) 641 set(STRICT_ABI OFF)
642endif() 642endif()
643 643
644if(STRICT_ABI AND SH) 644if(STRICT_ABI AND SHELL AND ENABLE_SHARED)
645 if(BUILD_TOXAV) 645 if(BUILD_TOXAV)
646 make_version_script(${toxcore_SOURCE_DIR}/toxav/toxav.h toxav toxav) 646 make_version_script(${toxcore_SOURCE_DIR}/toxav/toxav.h toxav toxav)
647 endif() 647 endif()