summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2bd5381..f5ee2770 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -219,7 +219,7 @@ add_test(
219 219
220function(auto_test target) 220function(auto_test target)
221 if(CHECK_FOUND) 221 if(CHECK_FOUND)
222 add_executable(auto_${target} auto_tests/${target}.c) 222 add_c_executable(auto_${target} auto_tests/${target}.c)
223 target_link_modules(auto_${target} 223 target_link_modules(auto_${target}
224 toxcore 224 toxcore
225 toxencryptsave 225 toxencryptsave
@@ -253,13 +253,13 @@ endif()
253# 253#
254################################################################################ 254################################################################################
255 255
256add_executable(DHT_bootstrap 256add_c_executable(DHT_bootstrap
257 other/DHT_bootstrap.c 257 other/DHT_bootstrap.c
258 other/bootstrap_node_packets.c) 258 other/bootstrap_node_packets.c)
259target_link_modules(DHT_bootstrap toxnetcrypto) 259target_link_modules(DHT_bootstrap toxnetcrypto)
260 260
261if(LIBCONFIG_FOUND) 261if(LIBCONFIG_FOUND)
262 add_executable(tox-bootstrapd 262 add_c_executable(tox-bootstrapd
263 other/bootstrap_daemon/src/command_line_arguments.c 263 other/bootstrap_daemon/src/command_line_arguments.c
264 other/bootstrap_daemon/src/command_line_arguments.h 264 other/bootstrap_daemon/src/command_line_arguments.h
265 other/bootstrap_daemon/src/config.c 265 other/bootstrap_daemon/src/config.c
@@ -282,7 +282,7 @@ endif()
282################################################################################ 282################################################################################
283 283
284if(NOT WIN32 AND BUILD_TOXAV AND SNDFILE_FOUND AND PORTAUDIO_FOUND AND OPENCV_FOUND) 284if(NOT WIN32 AND BUILD_TOXAV AND SNDFILE_FOUND AND PORTAUDIO_FOUND AND OPENCV_FOUND)
285 add_executable(av_test testing/av_test.c) 285 add_c_executable(av_test testing/av_test.c)
286 target_link_modules(av_test 286 target_link_modules(av_test
287 toxav 287 toxav
288 ${OPENCV_LIBRARIES} 288 ${OPENCV_LIBRARIES}
@@ -291,31 +291,31 @@ if(NOT WIN32 AND BUILD_TOXAV AND SNDFILE_FOUND AND PORTAUDIO_FOUND AND OPENCV_FO
291endif() 291endif()
292 292
293if(NOT WIN32) 293if(NOT WIN32)
294 add_executable(nTox testing/nTox.c) 294 add_c_executable(nTox testing/nTox.c)
295 target_link_modules(nTox toxcore ${NCURSES_LIBRARIES}) 295 target_link_modules(nTox toxcore ${NCURSES_LIBRARIES})
296endif() 296endif()
297 297
298add_executable(DHT_test testing/DHT_test.c) 298add_c_executable(DHT_test testing/DHT_test.c)
299target_link_modules(DHT_test toxdht) 299target_link_modules(DHT_test toxdht)
300 300
301add_executable(Messenger_test testing/Messenger_test.c) 301add_c_executable(Messenger_test testing/Messenger_test.c)
302target_link_modules(Messenger_test toxmessenger) 302target_link_modules(Messenger_test toxmessenger)
303 303
304add_executable(dns3_test testing/dns3_test.c) 304add_c_executable(dns3_test testing/dns3_test.c)
305target_link_modules(dns3_test toxdns) 305target_link_modules(dns3_test toxdns)
306 306
307if(NOT WIN32) 307if(NOT WIN32)
308 add_executable(tox_sync testing/tox_sync.c) 308 add_c_executable(tox_sync testing/tox_sync.c)
309 target_link_modules(tox_sync toxcore) 309 target_link_modules(tox_sync toxcore)
310endif() 310endif()
311 311
312if(UTIL_LIBRARIES) 312if(UTIL_LIBRARIES)
313 add_executable(tox_shell testing/tox_shell.c) 313 add_c_executable(tox_shell testing/tox_shell.c)
314 target_link_modules(tox_shell toxcore ${UTIL_LIBRARIES}) 314 target_link_modules(tox_shell toxcore ${UTIL_LIBRARIES})
315endif() 315endif()
316 316
317if(NOT WIN32) 317if(NOT WIN32)
318 add_executable(irc_syncbot testing/irc_syncbot.c) 318 add_c_executable(irc_syncbot testing/irc_syncbot.c)
319 target_link_modules(irc_syncbot toxcore) 319 target_link_modules(irc_syncbot toxcore)
320endif() 320endif()
321 321