summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc846554..d6302051 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,9 +54,13 @@ message("SOVERSION: ${SOVERSION}")
54 54
55include(AddCompilerFlag) 55include(AddCompilerFlag)
56include(ApiDsl) 56include(ApiDsl)
57include(MacRpath)
58include(ModulePackage) 57include(ModulePackage)
59include(StrictAbi) 58include(StrictAbi)
59include(GNUInstallDirs)
60
61if(APPLE)
62 include(MacRpath)
63endif()
60 64
61enable_testing() 65enable_testing()
62 66
@@ -374,9 +378,9 @@ endforeach()
374# Make version script (on systems that support it) to limit symbol visibility. 378# Make version script (on systems that support it) to limit symbol visibility.
375make_version_script(toxcore ${toxcore_API_HEADERS}) 379make_version_script(toxcore ${toxcore_API_HEADERS})
376 380
377# Generate pkg-config file, install library to "lib" and install headers to 381# Generate pkg-config file, install library to "${CMAKE_INSTALL_LIBDIR}" and install headers to
378# "include/tox". 382# "${CMAKE_INSTALL_INCLUDEDIR}/tox".
379install_module(toxcore DESTINATION "include/tox") 383install_module(toxcore DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/tox)
380 384
381################################################################################ 385################################################################################
382# 386#