summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 841b756a..23bfdcdb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ set(core_sources
11 core/Messenger.c) 11 core/Messenger.c)
12 12
13set(test_sources 13set(test_sources
14 testing/Messenger_test.c) 14 testing/nTox.c)
15 15
16add_executable(${exe_name} 16add_executable(${exe_name}
17 ${core_sources} 17 ${core_sources}
@@ -23,6 +23,7 @@ if(WIN32)
23 ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a) 23 ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a)
24else() 24else()
25 target_link_libraries(${exe_name} sodium) 25 target_link_libraries(${exe_name} sodium)
26 target_link_libraries(${exe_name} ncurses)
26endif() 27endif()
27 28
28if(CMAKE_COMPILER_IS_GNUCC) 29if(CMAKE_COMPILER_IS_GNUCC)