summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51e1e99f..98a4eabe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@ cmake_minimum_required(VERSION 2.8.12)
18cmake_policy(VERSION 2.8.12) 18cmake_policy(VERSION 2.8.12)
19project(toxcore) 19project(toxcore)
20 20
21set(CMAKE_MODULE_PATH ${toxcore_SOURCE_DIR}/cmake) 21list(APPEND CMAKE_MODULE_PATH ${toxcore_SOURCE_DIR}/cmake)
22 22
23################################################################################ 23################################################################################
24# 24#
@@ -115,6 +115,13 @@ option(NON_HERMETIC_TESTS "Whether to build and run tests that depend on an inte
115option(BUILD_TOXAV "Whether to build the tox AV library" ON) 115option(BUILD_TOXAV "Whether to build the tox AV library" ON)
116option(MUST_BUILD_TOXAV "Fail the build if toxav cannot be built" OFF) 116option(MUST_BUILD_TOXAV "Fail the build if toxav cannot be built" OFF)
117 117
118if(MSVC)
119 option(MSVC_STATIC_SODIUM "Whether to link libsodium statically for MSVC" OFF)
120 if(MSVC_STATIC_SODIUM)
121 add_definitions(-DSODIUM_STATIC=1 -DSODIUM_EXPORT)
122 endif()
123endif()
124
118include(Dependencies) 125include(Dependencies)
119 126
120if(MUST_BUILD_TOXAV) 127if(MUST_BUILD_TOXAV)