summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed934c01..07098391 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,15 +33,15 @@ if(NOT USE_NACL)
33endif() 33endif()
34 34
35macro(linkCoreLibraries exe_name) 35macro(linkCoreLibraries exe_name)
36 add_dependencies(${exe_name} core) 36 add_dependencies(${exe_name} toxcore)
37 if(WIN32) 37 if(WIN32)
38 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/) 38 include_directories(${CMAKE_HOME_DIRECTORY}/sodium/include/)
39 target_link_libraries(${exe_name} core 39 target_link_libraries(${exe_name} toxcore
40 ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a 40 ${CMAKE_SOURCE_DIR}/sodium/lib/libsodium.a
41 ws2_32) 41 ws2_32)
42 else() 42 else()
43 include_directories(${SODIUM_INCLUDE_DIR}) 43 include_directories(${SODIUM_INCLUDE_DIR})
44 target_link_libraries(${exe_name} core 44 target_link_libraries(${exe_name} toxcore
45 ${LINK_CRYPTO_LIBRARY}) 45 ${LINK_CRYPTO_LIBRARY})
46 46
47 endif() 47 endif()