summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4544a91a..2d7fcece 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,10 @@ if(NOT "${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
83 if(DEBUG) 83 if(DEBUG)
84 set(MIN_LOGGER_LEVEL DEBUG) 84 set(MIN_LOGGER_LEVEL DEBUG)
85 add_cflag("-g3") 85 add_cflag("-g3")
86 if(MINGW)
87 # Allows wine to display source code file names and line numbers on crash in its backtrace
88 add_flag("-gdwarf-2")
89 endif()
86 endif() 90 endif()
87 91
88 option(WARNINGS "Enable additional compiler warnings" ON) 92 option(WARNINGS "Enable additional compiler warnings" ON)