summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58e3e673..bbb9a014 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,6 +289,11 @@ if(NOT WIN32 AND BUILD_TOXAV AND SNDFILE_FOUND AND PORTAUDIO_FOUND AND OPENCV_FO
289 ${OPENCV_LIBRARIES} 289 ${OPENCV_LIBRARIES}
290 ${PORTAUDIO_LIBRARIES} 290 ${PORTAUDIO_LIBRARIES}
291 ${SNDFILE_LIBRARIES}) 291 ${SNDFILE_LIBRARIES})
292 # Due to https://github.com/opencv/opencv/issues/6585, we need to compile
293 # av_test as C++ for newer OpenCV versions.
294 if(NOT OPENCV_VERSION VERSION_LESS 3)
295 set_source_files_properties(testing/av_test.c PROPERTIES LANGUAGE CXX)
296 endif()
292endif() 297endif()
293 298
294if(NOT WIN32) 299if(NOT WIN32)