summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73f66cf1..8417715b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,8 @@ if(USE_STDERR_LOGGER)
110 add_definitions(-DUSE_STDERR_LOGGER=1) 110 add_definitions(-DUSE_STDERR_LOGGER=1)
111endif() 111endif()
112 112
113option(NON_HERMETIC_TESTS "Whether to build and run tests that depend on an internet connection" OFF)
114
113option(BUILD_TOXAV "Whether to build the tox AV library" ON) 115option(BUILD_TOXAV "Whether to build the tox AV library" ON)
114option(MUST_BUILD_TOXAV "Fail the build if toxav cannot be built" OFF) 116option(MUST_BUILD_TOXAV "Fail the build if toxav cannot be built" OFF)
115 117
@@ -405,7 +407,6 @@ function(auto_test target)
405endfunction() 407endfunction()
406 408
407auto_test(TCP) 409auto_test(TCP)
408auto_test(bootstrap)
409auto_test(conference) 410auto_test(conference)
410auto_test(conference_double_invite) 411auto_test(conference_double_invite)
411auto_test(conference_invite_merge) 412auto_test(conference_invite_merge)
@@ -436,7 +437,6 @@ auto_test(send_message)
436auto_test(set_name) 437auto_test(set_name)
437auto_test(set_status_message) 438auto_test(set_status_message)
438auto_test(skeleton) 439auto_test(skeleton)
439auto_test(tcp_relay)
440auto_test(tox_many) 440auto_test(tox_many)
441auto_test(tox_many_tcp) 441auto_test(tox_many_tcp)
442auto_test(tox_one) 442auto_test(tox_one)
@@ -445,6 +445,11 @@ auto_test(typing)
445auto_test(version) 445auto_test(version)
446auto_test(save_compatibility) 446auto_test(save_compatibility)
447 447
448if(NON_HERMETIC_TESTS)
449 auto_test(bootstrap)
450 auto_test(tcp_relay)
451endif()
452
448if(BUILD_TOXAV) 453if(BUILD_TOXAV)
449 auto_test(conference_av) 454 auto_test(conference_av)
450 auto_test(toxav_basic) 455 auto_test(toxav_basic)