summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 20 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 2b4fad78..066c919a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,11 +32,11 @@ if test "x${prefix}" = "xNONE"; then
32 prefix="${ac_default_prefix}" 32 prefix="${ac_default_prefix}"
33fi 33fi
34 34
35BUILD_DHT_BOOTSTRAP_DAEMON="yes" 35BUILD_DHT_BOOTSTRAP_DAEMON="no"
36BUILD_NTOX="yes" 36BUILD_NTOX="no"
37BUILD_TESTS="yes" 37BUILD_TESTS="yes"
38BUILD_AV="yes" 38BUILD_AV="yes"
39BUILD_PHONE="yes" 39BUILD_PHONE="no"
40BUILD_TESTING="yes" 40BUILD_TESTING="yes"
41 41
42NCURSES_FOUND="no" 42NCURSES_FOUND="no"
@@ -57,25 +57,25 @@ AC_ARG_ENABLE([nacl],
57 57
58PKG_PROG_PKG_CONFIG 58PKG_PROG_PKG_CONFIG
59 59
60AC_ARG_ENABLE([av], 60AC_ARG_ENABLE([phone],
61 [AC_HELP_STRING([--disable-av], [build AV support libraries (default: auto)]) ], 61 [AC_HELP_STRING([--enable-phone], [build test phone (default: auto)]) ],
62 [ 62 [
63 if test "x$enableval" = "xno"; then 63 if test "x$enableval" = "xno"; then
64 BUILD_AV="no"
65 BUILD_PHONE="no" 64 BUILD_PHONE="no"
66 elif test "x$enableval" = "xyes"; then 65 elif test "x$enableval" = "xyes"; then
67 BUILD_AV="yes" 66 BUILD_PHONE="yes"
68 fi 67 fi
69 ] 68 ]
70) 69)
71 70
72AC_ARG_ENABLE([phone], 71AC_ARG_ENABLE([av],
73 [AC_HELP_STRING([--disable-phone], [build test phone (default: auto)]) ], 72 [AC_HELP_STRING([--disable-av], [build AV support libraries (default: auto)]) ],
74 [ 73 [
75 if test "x$enableval" = "xno"; then 74 if test "x$enableval" = "xno"; then
75 BUILD_AV="no"
76 BUILD_PHONE="no" 76 BUILD_PHONE="no"
77 elif test "x$enableval" = "xyes"; then 77 elif test "x$enableval" = "xyes"; then
78 BUILD_PHONE="yes" 78 BUILD_AV="yes"
79 fi 79 fi
80 ] 80 ]
81) 81)
@@ -92,7 +92,7 @@ AC_ARG_ENABLE([tests],
92) 92)
93 93
94AC_ARG_ENABLE([ntox], 94AC_ARG_ENABLE([ntox],
95 [AC_HELP_STRING([--disable-ntox], [build nTox client (default: auto)]) ], 95 [AC_HELP_STRING([--enable-ntox], [build nTox client (default: auto)]) ],
96 [ 96 [
97 if test "x$enableval" = "xno"; then 97 if test "x$enableval" = "xno"; then
98 BUILD_NTOX="no" 98 BUILD_NTOX="no"
@@ -102,8 +102,8 @@ AC_ARG_ENABLE([ntox],
102 ] 102 ]
103) 103)
104 104
105AC_ARG_ENABLE([dht-bootstrap-daemon], 105AC_ARG_ENABLE([daemon],
106 [AC_HELP_STRING([--disable-dht-bootstrap-daemon], [build DHT bootstrap daemon (default: auto)]) ], 106 [AC_HELP_STRING([--enable-daemon], [build DHT bootstrap daemon (default: auto)]) ],
107 [ 107 [
108 if test "x$enableval" = "xno"; then 108 if test "x$enableval" = "xno"; then
109 BUILD_DHT_BOOTSTRAP_DAEMON="no" 109 BUILD_DHT_BOOTSTRAP_DAEMON="no"
@@ -345,6 +345,7 @@ AC_TYPE_UINT64_T
345AC_TYPE_UINT8_T 345AC_TYPE_UINT8_T
346AC_C_BIGENDIAN 346AC_C_BIGENDIAN
347 347
348
348# Checks for library functions. 349# Checks for library functions.
349AC_FUNC_FORK 350AC_FUNC_FORK
350AC_CHECK_FUNCS([gettimeofday memset socket strchr malloc]) 351AC_CHECK_FUNCS([gettimeofday memset socket strchr malloc])
@@ -430,6 +431,12 @@ if test "x$BUILD_PHONE" = "xyes"; then
430 ) 431 )
431fi 432fi
432 433
434#If all dependencies are here add support video define for phone.c
435if test "x$BUILD_PHONE" == "xyes"; then
436 #Set FFMpeg define
437 AC_DEFINE([TOX_FFMPEG], [1], [Support video])
438fi
439
433if test "x$BUILD_AV" = "xyes"; then 440if test "x$BUILD_AV" = "xyes"; then
434 PKG_CHECK_MODULES([OPUS], [opus], 441 PKG_CHECK_MODULES([OPUS], [opus],
435 [], 442 [],