summaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 49ca7c83..ecbb65c2 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -37,3 +37,9 @@ if(WIN32)
37 target_link_libraries(toxcore ws2_32) 37 target_link_libraries(toxcore ws2_32)
38endif() 38endif()
39 39
40execute_process(COMMAND git rev-list HEAD --count OUTPUT_VARIABLE COMMIT)
41
42# Write pkgconfig-file:
43include(InstallPkgConfigFile)
44install_pkg_config_file(toxcore CFLAGS LIBS -ltoxcore REQUIRES VERSION 0.1.1_r${COMMIT})
45