summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
deleted file mode 100644
index 4b281eb4..00000000
--- a/docs/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
1find_package(Sphinx QUIET)
2
3if(NOT DEFINED SPHINX_THEME)
4 set(SPHINX_THEME default)
5endif()
6
7if(NOT DEFINED SPHINX_THEME_DIR)
8 set(SPHINX_THEME_DIR)
9endif()
10
11# configured documentation tools and intermediate build results
12set(BINARY_BUILD_DIR "${CMAKE_CURRENT_BINARY_DIR}/_build")
13
14# Sphinx cache with pickled ReST documents
15set(SPHINX_CACHE_DIR "${CMAKE_CURRENT_BINARY_DIR}/_doctrees")
16
17# HTML output directory
18set(SPHINX_HTML_DIR "${CMAKE_CURRENT_BINARY_DIR}/html")
19
20configure_file(
21 "${CMAKE_CURRENT_SOURCE_DIR}/conf.py.in"
22 "${BINARY_BUILD_DIR}/conf.py"
23 @ONLY)
24
25if(SPHINX_FOUND)
26 add_custom_target(docs
27 ${SPHINX_EXECUTABLE}
28 -b html
29 -c "${BINARY_BUILD_DIR}"
30 -d "${SPHINX_CACHE_DIR}"
31 "${CMAKE_CURRENT_SOURCE_DIR}"
32 "${SPHINX_HTML_DIR}"
33 COMMENT "Building HTML documentation with Sphinx")
34else()
35 add_custom_target(docs
36 echo "Please install python-sphinx to build the docs or read the docs online: https://projecttox.readthedocs.org/en/latest"
37- COMMENT "No sphinx executable found")
38endif()