summaryrefslogtreecommitdiff
path: root/other/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'other/CMakeLists.txt')
-rw-r--r--other/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/other/CMakeLists.txt b/other/CMakeLists.txt
index db742e3e..10e5b051 100644
--- a/other/CMakeLists.txt
+++ b/other/CMakeLists.txt
@@ -1,9 +1,24 @@
1cmake_minimum_required(VERSION 2.6.0) 1cmake_minimum_required(VERSION 2.6.0)
2 2
3cmake_policy(SET CMP0011 NEW) 3cmake_policy(SET CMP0011 NEW)
4SET(USER_NAME $ENV{USERNAME} CACHE STRING UserName)
4 5
5include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/DHT_bootstrap.cmake) 6include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/DHT_bootstrap.cmake)
6 7
8if(WIN32)
9 file(MAKE_DIRECTORY "C:/Users/${USER_NAME}/AppData/Roaming/.tox")
10 file(INSTALL DHTservers DESTINATION "C:/Users/${USER_NAME}/AppData/Roaming/.tox")
11else()
12 set(HOME "$ENV{HOME}")
13 if(APPLE)
14 file(MAKE_DIRECTORY ${HOME}Library/Application Support/.tox)
15 file(INSTALL DHTservers DESTINATION ${HOME}Library/Application Support/.tox)
16 else()
17 file(MAKE_DIRECTORY ${HOME}/.tox)
18 file(INSTALL DHTservers DESTINATION ${HOME}/.tox)
19 endif()
20endif()
21
7if(LINUX) 22if(LINUX)
8 add_subdirectory(bootstrap_serverdaemon) 23 add_subdirectory(bootstrap_serverdaemon)
9endif() 24endif()