summaryrefslogtreecommitdiff
path: root/toxcore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'toxcore/CMakeLists.txt')
-rw-r--r--toxcore/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/toxcore/CMakeLists.txt b/toxcore/CMakeLists.txt
deleted file mode 100644
index ecbb65c2..00000000
--- a/toxcore/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
1cmake_minimum_required(VERSION 2.6.0)
2project(toxcore C)
3
4set(core_sources
5 DHT.c
6 network.c
7 Lossless_UDP.c
8 net_crypto.c
9 friend_requests.c
10 LAN_discovery.c
11 Messenger.c
12 util.c
13 ping.c
14 tox.c)
15
16set(core_headers
17 DHT.h
18 network.h
19 Lossless_UDP.h
20 net_crypto.h
21 friend_requests.h
22 LAN_discovery.h
23 Messenger.h
24 util.h
25 ping.h)
26
27add_library(toxcore SHARED ${core_sources})
28add_library(toxcore_static ${core_sources})
29set_target_properties(toxcore_static PROPERTIES OUTPUT_NAME toxcore)
30
31target_link_libraries(toxcore ${LINK_CRYPTO_LIBRARY})
32
33install(TARGETS toxcore toxcore_static DESTINATION lib)
34install(FILES ${core_headers} DESTINATION include)
35
36if(WIN32)
37 target_link_libraries(toxcore ws2_32)
38endif()
39
40execute_process(COMMAND git rev-list HEAD --count OUTPUT_VARIABLE COMMIT)
41
42# Write pkgconfig-file:
43include(InstallPkgConfigFile)
44install_pkg_config_file(toxcore CFLAGS LIBS -ltoxcore REQUIRES VERSION 0.1.1_r${COMMIT})
45