diff options
author | Ben West <bewest@gmail.com> | 2014-05-24 16:44:18 -0700 |
---|---|---|
committer | Ben West <bewest@gmail.com> | 2014-05-24 16:44:18 -0700 |
commit | 233f3e5ed307df775f53ccc66e5823dd0d46b75f (patch) | |
tree | 3c5ec358844de71b7c6435d405ede4b328302daf /setup.py | |
parent | 5d92368e5b10fb2d01ae25a2730e15cd05a84da6 (diff) |
Make remotely installable, via pip/distutils et al
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/setup.py b/setup.py new file mode 100644 index 0000000..e0363ea --- /dev/null +++ b/setup.py | |||
@@ -0,0 +1,34 @@ | |||
1 | #!/usr/bin/python | ||
2 | |||
3 | from setuptools import setup, find_packages | ||
4 | |||
5 | import dexcom_reader | ||
6 | def readme(): | ||
7 | with open("README.md") as f: | ||
8 | return f.read() | ||
9 | |||
10 | setup(name='dexcom_reader', | ||
11 | version='0.0.1', # http://semver.org/ | ||
12 | description='Audit, and inspect data from Dexcom G4.', | ||
13 | long_description=readme(), | ||
14 | author="Medevice contributors", | ||
15 | # I'm just maintaining the package, compbrain authored it. | ||
16 | author_email="bewest+insulaudit@gmail.com", | ||
17 | url="https://github.com/compbrain/dexcom_reader", | ||
18 | packages=['dexcom_reader'], | ||
19 | install_requires = [ | ||
20 | 'pyserial' | ||
21 | ], | ||
22 | classifiers = [ | ||
23 | 'Development Status :: 3 - Alpha', | ||
24 | 'Intended Audience :: Developers', | ||
25 | 'Intended Audience :: Science/Research', | ||
26 | 'Programming Language :: Python', | ||
27 | 'Topic :: Scientific/Engineering', | ||
28 | 'Topic :: Software Development :: Libraries' | ||
29 | ], | ||
30 | zip_safe=False, | ||
31 | ) | ||
32 | |||
33 | ##### | ||
34 | # EOF | ||