summaryrefslogtreecommitdiff
path: root/packages/sundials
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sundials')
-rw-r--r--packages/sundials/nixpkgs.nix1
-rw-r--r--packages/sundials/shell.nix20
-rw-r--r--packages/sundials/stack.yaml12
3 files changed, 0 insertions, 33 deletions
diff --git a/packages/sundials/nixpkgs.nix b/packages/sundials/nixpkgs.nix
deleted file mode 100644
index b416238..0000000
--- a/packages/sundials/nixpkgs.nix
+++ /dev/null
@@ -1 +0,0 @@
1import (fetchTarball "https://github.com/nixos/nixpkgs/archive/54ade273e7a677ec35e501174d86d253d9d8dede.tar.gz")
diff --git a/packages/sundials/shell.nix b/packages/sundials/shell.nix
deleted file mode 100644
index c034dde..0000000
--- a/packages/sundials/shell.nix
+++ /dev/null
@@ -1,20 +0,0 @@
1{ghc}:
2
3with import <nixpkgs> {};
4
5let
6 gfortranlibdir = "${gfortran7.cc.lib}";
7 # XXX Workaround https://ghc.haskell.org/trac/ghc/ticket/11042.
8 libHack = if stdenv.isDarwin then {
9 DYLD_LIBRARY_PATH = [gfortranlibdir];
10 } else {
11 LD_LIBRARY_PATH = [gfortranlibdir];
12 };
13in
14haskell.lib.buildStackProject ({
15 name = "haskell-sundials";
16 buildInputs = [blas liblapack sundials zlib];
17 inherit ghc;
18 # XXX Workaround https://ghc.haskell.org/trac/ghc/ticket/11042.
19 extraArgs = ["--extra-lib-dirs=${gfortranlibdir}"];
20} // libHack)
diff --git a/packages/sundials/stack.yaml b/packages/sundials/stack.yaml
deleted file mode 100644
index d87e6fd..0000000
--- a/packages/sundials/stack.yaml
+++ /dev/null
@@ -1,12 +0,0 @@
1resolver: lts-10.9
2
3packages:
4- .
5
6extra-deps:
7- diagrams-rasterific-1.4
8- plots-0.1.0.2
9
10nix:
11 path: [nixpkgs=./nixpkgs.nix]
12 shell-file: shell.nix