diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 43 |
1 files changed, 2 insertions, 41 deletions
@@ -58,7 +58,7 @@ mkDerivation { | |||
58 | executableSystemDepends = [ | 58 | executableSystemDepends = [ |
59 | pkgs.blas | 59 | pkgs.blas |
60 | pkgs.liblapack | 60 | pkgs.liblapack |
61 | patched-gsl | 61 | pkgs.gsl |
62 | sundials | 62 | sundials |
63 | pkgs.zlib | 63 | pkgs.zlib |
64 | ] ++ (if pkgs.stdenv.isDarwin then [pkgs.darwin.apple_sdk.frameworks.Accelerate] else []); | 64 | ] ++ (if pkgs.stdenv.isDarwin then [pkgs.darwin.apple_sdk.frameworks.Accelerate] else []); |
@@ -71,46 +71,7 @@ haskellPackages = if compiler == "default" | |||
71 | 71 | ||
72 | variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id; | 72 | variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id; |
73 | 73 | ||
74 | patched-hmatrix = pkgs.haskellPackages.hmatrix.overrideAttrs (oldAttrs: rec { | 74 | drv = variant (haskellPackages.callPackage f {}); |
75 | src = nixpkgs.fetchgit { | ||
76 | url = git://github.com/albertoruiz/hmatrix; | ||
77 | rev = "d83b17190029c11e3ab8b504e5cdc917f5863120"; | ||
78 | sha256 = "11wr59wg21rky59j3kkd3ba6aqns9gkh0r1fnhwhn3fp7zfhanqn"; | ||
79 | }; | ||
80 | postUnpack = '' | ||
81 | sourceRoot=''${sourceRoot}/packages/base | ||
82 | echo Source root reset to ''${sourceRoot} | ||
83 | ''; | ||
84 | }); | ||
85 | |||
86 | patched-hmatrix-gsl = pkgs.haskellPackages.hmatrix-gsl.overrideAttrs (oldAttrs: rec { | ||
87 | src = nixpkgs.fetchgit { | ||
88 | url = git://github.com/albertoruiz/hmatrix; | ||
89 | rev = "d83b17190029c11e3ab8b504e5cdc917f5863120"; | ||
90 | sha256 = "11wr59wg21rky59j3kkd3ba6aqns9gkh0r1fnhwhn3fp7zfhanqn"; | ||
91 | }; | ||
92 | postUnpack = '' | ||
93 | sourceRoot=''${sourceRoot}/packages/gsl | ||
94 | echo Source root reset to ''${sourceRoot} | ||
95 | ''; | ||
96 | }); | ||
97 | |||
98 | patched-gsl = pkgs.gsl.overrideAttrs (oldAttrs: rec { | ||
99 | src = nixpkgs.fetchgit { | ||
100 | url = git://github.com/idontgetoutmuch/gsl; | ||
101 | rev = "c2035977d65cd804169ff3370da6723cf879be75"; | ||
102 | sha256 = "1fqp77gp9nl3av1z58cwg8fivik4rff394wgjzc76ayd04y0d1k7"; | ||
103 | }; | ||
104 | version = "2.5"; | ||
105 | name = "gsl-${version}"; | ||
106 | doCheck = false; | ||
107 | CFLAGS = "-DDEBUG"; | ||
108 | }); | ||
109 | |||
110 | drv = variant (haskellPackages.callPackage f { | ||
111 | hmatrix = patched-hmatrix; | ||
112 | hmatrix-gsl = patched-hmatrix-gsl; | ||
113 | }); | ||
114 | 75 | ||
115 | in | 76 | in |
116 | 77 | ||