diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 20 |
1 files changed, 0 insertions, 20 deletions
diff --git a/shell.nix b/shell.nix deleted file mode 100644 index c034dde..0000000 --- a/shell.nix +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | {ghc}: | ||
2 | |||
3 | with import <nixpkgs> {}; | ||
4 | |||
5 | let | ||
6 | gfortranlibdir = "${gfortran7.cc.lib}"; | ||
7 | # XXX Workaround https://ghc.haskell.org/trac/ghc/ticket/11042. | ||
8 | libHack = if stdenv.isDarwin then { | ||
9 | DYLD_LIBRARY_PATH = [gfortranlibdir]; | ||
10 | } else { | ||
11 | LD_LIBRARY_PATH = [gfortranlibdir]; | ||
12 | }; | ||
13 | in | ||
14 | haskell.lib.buildStackProject ({ | ||
15 | name = "haskell-sundials"; | ||
16 | buildInputs = [blas liblapack sundials zlib]; | ||
17 | inherit ghc; | ||
18 | # XXX Workaround https://ghc.haskell.org/trac/ghc/ticket/11042. | ||
19 | extraArgs = ["--extra-lib-dirs=${gfortranlibdir}"]; | ||
20 | } // libHack) | ||