summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2020-09-20 16:14:20 +0100
committerColin Watson <cjwatson@debian.org>2020-09-20 16:14:20 +0100
commit173bfbf7886608a4a7abbfac6a42ac4bf4a3432d (patch)
treeb97833d8754f257f92d99dd2f5c9e9d557e3f689 /tools/CMakeLists.txt
parent75073d0a8478441cc97a6efa10b566c5fb1dac81 (diff)
New upstream version 1.5.0
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 274a799..4d08be9 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -20,6 +20,13 @@ else()
20 list(APPEND COMPAT_SOURCES ../openbsd-compat/readpassphrase.c) 20 list(APPEND COMPAT_SOURCES ../openbsd-compat/readpassphrase.c)
21endif() 21endif()
22 22
23if(NOT MSVC)
24 set_source_files_properties(assert_get.c assert_verify.c base64.c bio.c
25 cred_make.c cred_verify.c credman.c fido2-assert.c fido2-cred.c
26 fido2-token.c pin.c token.c util.c PROPERTIES COMPILE_FLAGS
27 "-Wconversion -Wsign-conversion")
28endif()
29
23add_executable(fido2-cred 30add_executable(fido2-cred
24 fido2-cred.c 31 fido2-cred.c
25 cred_make.c 32 cred_make.c