summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authornicoo <nicoo@debian.org>2020-02-23 14:46:35 +0000
committernicoo <nicoo@debian.org>2020-02-23 14:46:35 +0000
commitf794345c2d734f593da8ed7754e5dbb5809c688d (patch)
tree32889c9b7bd26656242cc5e4b483c8a1deba88e1 /tools/CMakeLists.txt
parent28215e6c161c70cb1bcae7d01195fefcffb09d32 (diff)
parent400533f0af0b8119c84e574387ed05e500f63861 (diff)
Merge branch 'prep-v1.3.1-1' into 'debian/sid'
Prepare upload v1.3.1-1 See merge request auth-team/libfido2!3
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 5f27e88..4b8ef32 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -49,17 +49,10 @@ add_executable(fido2-token
49 ${COMPAT_SOURCES} 49 ${COMPAT_SOURCES}
50) 50)
51 51
52add_library(sk-libfido2 MODULE sk-libfido2.c)
53set_target_properties(sk-libfido2 PROPERTIES
54 COMPILE_FLAGS "-DSK_STANDALONE -DWITH_OPENSSL"
55 OUTPUT_NAME sk-libfido2
56)
57 52
58target_link_libraries(fido2-cred ${CRYPTO_LIBRARIES} fido2_shared) 53target_link_libraries(fido2-cred ${CRYPTO_LIBRARIES} fido2_shared)
59target_link_libraries(fido2-assert ${CRYPTO_LIBRARIES} fido2_shared) 54target_link_libraries(fido2-assert ${CRYPTO_LIBRARIES} fido2_shared)
60target_link_libraries(fido2-token ${CRYPTO_LIBRARIES} fido2_shared) 55target_link_libraries(fido2-token ${CRYPTO_LIBRARIES} fido2_shared)
61target_link_libraries(sk-libfido2 ${CRYPTO_LIBRARIES} fido2_shared)
62 56
63install(TARGETS fido2-cred fido2-assert fido2-token 57install(TARGETS fido2-cred fido2-assert fido2-token
64 DESTINATION ${CMAKE_INSTALL_BINDIR}) 58 DESTINATION ${CMAKE_INSTALL_BINDIR})
65install(TARGETS sk-libfido2 DESTINATION ${CMAKE_INSTALL_LIBDIR})