summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2012-04-25 17:19:07 -0500
committerStephen Paul Weber <singpolyma@singpolyma.net>2012-04-25 17:19:07 -0500
commit6b743222684f2b8151dfbdef42f0dc890e590c41 (patch)
tree77b5ae031d2b863f03399ba9a5b56ba4478d2ab2 /debian
parent7b3232778f284dd4dd3a6f3287bcbe1fbe10b010 (diff)
Split OpenPGP.Crypto out into a seperate package
Diffstat (limited to 'debian')
-rw-r--r--debian/control27
1 files changed, 6 insertions, 21 deletions
diff --git a/debian/control b/debian/control
index a4b9165..679e316 100644
--- a/debian/control
+++ b/debian/control
@@ -7,8 +7,6 @@ Build-Depends: debhelper (>= 7.0),
7 cdbs, 7 cdbs,
8 ghc, 8 ghc,
9 ghc-prof, 9 ghc-prof,
10 libghc-crypto-dev,
11 libghc-crypto-prof,
12 libghc-binary-dev, 10 libghc-binary-dev,
13 libghc-binary-prof, 11 libghc-binary-prof,
14 libghc-bzlib-dev, 12 libghc-bzlib-dev,
@@ -18,7 +16,6 @@ Build-Depends: debhelper (>= 7.0),
18 libghc-zlib-dev, 16 libghc-zlib-dev,
19 libghc-zlib-prof 17 libghc-zlib-prof
20Build-Depends-Indep: ghc-doc, 18Build-Depends-Indep: ghc-doc,
21 libghc-crypto-doc,
22 libghc-binary-doc, 19 libghc-binary-doc,
23 libghc-bzlib-doc, 20 libghc-bzlib-doc,
24 libghc-utf8-string-doc, 21 libghc-utf8-string-doc,
@@ -44,15 +41,11 @@ Description: Implementation of the OpenPGP message format
44 and then defines instances of Data.Binary for each to facilitate 41 and then defines instances of Data.Binary for each to facilitate
45 encoding/decoding. 42 encoding/decoding.
46 . 43 .
47 There is also a wrapper around <http://hackage.haskell.org/package/Crypto> 44 For performing cryptography, see <http://hackage.haskell.org/openpgp-Crypto>
48 that currently does fingerprint generation, signature generation, and
49 signature verification (for RSA keys only).
50 . 45 .
51 It is intended that you use qualified imports with this library. If importing 46 It is intended that you use qualified imports with this library.
52 both modules, something like this will do:
53 . 47 .
54 > import qualified Data.OpenPGP as OpenPGP 48 > import qualified Data.OpenPGP as OpenPGP
55 > import qualified Data.OpenPGP.Crypto as OpenPGP
56 . 49 .
57 Author: Stephen Paul Weber <singpolyma@singpolyma.net> 50 Author: Stephen Paul Weber <singpolyma@singpolyma.net>
58 Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> 51 Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net>
@@ -76,15 +69,11 @@ Description: Implementation of the OpenPGP message format
76 and then defines instances of Data.Binary for each to facilitate 69 and then defines instances of Data.Binary for each to facilitate
77 encoding/decoding. 70 encoding/decoding.
78 . 71 .
79 There is also a wrapper around <http://hackage.haskell.org/package/Crypto> 72 For performing cryptography, see <http://hackage.haskell.org/openpgp-Crypto>
80 that currently does fingerprint generation, signature generation, and
81 signature verification (for RSA keys only).
82 . 73 .
83 It is intended that you use qualified imports with this library. If importing 74 It is intended that you use qualified imports with this library.
84 both modules, something like this will do:
85 . 75 .
86 > import qualified Data.OpenPGP as OpenPGP 76 > import qualified Data.OpenPGP as OpenPGP
87 > import qualified Data.OpenPGP.Crypto as OpenPGP
88 . 77 .
89 Author: Stephen Paul Weber <singpolyma@singpolyma.net> 78 Author: Stephen Paul Weber <singpolyma@singpolyma.net>
90 Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> 79 Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net>
@@ -108,15 +97,11 @@ Description: Implementation of the OpenPGP message format
108 and then defines instances of Data.Binary for each to facilitate 97 and then defines instances of Data.Binary for each to facilitate
109 encoding/decoding. 98 encoding/decoding.
110 . 99 .
111 There is also a wrapper around <http://hackage.haskell.org/package/Crypto> 100 For performing cryptography, see <http://hackage.haskell.org/openpgp-Crypto>
112 that currently does fingerprint generation, signature generation, and
113 signature verification (for RSA keys only).
114 . 101 .
115 It is intended that you use qualified imports with this library. If importing 102 It is intended that you use qualified imports with this library.
116 both modules, something like this will do:
117 . 103 .
118 > import qualified Data.OpenPGP as OpenPGP 104 > import qualified Data.OpenPGP as OpenPGP
119 > import qualified Data.OpenPGP.Crypto as OpenPGP
120 . 105 .
121 Author: Stephen Paul Weber <singpolyma@singpolyma.net> 106 Author: Stephen Paul Weber <singpolyma@singpolyma.net>
122 Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> 107 Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net>