diff options
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 6 | ||||
-rw-r--r-- | debian/compat | 1 | ||||
-rw-r--r-- | debian/control | 124 | ||||
-rw-r--r-- | debian/copyright | 13 | ||||
-rwxr-xr-x | debian/rules | 7 |
5 files changed, 151 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog new file mode 100644 index 0000000..31d5882 --- /dev/null +++ b/debian/changelog | |||
@@ -0,0 +1,6 @@ | |||
1 | haskell-openpgp (0.3-1~hackage1) unstable; urgency=low | ||
2 | |||
3 | * Debianization generated by cabal-debian | ||
4 | |||
5 | -- Stephen Paul Weber <singpolyma@singpolyma.net> Sun, 15 Apr 2012 12:22:30 -0500 | ||
6 | |||
diff --git a/debian/compat b/debian/compat new file mode 100644 index 0000000..c793025 --- /dev/null +++ b/debian/compat | |||
@@ -0,0 +1 @@ | |||
7 \ No newline at end of file | |||
diff --git a/debian/control b/debian/control new file mode 100644 index 0000000..a4b9165 --- /dev/null +++ b/debian/control | |||
@@ -0,0 +1,124 @@ | |||
1 | Source: haskell-openpgp | ||
2 | Priority: extra | ||
3 | Section: haskell | ||
4 | Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
5 | Build-Depends: debhelper (>= 7.0), | ||
6 | haskell-devscripts (>= 0.8), | ||
7 | cdbs, | ||
8 | ghc, | ||
9 | ghc-prof, | ||
10 | libghc-crypto-dev, | ||
11 | libghc-crypto-prof, | ||
12 | libghc-binary-dev, | ||
13 | libghc-binary-prof, | ||
14 | libghc-bzlib-dev, | ||
15 | libghc-bzlib-prof, | ||
16 | libghc-utf8-string-dev, | ||
17 | libghc-utf8-string-prof, | ||
18 | libghc-zlib-dev, | ||
19 | libghc-zlib-prof | ||
20 | Build-Depends-Indep: ghc-doc, | ||
21 | libghc-crypto-doc, | ||
22 | libghc-binary-doc, | ||
23 | libghc-bzlib-doc, | ||
24 | libghc-utf8-string-doc, | ||
25 | libghc-zlib-doc | ||
26 | Standards-Version: 3.9.1 | ||
27 | Homepage: http://github.com/singpolyma/OpenPGP-Haskell | ||
28 | |||
29 | Package: libghc-openpgp-dev | ||
30 | Architecture: any | ||
31 | Depends: ${shlibs:Depends}, | ||
32 | ${haskell:Depends}, | ||
33 | ${misc:Depends} | ||
34 | Recommends: ${haskell:Recommends} | ||
35 | Suggests: ${haskell:Suggests} | ||
36 | Provides: ${haskell:Provides} | ||
37 | Description: Implementation of the OpenPGP message format | ||
38 | This is an OpenPGP library inspired by my work on OpenPGP libraries in | ||
39 | Ruby <https://github.com/singpolyma/openpgp>, | ||
40 | PHP <http://github.com/singpolyma/openpgp-php>, | ||
41 | and Python <https://github.com/singpolyma/OpenPGP-Python>. | ||
42 | . | ||
43 | It defines types to represent OpenPGP messages as a series of packets | ||
44 | and then defines instances of Data.Binary for each to facilitate | ||
45 | encoding/decoding. | ||
46 | . | ||
47 | There is also a wrapper around <http://hackage.haskell.org/package/Crypto> | ||
48 | that currently does fingerprint generation, signature generation, and | ||
49 | signature verification (for RSA keys only). | ||
50 | . | ||
51 | It is intended that you use qualified imports with this library. If importing | ||
52 | both modules, something like this will do: | ||
53 | . | ||
54 | > import qualified Data.OpenPGP as OpenPGP | ||
55 | > import qualified Data.OpenPGP.Crypto as OpenPGP | ||
56 | . | ||
57 | Author: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
58 | Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
59 | . | ||
60 | This package contains the normal library files. | ||
61 | |||
62 | Package: libghc-openpgp-prof | ||
63 | Architecture: any | ||
64 | Depends: ${haskell:Depends}, | ||
65 | ${misc:Depends} | ||
66 | Recommends: ${haskell:Recommends} | ||
67 | Suggests: ${haskell:Suggests} | ||
68 | Provides: ${haskell:Provides} | ||
69 | Description: Implementation of the OpenPGP message format | ||
70 | This is an OpenPGP library inspired by my work on OpenPGP libraries in | ||
71 | Ruby <https://github.com/singpolyma/openpgp>, | ||
72 | PHP <http://github.com/singpolyma/openpgp-php>, | ||
73 | and Python <https://github.com/singpolyma/OpenPGP-Python>. | ||
74 | . | ||
75 | It defines types to represent OpenPGP messages as a series of packets | ||
76 | and then defines instances of Data.Binary for each to facilitate | ||
77 | encoding/decoding. | ||
78 | . | ||
79 | There is also a wrapper around <http://hackage.haskell.org/package/Crypto> | ||
80 | that currently does fingerprint generation, signature generation, and | ||
81 | signature verification (for RSA keys only). | ||
82 | . | ||
83 | It is intended that you use qualified imports with this library. If importing | ||
84 | both modules, something like this will do: | ||
85 | . | ||
86 | > import qualified Data.OpenPGP as OpenPGP | ||
87 | > import qualified Data.OpenPGP.Crypto as OpenPGP | ||
88 | . | ||
89 | Author: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
90 | Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
91 | . | ||
92 | This package contains the libraries compiled with profiling enabled. | ||
93 | |||
94 | Package: libghc-openpgp-doc | ||
95 | Architecture: all | ||
96 | Section: doc | ||
97 | Depends: ${haskell:Depends}, | ||
98 | ${misc:Depends} | ||
99 | Recommends: ${haskell:Recommends} | ||
100 | Suggests: ${haskell:Suggests} | ||
101 | Description: Implementation of the OpenPGP message format | ||
102 | This is an OpenPGP library inspired by my work on OpenPGP libraries in | ||
103 | Ruby <https://github.com/singpolyma/openpgp>, | ||
104 | PHP <http://github.com/singpolyma/openpgp-php>, | ||
105 | and Python <https://github.com/singpolyma/OpenPGP-Python>. | ||
106 | . | ||
107 | It defines types to represent OpenPGP messages as a series of packets | ||
108 | and then defines instances of Data.Binary for each to facilitate | ||
109 | encoding/decoding. | ||
110 | . | ||
111 | There is also a wrapper around <http://hackage.haskell.org/package/Crypto> | ||
112 | that currently does fingerprint generation, signature generation, and | ||
113 | signature verification (for RSA keys only). | ||
114 | . | ||
115 | It is intended that you use qualified imports with this library. If importing | ||
116 | both modules, something like this will do: | ||
117 | . | ||
118 | > import qualified Data.OpenPGP as OpenPGP | ||
119 | > import qualified Data.OpenPGP.Crypto as OpenPGP | ||
120 | . | ||
121 | Author: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
122 | Upstream-Maintainer: Stephen Paul Weber <singpolyma@singpolyma.net> | ||
123 | . | ||
124 | This package contains the documentation files. | ||
diff --git a/debian/copyright b/debian/copyright new file mode 100644 index 0000000..55234e7 --- /dev/null +++ b/debian/copyright | |||
@@ -0,0 +1,13 @@ | |||
1 | Copyright © 2011, Stephen Paul Weber <singpolyma.net> | ||
2 | |||
3 | Permission to use, copy, modify, and/or distribute this software for any | ||
4 | purpose with or without fee is hereby granted, provided that the above | ||
5 | copyright notice and this permission notice appear in all copies. | ||
6 | |||
7 | THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES | ||
8 | WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF | ||
9 | MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR | ||
10 | ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES | ||
11 | WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN | ||
12 | ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF | ||
13 | OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | ||
diff --git a/debian/rules b/debian/rules new file mode 100755 index 0000000..cc204b3 --- /dev/null +++ b/debian/rules | |||
@@ -0,0 +1,7 @@ | |||
1 | #!/usr/bin/make -f | ||
2 | include /usr/share/cdbs/1/rules/debhelper.mk | ||
3 | include /usr/share/cdbs/1/class/hlibrary.mk | ||
4 | |||
5 | # How to install an extra file into the documentation package | ||
6 | #binary-fixup/libghc-openpgp-doc:: | ||
7 | # echo "Some informative text" > debian/libghc-openpgp-doc/usr/share/doc/libghc-openpgp-doc/AnExtraDocFile | ||