summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-06-05 06:41:44 +0100
committerColin Watson <cjwatson@debian.org>2019-06-05 06:41:44 +0100
commit102062f825fb26a74295a1c089c00c4c4c76b68a (patch)
tree3db66bc8c8483cce66516dff36f6ef56065143d9 /configure.ac
parent3d246f10429fc9a37b98eabef94fe8dc7c61002b (diff)
parentfd0fa130ecf06d7d092932adcd5d77f1549bfc8d (diff)
Import openssh_8.0p1.orig.tar.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac284
1 files changed, 112 insertions, 172 deletions
diff --git a/configure.ac b/configure.ac
index 7379ab358..30be6c182 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,7 @@ AC_CONFIG_SRCDIR([ssh.c])
19AC_LANG([C]) 19AC_LANG([C])
20 20
21AC_CONFIG_HEADER([config.h]) 21AC_CONFIG_HEADER([config.h])
22AC_PROG_CC 22AC_PROG_CC([cc gcc])
23AC_CANONICAL_HOST 23AC_CANONICAL_HOST
24AC_C_BIGENDIAN 24AC_C_BIGENDIAN
25 25
@@ -285,10 +285,11 @@ AC_ARG_WITH([rpath],
285 [ --without-rpath Disable auto-added -R linker paths], 285 [ --without-rpath Disable auto-added -R linker paths],
286 [ 286 [
287 if test "x$withval" = "xno" ; then 287 if test "x$withval" = "xno" ; then
288 need_dash_r="" 288 rpath_opt=""
289 fi 289 elif test "x$withval" = "xyes" ; then
290 if test "x$withval" = "xyes" ; then 290 rpath_opt="-R"
291 need_dash_r=1 291 else
292 rpath_opt="$withval"
292 fi 293 fi
293 ] 294 ]
294) 295)
@@ -911,7 +912,7 @@ mips-sony-bsd|mips-sony-newsos4)
911*-*-netbsd*) 912*-*-netbsd*)
912 check_for_libcrypt_before=1 913 check_for_libcrypt_before=1
913 if test "x$withval" != "xno" ; then 914 if test "x$withval" != "xno" ; then
914 need_dash_r=1 915 rpath_opt="-R"
915 fi 916 fi
916 CPPFLAGS="$CPPFLAGS -D_OPENBSD_SOURCE" 917 CPPFLAGS="$CPPFLAGS -D_OPENBSD_SOURCE"
917 AC_DEFINE([SSH_TUN_FREEBSD], [1], [Open tunnel devices the FreeBSD way]) 918 AC_DEFINE([SSH_TUN_FREEBSD], [1], [Open tunnel devices the FreeBSD way])
@@ -962,7 +963,7 @@ mips-sony-bsd|mips-sony-newsos4)
962 ;; 963 ;;
963*-*-solaris*) 964*-*-solaris*)
964 if test "x$withval" != "xno" ; then 965 if test "x$withval" != "xno" ; then
965 need_dash_r=1 966 rpath_opt="-R"
966 fi 967 fi
967 AC_DEFINE([PAM_SUN_CODEBASE]) 968 AC_DEFINE([PAM_SUN_CODEBASE])
968 AC_DEFINE([LOGIN_NEEDS_UTMPX]) 969 AC_DEFINE([LOGIN_NEEDS_UTMPX])
@@ -1263,14 +1264,14 @@ AC_ARG_WITH([zlib],
1263 AC_MSG_ERROR([*** zlib is required ***]) 1264 AC_MSG_ERROR([*** zlib is required ***])
1264 elif test "x$withval" != "xyes"; then 1265 elif test "x$withval" != "xyes"; then
1265 if test -d "$withval/lib"; then 1266 if test -d "$withval/lib"; then
1266 if test -n "${need_dash_r}"; then 1267 if test -n "${rpath_opt}"; then
1267 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" 1268 LDFLAGS="-L${withval}/lib ${rpath_opt}${withval}/lib ${LDFLAGS}"
1268 else 1269 else
1269 LDFLAGS="-L${withval}/lib ${LDFLAGS}" 1270 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1270 fi 1271 fi
1271 else 1272 else
1272 if test -n "${need_dash_r}"; then 1273 if test -n "${rpath_opt}"; then
1273 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}" 1274 LDFLAGS="-L${withval} ${rpath_opt}${withval} ${LDFLAGS}"
1274 else 1275 else
1275 LDFLAGS="-L${withval} ${LDFLAGS}" 1276 LDFLAGS="-L${withval} ${LDFLAGS}"
1276 fi 1277 fi
@@ -1290,8 +1291,8 @@ AC_CHECK_LIB([z], [deflate], ,
1290 saved_LDFLAGS="$LDFLAGS" 1291 saved_LDFLAGS="$LDFLAGS"
1291 save_LIBS="$LIBS" 1292 save_LIBS="$LIBS"
1292 dnl Check default zlib install dir 1293 dnl Check default zlib install dir
1293 if test -n "${need_dash_r}"; then 1294 if test -n "${rpath_opt}"; then
1294 LDFLAGS="-L/usr/local/lib -R/usr/local/lib ${saved_LDFLAGS}" 1295 LDFLAGS="-L/usr/local/lib ${rpath_opt}/usr/local/lib ${saved_LDFLAGS}"
1295 else 1296 else
1296 LDFLAGS="-L/usr/local/lib ${saved_LDFLAGS}" 1297 LDFLAGS="-L/usr/local/lib ${saved_LDFLAGS}"
1297 fi 1298 fi
@@ -1558,8 +1559,8 @@ AC_ARG_WITH([libedit],
1558 fi 1559 fi
1559 else 1560 else
1560 CPPFLAGS="$CPPFLAGS -I${withval}/include" 1561 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1561 if test -n "${need_dash_r}"; then 1562 if test -n "${rpath_opt}"; then
1562 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" 1563 LDFLAGS="-L${withval}/lib ${rpath_opt}${withval}/lib ${LDFLAGS}"
1563 else 1564 else
1564 LDFLAGS="-L${withval}/lib ${LDFLAGS}" 1565 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1565 fi 1566 fi
@@ -1719,7 +1720,9 @@ AC_CHECK_FUNCS([ \
1719 errx \ 1720 errx \
1720 explicit_bzero \ 1721 explicit_bzero \
1721 fchmod \ 1722 fchmod \
1723 fchmodat \
1722 fchown \ 1724 fchown \
1725 fchownat \
1723 flock \ 1726 flock \
1724 freeaddrinfo \ 1727 freeaddrinfo \
1725 freezero \ 1728 freezero \
@@ -1812,6 +1815,7 @@ AC_CHECK_FUNCS([ \
1812 truncate \ 1815 truncate \
1813 unsetenv \ 1816 unsetenv \
1814 updwtmpx \ 1817 updwtmpx \
1818 utimensat \
1815 user_from_uid \ 1819 user_from_uid \
1816 usleep \ 1820 usleep \
1817 vasprintf \ 1821 vasprintf \
@@ -2476,20 +2480,20 @@ AC_ARG_WITH([ssl-dir],
2476 ./*|../*) withval="`pwd`/$withval" 2480 ./*|../*) withval="`pwd`/$withval"
2477 esac 2481 esac
2478 if test -d "$withval/lib"; then 2482 if test -d "$withval/lib"; then
2479 if test -n "${need_dash_r}"; then 2483 if test -n "${rpath_opt}"; then
2480 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" 2484 LDFLAGS="-L${withval}/lib ${rpath_opt}${withval}/lib ${LDFLAGS}"
2481 else 2485 else
2482 LDFLAGS="-L${withval}/lib ${LDFLAGS}" 2486 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
2483 fi 2487 fi
2484 elif test -d "$withval/lib64"; then 2488 elif test -d "$withval/lib64"; then
2485 if test -n "${need_dash_r}"; then 2489 if test -n "${rpath_opt}"; then
2486 LDFLAGS="-L${withval}/lib64 -R${withval}/lib64 ${LDFLAGS}" 2490 LDFLAGS="-L${withval}/lib64 ${rpath_opt}${withval}/lib64 ${LDFLAGS}"
2487 else 2491 else
2488 LDFLAGS="-L${withval}/lib64 ${LDFLAGS}" 2492 LDFLAGS="-L${withval}/lib64 ${LDFLAGS}"
2489 fi 2493 fi
2490 else 2494 else
2491 if test -n "${need_dash_r}"; then 2495 if test -n "${rpath_opt}"; then
2492 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}" 2496 LDFLAGS="-L${withval} ${rpath_opt}${withval} ${LDFLAGS}"
2493 else 2497 else
2494 LDFLAGS="-L${withval} ${LDFLAGS}" 2498 LDFLAGS="-L${withval} ${LDFLAGS}"
2495 fi 2499 fi
@@ -2527,26 +2531,10 @@ AC_ARG_WITH([ssl-engine],
2527 2531
2528if test "x$openssl" = "xyes" ; then 2532if test "x$openssl" = "xyes" ; then
2529 LIBS="-lcrypto $LIBS" 2533 LIBS="-lcrypto $LIBS"
2530 AC_TRY_LINK_FUNC([RAND_add], [AC_DEFINE([HAVE_OPENSSL], [1], 2534 AC_TRY_LINK_FUNC([RAND_add], ,
2531 [Define if your ssl headers are included 2535 [AC_MSG_ERROR([*** working libcrypto not found, check config.log])])
2532 with #include <openssl/header.h>])], 2536 AC_CHECK_HEADER([openssl/opensslv.h], ,
2533 [ 2537 [AC_MSG_ERROR([*** OpenSSL headers missing - please install first or check config.log ***])])
2534 dnl Check default openssl install dir
2535 if test -n "${need_dash_r}"; then
2536 LDFLAGS="-L/usr/local/ssl/lib -R/usr/local/ssl/lib ${saved_LDFLAGS}"
2537 else
2538 LDFLAGS="-L/usr/local/ssl/lib ${saved_LDFLAGS}"
2539 fi
2540 CPPFLAGS="-I/usr/local/ssl/include ${saved_CPPFLAGS}"
2541 AC_CHECK_HEADER([openssl/opensslv.h], ,
2542 [AC_MSG_ERROR([*** OpenSSL headers missing - please install first or check config.log ***])])
2543 AC_TRY_LINK_FUNC([RAND_add], [AC_DEFINE([HAVE_OPENSSL])],
2544 [
2545 AC_MSG_ERROR([*** Can't find recent OpenSSL libcrypto (see config.log for details) ***])
2546 ]
2547 )
2548 ]
2549 )
2550 2538
2551 # Determine OpenSSL header version 2539 # Determine OpenSSL header version
2552 AC_MSG_CHECKING([OpenSSL header version]) 2540 AC_MSG_CHECKING([OpenSSL header version])
@@ -2585,6 +2573,9 @@ if test "x$openssl" = "xyes" ; then
2585 ] 2573 ]
2586 ) 2574 )
2587 2575
2576 # Determining OpenSSL library version is version dependent.
2577 AC_CHECK_FUNCS([OpenSSL_version OpenSSL_version_num])
2578
2588 # Determine OpenSSL library version 2579 # Determine OpenSSL library version
2589 AC_MSG_CHECKING([OpenSSL library version]) 2580 AC_MSG_CHECKING([OpenSSL library version])
2590 AC_RUN_IFELSE( 2581 AC_RUN_IFELSE(
@@ -2601,9 +2592,18 @@ if test "x$openssl" = "xyes" ; then
2601 fd = fopen(DATA,"w"); 2592 fd = fopen(DATA,"w");
2602 if(fd == NULL) 2593 if(fd == NULL)
2603 exit(1); 2594 exit(1);
2604 2595#ifndef OPENSSL_VERSION
2605 if ((rc = fprintf(fd, "%08lx (%s)\n", (unsigned long)SSLeay(), 2596# define OPENSSL_VERSION SSLEAY_VERSION
2606 SSLeay_version(SSLEAY_VERSION))) < 0) 2597#endif
2598#ifndef HAVE_OPENSSL_VERSION
2599# define OpenSSL_version SSLeay_version
2600#endif
2601#ifndef HAVE_OPENSSL_VERSION_NUM
2602# define OpenSSL_version_num SSLeay
2603#endif
2604 if ((rc = fprintf(fd, "%08lx (%s)\n",
2605 (unsigned long)OpenSSL_version_num(),
2606 OpenSSL_version(OPENSSL_VERSION))) < 0)
2607 exit(1); 2607 exit(1);
2608 2608
2609 exit(0); 2609 exit(0);
@@ -2616,14 +2616,15 @@ if test "x$openssl" = "xyes" ; then
2616 AC_MSG_ERROR([OpenSSL >= 1.0.1 required (have "$ssl_library_ver")]) 2616 AC_MSG_ERROR([OpenSSL >= 1.0.1 required (have "$ssl_library_ver")])
2617 ;; 2617 ;;
2618 100*) ;; # 1.0.x 2618 100*) ;; # 1.0.x
2619 101000[0123456]*) 2619 101000[[0123456]]*)
2620 # https://github.com/openssl/openssl/pull/4613 2620 # https://github.com/openssl/openssl/pull/4613
2621 AC_MSG_ERROR([OpenSSL 1.1.x versions prior to 1.1.0g have a bug that breaks their use with OpenSSH (have "$ssl_library_ver")]) 2621 AC_MSG_ERROR([OpenSSL 1.1.x versions prior to 1.1.0g have a bug that breaks their use with OpenSSH (have "$ssl_library_ver")])
2622 ;; 2622 ;;
2623 101*) ;; # 1.1.x 2623 101*) ;; # 1.1.x
2624 200*) ;; # LibreSSL 2624 200*) ;; # LibreSSL
2625 300*) ;; # OpenSSL development branch.
2625 *) 2626 *)
2626 AC_MSG_ERROR([OpenSSL > 1.1.x is not yet supported (have "$ssl_library_ver")]) 2627 AC_MSG_ERROR([Unknown/unsupported OpenSSL version ("$ssl_library_ver")])
2627 ;; 2628 ;;
2628 esac 2629 esac
2629 AC_MSG_RESULT([$ssl_library_ver]) 2630 AC_MSG_RESULT([$ssl_library_ver])
@@ -2645,7 +2646,10 @@ if test "x$openssl" = "xyes" ; then
2645 #include <openssl/opensslv.h> 2646 #include <openssl/opensslv.h>
2646 #include <openssl/crypto.h> 2647 #include <openssl/crypto.h>
2647 ]], [[ 2648 ]], [[
2648 exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); 2649#ifndef HAVE_OPENSSL_VERSION_NUM
2650# define OpenSSL_version_num SSLeay
2651#endif
2652 exit(OpenSSL_version_num() == OPENSSL_VERSION_NUMBER ? 0 : 1);
2649 ]])], 2653 ]])],
2650 [ 2654 [
2651 AC_MSG_RESULT([yes]) 2655 AC_MSG_RESULT([yes])
@@ -2672,8 +2676,8 @@ if test "x$openssl" = "xyes" ; then
2672 2676
2673 AC_MSG_CHECKING([if programs using OpenSSL functions will link]) 2677 AC_MSG_CHECKING([if programs using OpenSSL functions will link])
2674 AC_LINK_IFELSE( 2678 AC_LINK_IFELSE(
2675 [AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]], 2679 [AC_LANG_PROGRAM([[ #include <openssl/err.h> ]],
2676 [[ SSLeay_add_all_algorithms(); ]])], 2680 [[ ERR_load_crypto_strings(); ]])],
2677 [ 2681 [
2678 AC_MSG_RESULT([yes]) 2682 AC_MSG_RESULT([yes])
2679 ], 2683 ],
@@ -2683,8 +2687,8 @@ if test "x$openssl" = "xyes" ; then
2683 LIBS="$LIBS -ldl" 2687 LIBS="$LIBS -ldl"
2684 AC_MSG_CHECKING([if programs using OpenSSL need -ldl]) 2688 AC_MSG_CHECKING([if programs using OpenSSL need -ldl])
2685 AC_LINK_IFELSE( 2689 AC_LINK_IFELSE(
2686 [AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]], 2690 [AC_LANG_PROGRAM([[ #include <openssl/err.h> ]],
2687 [[ SSLeay_add_all_algorithms(); ]])], 2691 [[ ERR_load_crypto_strings(); ]])],
2688 [ 2692 [
2689 AC_MSG_RESULT([yes]) 2693 AC_MSG_RESULT([yes])
2690 ], 2694 ],
@@ -2699,16 +2703,64 @@ if test "x$openssl" = "xyes" ; then
2699 AC_CHECK_FUNCS([ \ 2703 AC_CHECK_FUNCS([ \
2700 BN_is_prime_ex \ 2704 BN_is_prime_ex \
2701 DSA_generate_parameters_ex \ 2705 DSA_generate_parameters_ex \
2702 EVP_DigestInit_ex \ 2706 EVP_CIPHER_CTX_ctrl \
2703 EVP_DigestFinal_ex \ 2707 EVP_DigestFinal_ex \
2704 EVP_MD_CTX_init \ 2708 EVP_DigestInit_ex \
2705 EVP_MD_CTX_cleanup \ 2709 EVP_MD_CTX_cleanup \
2706 EVP_MD_CTX_copy_ex \ 2710 EVP_MD_CTX_copy_ex \
2711 EVP_MD_CTX_init \
2707 HMAC_CTX_init \ 2712 HMAC_CTX_init \
2708 RSA_generate_key_ex \ 2713 RSA_generate_key_ex \
2709 RSA_get_default_method \ 2714 RSA_get_default_method \
2710 ]) 2715 ])
2711 2716
2717 # OpenSSL_add_all_algorithms may be a macro.
2718 AC_CHECK_FUNC(OpenSSL_add_all_algorithms,
2719 AC_DEFINE(HAVE_OPENSSL_ADD_ALL_ALGORITHMS, 1, [as a function]),
2720 AC_CHECK_DECL(OpenSSL_add_all_algorithms,
2721 AC_DEFINE(HAVE_OPENSSL_ADD_ALL_ALGORITHMS, 1, [as a macro]), ,
2722 [[#include <openssl/evp.h>]]
2723 )
2724 )
2725
2726 # LibreSSL/OpenSSL 1.1x API
2727 AC_CHECK_FUNCS([ \
2728 OPENSSL_init_crypto \
2729 DH_get0_key \
2730 DH_get0_pqg \
2731 DH_set0_key \
2732 DH_set_length \
2733 DH_set0_pqg \
2734 DSA_get0_key \
2735 DSA_get0_pqg \
2736 DSA_set0_key \
2737 DSA_set0_pqg \
2738 DSA_SIG_get0 \
2739 DSA_SIG_set0 \
2740 ECDSA_SIG_get0 \
2741 ECDSA_SIG_set0 \
2742 EVP_CIPHER_CTX_iv \
2743 EVP_CIPHER_CTX_iv_noconst \
2744 EVP_CIPHER_CTX_get_iv \
2745 EVP_CIPHER_CTX_set_iv \
2746 RSA_get0_crt_params \
2747 RSA_get0_factors \
2748 RSA_get0_key \
2749 RSA_set0_crt_params \
2750 RSA_set0_factors \
2751 RSA_set0_key \
2752 RSA_meth_free \
2753 RSA_meth_dup \
2754 RSA_meth_set1_name \
2755 RSA_meth_get_finish \
2756 RSA_meth_set_priv_enc \
2757 RSA_meth_set_priv_dec \
2758 RSA_meth_set_finish \
2759 EVP_PKEY_get0_RSA \
2760 EVP_MD_CTX_new \
2761 EVP_MD_CTX_free \
2762 ])
2763
2712 if test "x$openssl_engine" = "xyes" ; then 2764 if test "x$openssl_engine" = "xyes" ; then
2713 AC_MSG_CHECKING([for OpenSSL ENGINE support]) 2765 AC_MSG_CHECKING([for OpenSSL ENGINE support])
2714 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ 2766 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
@@ -2792,119 +2844,6 @@ if test "x$openssl" = "xyes" ; then
2792 ] 2844 ]
2793 ) 2845 )
2794 2846
2795 AC_SEARCH_LIBS([EVP_CIPHER_CTX_ctrl], [crypto],
2796 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_CTRL], [1],
2797 [Define if libcrypto has EVP_CIPHER_CTX_ctrl])])
2798
2799 # LibreSSL/OpenSSL 1.1x API
2800 AC_SEARCH_LIBS([DH_get0_key], [crypto],
2801 [AC_DEFINE([HAVE_DH_GET0_KEY], [1],
2802 [Define if libcrypto has DH_get0_key])])
2803 AC_SEARCH_LIBS([DH_get0_pqg], [crypto],
2804 [AC_DEFINE([HAVE_DH_GET0_PQG], [1],
2805 [Define if libcrypto has DH_get0_pqg])])
2806 AC_SEARCH_LIBS([DH_set0_key], [crypto],
2807 [AC_DEFINE([HAVE_DH_SET0_KEY], [1],
2808 [Define if libcrypto has DH_set0_key])])
2809 AC_SEARCH_LIBS([DH_set_length], [crypto],
2810 [AC_DEFINE([HAVE_DH_SET_LENGTH], [1],
2811 [Define if libcrypto has DH_set_length])])
2812 AC_SEARCH_LIBS([DH_set0_pqg], [crypto],
2813 [AC_DEFINE([HAVE_DH_SET0_PQG], [1],
2814 [Define if libcrypto has DH_set0_pqg])])
2815
2816 AC_SEARCH_LIBS([DSA_get0_key], [crypto],
2817 [AC_DEFINE([HAVE_DSA_GET0_KEY], [1],
2818 [Define if libcrypto has DSA_get0_key])])
2819 AC_SEARCH_LIBS([DSA_get0_pqg], [crypto],
2820 [AC_DEFINE([HAVE_DSA_GET0_PQG], [1],
2821 [Define if libcrypto has DSA_get0_pqg])])
2822 AC_SEARCH_LIBS([DSA_set0_key], [crypto],
2823 [AC_DEFINE([HAVE_DSA_SET0_KEY], [1],
2824 [Define if libcrypto has DSA_set0_key])])
2825 AC_SEARCH_LIBS([DSA_set0_pqg], [crypto],
2826 [AC_DEFINE([HAVE_DSA_SET0_PQG], [1],
2827 [Define if libcrypto has DSA_set0_pqg])])
2828
2829 AC_SEARCH_LIBS([DSA_SIG_get0], [crypto],
2830 [AC_DEFINE([HAVE_DSA_SIG_GET0], [1],
2831 [Define if libcrypto has DSA_SIG_get0])])
2832 AC_SEARCH_LIBS([DSA_SIG_set0], [crypto],
2833 [AC_DEFINE([HAVE_DSA_SIG_SET0], [1],
2834 [Define if libcrypto has DSA_SIG_set0])])
2835
2836 AC_SEARCH_LIBS([ECDSA_SIG_get0], [crypto],
2837 [AC_DEFINE([HAVE_ECDSA_SIG_GET0], [1],
2838 [Define if libcrypto has ECDSA_SIG_get0])])
2839 AC_SEARCH_LIBS([ECDSA_SIG_set0], [crypto],
2840 [AC_DEFINE([HAVE_ECDSA_SIG_SET0], [1],
2841 [Define if libcrypto has ECDSA_SIG_set0])])
2842
2843 AC_SEARCH_LIBS([EVP_CIPHER_CTX_iv], [crypto],
2844 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_IV], [1],
2845 [Define if libcrypto has EVP_CIPHER_CTX_iv])])
2846 AC_SEARCH_LIBS([EVP_CIPHER_CTX_iv_noconst], [crypto],
2847 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_IV_NOCONST], [1],
2848 [Define if libcrypto has EVP_CIPHER_CTX_iv_noconst])])
2849 AC_SEARCH_LIBS([EVP_CIPHER_CTX_get_iv], [crypto],
2850 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_GET_IV], [1],
2851 [Define if libcrypto has EVP_CIPHER_CTX_get_iv])])
2852 AC_SEARCH_LIBS([EVP_CIPHER_CTX_set_iv], [crypto],
2853 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_GET_IV], [1],
2854 [Define if libcrypto has EVP_CIPHER_CTX_set_iv])])
2855
2856 AC_SEARCH_LIBS([RSA_get0_crt_params], [crypto],
2857 [AC_DEFINE([HAVE_RSA_GET0_CRT_PARAMS], [1],
2858 [Define if libcrypto has RSA_get0_crt_params])])
2859 AC_SEARCH_LIBS([RSA_get0_factors], [crypto],
2860 [AC_DEFINE([HAVE_RSA_GET0_FACTORS], [1],
2861 [Define if libcrypto has RSA_get0_factors])])
2862 AC_SEARCH_LIBS([RSA_get0_key], [crypto],
2863 [AC_DEFINE([HAVE_RSA_GET0_KEY], [1],
2864 [Define if libcrypto has RSA_get0_key])])
2865 AC_SEARCH_LIBS([RSA_set0_crt_params], [crypto],
2866 [AC_DEFINE([HAVE_RSA_SET0_CRT_PARAMS], [1],
2867 [Define if libcrypto has RSA_get0_srt_params])])
2868 AC_SEARCH_LIBS([RSA_set0_factors], [crypto],
2869 [AC_DEFINE([HAVE_RSA_SET0_FACTORS], [1],
2870 [Define if libcrypto has RSA_set0_factors])])
2871 AC_SEARCH_LIBS([RSA_set0_key], [crypto],
2872 [AC_DEFINE([HAVE_RSA_SET0_KEY], [1],
2873 [Define if libcrypto has RSA_set0_key])])
2874
2875 AC_SEARCH_LIBS([RSA_meth_free], [crypto],
2876 [AC_DEFINE([HAVE_RSA_METH_FREE], [1],
2877 [Define if libcrypto has RSA_meth_free])])
2878 AC_SEARCH_LIBS([RSA_meth_dup], [crypto],
2879 [AC_DEFINE([HAVE_RSA_METH_DUP], [1],
2880 [Define if libcrypto has RSA_meth_dup])])
2881 AC_SEARCH_LIBS([RSA_meth_set1_name], [crypto],
2882 [AC_DEFINE([HAVE_RSA_METH_SET1_NAME], [1],
2883 [Define if libcrypto has RSA_meth_set1_name])])
2884 AC_SEARCH_LIBS([RSA_meth_get_finish], [crypto],
2885 [AC_DEFINE([HAVE_RSA_METH_GET_FINISH], [1],
2886 [Define if libcrypto has RSA_meth_get_finish])])
2887 AC_SEARCH_LIBS([RSA_meth_set_priv_enc], [crypto],
2888 [AC_DEFINE([HAVE_RSA_METH_SET_PRIV_ENC], [1],
2889 [Define if libcrypto has RSA_meth_set_priv_enc])])
2890 AC_SEARCH_LIBS([RSA_meth_set_priv_dec], [crypto],
2891 [AC_DEFINE([HAVE_RSA_METH_SET_PRIV_DEC], [1],
2892 [Define if libcrypto has RSA_meth_set_priv_dec])])
2893 AC_SEARCH_LIBS([RSA_meth_set_finish], [crypto],
2894 [AC_DEFINE([HAVE_RSA_METH_SET_FINISH], [1],
2895 [Define if libcrypto has RSA_meth_set_finish])])
2896
2897 AC_SEARCH_LIBS([EVP_PKEY_get0_RSA], [crypto],
2898 [AC_DEFINE([HAVE_EVP_PKEY_GET0_RSA], [1],
2899 [Define if libcrypto has EVP_PKEY_get0_RSA])])
2900
2901 AC_SEARCH_LIBS([EVP_MD_CTX_new], [crypto],
2902 [AC_DEFINE([HAVE_EVP_MD_CTX_NEW], [1],
2903 [Define if libcrypto has EVP_MD_CTX_new])])
2904 AC_SEARCH_LIBS([EVP_MD_CTX_free], [crypto],
2905 [AC_DEFINE([HAVE_EVP_MD_CTX_FREE], [1],
2906 [Define if libcrypto has EVP_MD_CTX_free])])
2907
2908 AC_MSG_CHECKING([if EVP_DigestUpdate returns an int]) 2847 AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2909 AC_LINK_IFELSE( 2848 AC_LINK_IFELSE(
2910 [AC_LANG_PROGRAM([[ 2849 [AC_LANG_PROGRAM([[
@@ -3036,6 +2975,7 @@ if test "x$openssl" = "xyes" ; then
3036 if test x$enable_nistp256 = x1 || test x$enable_nistp384 = x1 || \ 2975 if test x$enable_nistp256 = x1 || test x$enable_nistp384 = x1 || \
3037 test x$enable_nistp521 = x1; then 2976 test x$enable_nistp521 = x1; then
3038 AC_DEFINE(OPENSSL_HAS_ECC, [1], [OpenSSL has ECC]) 2977 AC_DEFINE(OPENSSL_HAS_ECC, [1], [OpenSSL has ECC])
2978 AC_CHECK_FUNCS([EC_KEY_METHOD_new])
3039 fi 2979 fi
3040 if test x$enable_nistp256 = x1; then 2980 if test x$enable_nistp256 = x1; then
3041 AC_DEFINE([OPENSSL_HAS_NISTP256], [1], 2981 AC_DEFINE([OPENSSL_HAS_NISTP256], [1],
@@ -3516,10 +3456,10 @@ fi
3516AC_CHECK_TYPES([long long, unsigned long long, long double]) 3456AC_CHECK_TYPES([long long, unsigned long long, long double])
3517 3457
3518# Check datatype sizes 3458# Check datatype sizes
3519AC_CHECK_SIZEOF([short int], [2]) 3459AC_CHECK_SIZEOF([short int])
3520AC_CHECK_SIZEOF([int], [4]) 3460AC_CHECK_SIZEOF([int])
3521AC_CHECK_SIZEOF([long int], [4]) 3461AC_CHECK_SIZEOF([long int])
3522AC_CHECK_SIZEOF([long long int], [8]) 3462AC_CHECK_SIZEOF([long long int])
3523 3463
3524# Sanity check long long for some platforms (AIX) 3464# Sanity check long long for some platforms (AIX)
3525if test "x$ac_cv_sizeof_long_long_int" = "x4" ; then 3465if test "x$ac_cv_sizeof_long_long_int" = "x4" ; then
@@ -4468,8 +4408,8 @@ AC_ARG_WITH([kerberos5],
4468 [ CPPFLAGS="$oldCPP" ]) 4408 [ CPPFLAGS="$oldCPP" ])
4469 4409
4470 fi 4410 fi
4471 if test ! -z "$need_dash_r" ; then 4411 if test -n "${rpath_opt}" ; then
4472 LDFLAGS="$LDFLAGS -R${KRB5ROOT}/lib" 4412 LDFLAGS="$LDFLAGS ${rpath_opt}${KRB5ROOT}/lib"
4473 fi 4413 fi
4474 if test ! -z "$blibpath" ; then 4414 if test ! -z "$blibpath" ; then
4475 blibpath="$blibpath:${KRB5ROOT}/lib" 4415 blibpath="$blibpath:${KRB5ROOT}/lib"