diff options
author | Ben Lindstrom <mouring@eviladmin.org> | 2003-03-21 00:51:35 +0000 |
---|---|---|
committer | Ben Lindstrom <mouring@eviladmin.org> | 2003-03-21 00:51:35 +0000 |
commit | 1182f654ee0ab474c40f28e6f10fa543194a973e (patch) | |
tree | 43d6fd0ede7e1113616ad93bdacad79c83e6381d /configure.ac | |
parent | 94de3b20db40dfa2ffbf51fb4757db11df493319 (diff) |
- (bal) The days of lack of int64_t support are over. Sorry kids.
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 17 |
1 files changed, 6 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac index 83575758f..6f4bdacc4 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.111 2003/03/18 18:21:41 tim Exp $ | 1 | # $Id: configure.ac,v 1.111.2.1 2003/03/21 00:51:35 mouring Exp $ |
2 | 2 | ||
3 | AC_INIT | 3 | AC_INIT |
4 | AC_CONFIG_SRCDIR([ssh.c]) | 4 | AC_CONFIG_SRCDIR([ssh.c]) |
@@ -1485,12 +1485,14 @@ fi | |||
1485 | 1485 | ||
1486 | AC_CHECK_TYPES(struct timespec) | 1486 | AC_CHECK_TYPES(struct timespec) |
1487 | 1487 | ||
1488 | # If we don't have int64_t then we can't compile sftp-server. So don't | 1488 | # We need int64_t or else certian parts of the compile will fail. |
1489 | # even attempt to do it. | ||
1490 | if test "x$ac_cv_have_int64_t" = "xno" -a \ | 1489 | if test "x$ac_cv_have_int64_t" = "xno" -a \ |
1491 | "x$ac_cv_sizeof_long_int" != "x8" -a \ | 1490 | "x$ac_cv_sizeof_long_int" != "x8" -a \ |
1492 | "x$ac_cv_sizeof_long_long_int" = "x0" ; then | 1491 | "x$ac_cv_sizeof_long_long_int" = "x0" ; then |
1493 | NO_SFTP='#' | 1492 | echo "OpenSSH requires int64_t support. Contact your vendor or install" |
1493 | echo "an alternative compiler (I.E., GCC) before continuing." | ||
1494 | echo "" | ||
1495 | exit 1; | ||
1494 | else | 1496 | else |
1495 | dnl test snprintf (broken on SCO w/gcc) | 1497 | dnl test snprintf (broken on SCO w/gcc) |
1496 | AC_TRY_RUN( | 1498 | AC_TRY_RUN( |
@@ -1520,7 +1522,6 @@ main() { exit(0); } | |||
1520 | ], [ true ], [ AC_DEFINE(BROKEN_SNPRINTF) ] | 1522 | ], [ true ], [ AC_DEFINE(BROKEN_SNPRINTF) ] |
1521 | ) | 1523 | ) |
1522 | fi | 1524 | fi |
1523 | AC_SUBST(NO_SFTP) | ||
1524 | 1525 | ||
1525 | dnl Checks for structure members | 1526 | dnl Checks for structure members |
1526 | OSSH_CHECK_HEADER_FOR_FIELD(ut_host, utmp.h, HAVE_HOST_IN_UTMP) | 1527 | OSSH_CHECK_HEADER_FOR_FIELD(ut_host, utmp.h, HAVE_HOST_IN_UTMP) |
@@ -2555,12 +2556,6 @@ if test "x$PAM_MSG" = "xyes" ; then | |||
2555 | echo "" | 2556 | echo "" |
2556 | fi | 2557 | fi |
2557 | 2558 | ||
2558 | if test ! -z "$NO_SFTP"; then | ||
2559 | echo "sftp-server will be disabled. Your compiler does not " | ||
2560 | echo "support 64bit integers." | ||
2561 | echo "" | ||
2562 | fi | ||
2563 | |||
2564 | if test ! -z "$RAND_HELPER_CMDHASH" ; then | 2559 | if test ! -z "$RAND_HELPER_CMDHASH" ; then |
2565 | echo "WARNING: you are using the builtin random number collection " | 2560 | echo "WARNING: you are using the builtin random number collection " |
2566 | echo "service. Please read WARNING.RNG and request that your OS " | 2561 | echo "service. Please read WARNING.RNG and request that your OS " |