summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-03-17 13:37:04 -0800
committerTim Rice <tim@multitalents.net>2005-03-17 13:37:04 -0800
commit12ee8e241eb38308be8c1e4dd57ac7d8c02f3297 (patch)
treece241c67181ab8a0df75cbebf72f61a709b4d595 /configure.ac
parentc3939e22fdcc9c22102b8d3d894f5885105a1a04 (diff)
- (tim) [configure.ac] Bug 998. Make path for --with-opensc optional.
Make --without-opensc work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 22 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index e48028b7b..c23094777 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.250 2005/03/07 09:21:37 tim Exp $ 1# $Id: configure.ac,v 1.251 2005/03/17 21:37:04 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -2324,23 +2324,28 @@ AC_ARG_WITH(sectok,
2324) 2324)
2325 2325
2326# Check whether user wants OpenSC support 2326# Check whether user wants OpenSC support
2327OPENSC_CONFIG="no"
2327AC_ARG_WITH(opensc, 2328AC_ARG_WITH(opensc,
2328 AC_HELP_STRING([--with-opensc=PFX], 2329 [--with-opensc[[=PFX]] Enable smartcard support using OpenSC (optionally in PATH)],
2329 [Enable smartcard support using OpenSC]), 2330 [
2330 opensc_config_prefix="$withval", opensc_config_prefix="") 2331 if test "x$withval" != "xno" ; then
2331if test x$opensc_config_prefix != x ; then 2332 if test "x$withval" != "xyes" ; then
2332 OPENSC_CONFIG=$opensc_config_prefix/bin/opensc-config 2333 OPENSC_CONFIG=$withval/bin/opensc-config
2333 AC_PATH_PROG(OPENSC_CONFIG, opensc-config, no) 2334 else
2334 if test "$OPENSC_CONFIG" != "no"; then 2335 AC_PATH_PROG(OPENSC_CONFIG, opensc-config, no)
2335 LIBOPENSC_CFLAGS=`$OPENSC_CONFIG --cflags` 2336 fi
2336 LIBOPENSC_LIBS=`$OPENSC_CONFIG --libs` 2337 if test "$OPENSC_CONFIG" != "no"; then
2337 CPPFLAGS="$CPPFLAGS $LIBOPENSC_CFLAGS" 2338 LIBOPENSC_CFLAGS=`$OPENSC_CONFIG --cflags`
2338 LDFLAGS="$LDFLAGS $LIBOPENSC_LIBS" 2339 LIBOPENSC_LIBS=`$OPENSC_CONFIG --libs`
2339 AC_DEFINE(SMARTCARD) 2340 CPPFLAGS="$CPPFLAGS $LIBOPENSC_CFLAGS"
2340 AC_DEFINE(USE_OPENSC) 2341 LDFLAGS="$LDFLAGS $LIBOPENSC_LIBS"
2341 SCARD_MSG="yes, using OpenSC" 2342 AC_DEFINE(SMARTCARD)
2342 fi 2343 AC_DEFINE(USE_OPENSC)
2343fi 2344 SCARD_MSG="yes, using OpenSC"
2345 fi
2346 fi
2347 ]
2348)
2344 2349
2345# Check libraries needed by DNS fingerprint support 2350# Check libraries needed by DNS fingerprint support
2346AC_SEARCH_LIBS(getrrsetbyname, resolv, 2351AC_SEARCH_LIBS(getrrsetbyname, resolv,