summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-11-08 15:03:11 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-11-08 15:03:11 +1100
commit1801cd11d99d05a66ab5248c0555f55909a355ce (patch)
tree8df37e8fafc0c86cf095d15a3f269ae53995149d /configure.ac
parentbc32f118d484e4d71d2a0828fd4eab7e4176c9af (diff)
Simplify OpenSSL 1.1 function checks.
Replace AC_SEARCH_LIBS checks for OpenSSL 1.1 functions with a single AC_CHECK_FUNCS. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac150
1 files changed, 37 insertions, 113 deletions
diff --git a/configure.ac b/configure.ac
index 199975fed..296124399 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2722,6 +2722,43 @@ if test "x$openssl" = "xyes" ; then
2722 HMAC_CTX_init \ 2722 HMAC_CTX_init \
2723 RSA_generate_key_ex \ 2723 RSA_generate_key_ex \
2724 RSA_get_default_method \ 2724 RSA_get_default_method \
2725 EVP_CIPHER_CTX_ctrl \
2726 ])
2727 # LibreSSL/OpenSSL 1.1x API
2728 AC_CHECK_FUNCS([ \
2729 DH_get0_key \
2730 DH_get0_pqg \
2731 DH_set0_key \
2732 DH_set_length \
2733 DH_set0_pqg \
2734 DSA_get0_key \
2735 DSA_get0_pqg \
2736 DSA_set0_key \
2737 DSA_set0_pqg \
2738 DSA_SIG_get0 \
2739 DSA_SIG_set0 \
2740 ECDSA_SIG_get0 \
2741 ECDSA_SIG_set0 \
2742 EVP_CIPHER_CTX_iv \
2743 EVP_CIPHER_CTX_iv_noconst \
2744 EVP_CIPHER_CTX_get_iv \
2745 EVP_CIPHER_CTX_set_iv \
2746 RSA_get0_crt_params \
2747 RSA_get0_factors \
2748 RSA_get0_key \
2749 RSA_set0_crt_params \
2750 RSA_set0_factors \
2751 RSA_set0_key \
2752 RSA_meth_free \
2753 RSA_meth_dup \
2754 RSA_meth_set1_name \
2755 RSA_meth_get_finish \
2756 RSA_meth_set_priv_enc \
2757 RSA_meth_set_priv_dec \
2758 RSA_meth_set_finish \
2759 EVP_PKEY_get0_RSA \
2760 EVP_MD_CTX_new \
2761 EVP_MD_CTX_free \
2725 ]) 2762 ])
2726 2763
2727 if test "x$openssl_engine" = "xyes" ; then 2764 if test "x$openssl_engine" = "xyes" ; then
@@ -2807,119 +2844,6 @@ if test "x$openssl" = "xyes" ; then
2807 ] 2844 ]
2808 ) 2845 )
2809 2846
2810 AC_SEARCH_LIBS([EVP_CIPHER_CTX_ctrl], [crypto],
2811 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_CTRL], [1],
2812 [Define if libcrypto has EVP_CIPHER_CTX_ctrl])])
2813
2814 # LibreSSL/OpenSSL 1.1x API
2815 AC_SEARCH_LIBS([DH_get0_key], [crypto],
2816 [AC_DEFINE([HAVE_DH_GET0_KEY], [1],
2817 [Define if libcrypto has DH_get0_key])])
2818 AC_SEARCH_LIBS([DH_get0_pqg], [crypto],
2819 [AC_DEFINE([HAVE_DH_GET0_PQG], [1],
2820 [Define if libcrypto has DH_get0_pqg])])
2821 AC_SEARCH_LIBS([DH_set0_key], [crypto],
2822 [AC_DEFINE([HAVE_DH_SET0_KEY], [1],
2823 [Define if libcrypto has DH_set0_key])])
2824 AC_SEARCH_LIBS([DH_set_length], [crypto],
2825 [AC_DEFINE([HAVE_DH_SET_LENGTH], [1],
2826 [Define if libcrypto has DH_set_length])])
2827 AC_SEARCH_LIBS([DH_set0_pqg], [crypto],
2828 [AC_DEFINE([HAVE_DH_SET0_PQG], [1],
2829 [Define if libcrypto has DH_set0_pqg])])
2830
2831 AC_SEARCH_LIBS([DSA_get0_key], [crypto],
2832 [AC_DEFINE([HAVE_DSA_GET0_KEY], [1],
2833 [Define if libcrypto has DSA_get0_key])])
2834 AC_SEARCH_LIBS([DSA_get0_pqg], [crypto],
2835 [AC_DEFINE([HAVE_DSA_GET0_PQG], [1],
2836 [Define if libcrypto has DSA_get0_pqg])])
2837 AC_SEARCH_LIBS([DSA_set0_key], [crypto],
2838 [AC_DEFINE([HAVE_DSA_SET0_KEY], [1],
2839 [Define if libcrypto has DSA_set0_key])])
2840 AC_SEARCH_LIBS([DSA_set0_pqg], [crypto],
2841 [AC_DEFINE([HAVE_DSA_SET0_PQG], [1],
2842 [Define if libcrypto has DSA_set0_pqg])])
2843
2844 AC_SEARCH_LIBS([DSA_SIG_get0], [crypto],
2845 [AC_DEFINE([HAVE_DSA_SIG_GET0], [1],
2846 [Define if libcrypto has DSA_SIG_get0])])
2847 AC_SEARCH_LIBS([DSA_SIG_set0], [crypto],
2848 [AC_DEFINE([HAVE_DSA_SIG_SET0], [1],
2849 [Define if libcrypto has DSA_SIG_set0])])
2850
2851 AC_SEARCH_LIBS([ECDSA_SIG_get0], [crypto],
2852 [AC_DEFINE([HAVE_ECDSA_SIG_GET0], [1],
2853 [Define if libcrypto has ECDSA_SIG_get0])])
2854 AC_SEARCH_LIBS([ECDSA_SIG_set0], [crypto],
2855 [AC_DEFINE([HAVE_ECDSA_SIG_SET0], [1],
2856 [Define if libcrypto has ECDSA_SIG_set0])])
2857
2858 AC_SEARCH_LIBS([EVP_CIPHER_CTX_iv], [crypto],
2859 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_IV], [1],
2860 [Define if libcrypto has EVP_CIPHER_CTX_iv])])
2861 AC_SEARCH_LIBS([EVP_CIPHER_CTX_iv_noconst], [crypto],
2862 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_IV_NOCONST], [1],
2863 [Define if libcrypto has EVP_CIPHER_CTX_iv_noconst])])
2864 AC_SEARCH_LIBS([EVP_CIPHER_CTX_get_iv], [crypto],
2865 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_GET_IV], [1],
2866 [Define if libcrypto has EVP_CIPHER_CTX_get_iv])])
2867 AC_SEARCH_LIBS([EVP_CIPHER_CTX_set_iv], [crypto],
2868 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_SET_IV], [1],
2869 [Define if libcrypto has EVP_CIPHER_CTX_set_iv])])
2870
2871 AC_SEARCH_LIBS([RSA_get0_crt_params], [crypto],
2872 [AC_DEFINE([HAVE_RSA_GET0_CRT_PARAMS], [1],
2873 [Define if libcrypto has RSA_get0_crt_params])])
2874 AC_SEARCH_LIBS([RSA_get0_factors], [crypto],
2875 [AC_DEFINE([HAVE_RSA_GET0_FACTORS], [1],
2876 [Define if libcrypto has RSA_get0_factors])])
2877 AC_SEARCH_LIBS([RSA_get0_key], [crypto],
2878 [AC_DEFINE([HAVE_RSA_GET0_KEY], [1],
2879 [Define if libcrypto has RSA_get0_key])])
2880 AC_SEARCH_LIBS([RSA_set0_crt_params], [crypto],
2881 [AC_DEFINE([HAVE_RSA_SET0_CRT_PARAMS], [1],
2882 [Define if libcrypto has RSA_get0_srt_params])])
2883 AC_SEARCH_LIBS([RSA_set0_factors], [crypto],
2884 [AC_DEFINE([HAVE_RSA_SET0_FACTORS], [1],
2885 [Define if libcrypto has RSA_set0_factors])])
2886 AC_SEARCH_LIBS([RSA_set0_key], [crypto],
2887 [AC_DEFINE([HAVE_RSA_SET0_KEY], [1],
2888 [Define if libcrypto has RSA_set0_key])])
2889
2890 AC_SEARCH_LIBS([RSA_meth_free], [crypto],
2891 [AC_DEFINE([HAVE_RSA_METH_FREE], [1],
2892 [Define if libcrypto has RSA_meth_free])])
2893 AC_SEARCH_LIBS([RSA_meth_dup], [crypto],
2894 [AC_DEFINE([HAVE_RSA_METH_DUP], [1],
2895 [Define if libcrypto has RSA_meth_dup])])
2896 AC_SEARCH_LIBS([RSA_meth_set1_name], [crypto],
2897 [AC_DEFINE([HAVE_RSA_METH_SET1_NAME], [1],
2898 [Define if libcrypto has RSA_meth_set1_name])])
2899 AC_SEARCH_LIBS([RSA_meth_get_finish], [crypto],
2900 [AC_DEFINE([HAVE_RSA_METH_GET_FINISH], [1],
2901 [Define if libcrypto has RSA_meth_get_finish])])
2902 AC_SEARCH_LIBS([RSA_meth_set_priv_enc], [crypto],
2903 [AC_DEFINE([HAVE_RSA_METH_SET_PRIV_ENC], [1],
2904 [Define if libcrypto has RSA_meth_set_priv_enc])])
2905 AC_SEARCH_LIBS([RSA_meth_set_priv_dec], [crypto],
2906 [AC_DEFINE([HAVE_RSA_METH_SET_PRIV_DEC], [1],
2907 [Define if libcrypto has RSA_meth_set_priv_dec])])
2908 AC_SEARCH_LIBS([RSA_meth_set_finish], [crypto],
2909 [AC_DEFINE([HAVE_RSA_METH_SET_FINISH], [1],
2910 [Define if libcrypto has RSA_meth_set_finish])])
2911
2912 AC_SEARCH_LIBS([EVP_PKEY_get0_RSA], [crypto],
2913 [AC_DEFINE([HAVE_EVP_PKEY_GET0_RSA], [1],
2914 [Define if libcrypto has EVP_PKEY_get0_RSA])])
2915
2916 AC_SEARCH_LIBS([EVP_MD_CTX_new], [crypto],
2917 [AC_DEFINE([HAVE_EVP_MD_CTX_NEW], [1],
2918 [Define if libcrypto has EVP_MD_CTX_new])])
2919 AC_SEARCH_LIBS([EVP_MD_CTX_free], [crypto],
2920 [AC_DEFINE([HAVE_EVP_MD_CTX_FREE], [1],
2921 [Define if libcrypto has EVP_MD_CTX_free])])
2922
2923 AC_MSG_CHECKING([if EVP_DigestUpdate returns an int]) 2847 AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2924 AC_LINK_IFELSE( 2848 AC_LINK_IFELSE(
2925 [AC_LANG_PROGRAM([[ 2849 [AC_LANG_PROGRAM([[