summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-10-07 13:22:41 +0100
committerColin Watson <cjwatson@debian.org>2018-10-20 22:54:09 +0100
commit389e16d0109d8c49a761cd7c267438b05c9ab984 (patch)
treea7dfff07f60a4896c9c2ab4adcbd9f5e72143da7 /configure.ac
parent72b1d308e6400194ef6e4e7dd45bfa48fa39b5e6 (diff)
Restore TCP wrappers support
Support for TCP wrappers was dropped in OpenSSH 6.7. See this message and thread: https://lists.mindrot.org/pipermail/openssh-unix-dev/2014-April/032497.html It is true that this reduces preauth attack surface in sshd. On the other hand, this support seems to be quite widely used, and abruptly dropping it (from the perspective of users who don't read openssh-unix-dev) could easily cause more serious problems in practice. It's not entirely clear what the right long-term answer for Debian is, but it at least probably doesn't involve dropping this feature shortly before a freeze. Forwarded: not-needed Last-Update: 2018-08-24 Patch-Name: restore-tcp-wrappers.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 023e7cc55..917300b43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1517,6 +1517,62 @@ else
1517 AC_MSG_RESULT([no]) 1517 AC_MSG_RESULT([no])
1518fi 1518fi
1519 1519
1520# Check whether user wants TCP wrappers support
1521TCPW_MSG="no"
1522AC_ARG_WITH([tcp-wrappers],
1523 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1524 [
1525 if test "x$withval" != "xno" ; then
1526 saved_LIBS="$LIBS"
1527 saved_LDFLAGS="$LDFLAGS"
1528 saved_CPPFLAGS="$CPPFLAGS"
1529 if test -n "${withval}" && \
1530 test "x${withval}" != "xyes"; then
1531 if test -d "${withval}/lib"; then
1532 if test -n "${need_dash_r}"; then
1533 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1534 else
1535 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1536 fi
1537 else
1538 if test -n "${need_dash_r}"; then
1539 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1540 else
1541 LDFLAGS="-L${withval} ${LDFLAGS}"
1542 fi
1543 fi
1544 if test -d "${withval}/include"; then
1545 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1546 else
1547 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1548 fi
1549 fi
1550 LIBS="-lwrap $LIBS"
1551 AC_MSG_CHECKING([for libwrap])
1552 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1553#include <sys/types.h>
1554#include <sys/socket.h>
1555#include <netinet/in.h>
1556#include <tcpd.h>
1557int deny_severity = 0, allow_severity = 0;
1558 ]], [[
1559 hosts_access(0);
1560 ]])], [
1561 AC_MSG_RESULT([yes])
1562 AC_DEFINE([LIBWRAP], [1],
1563 [Define if you want
1564 TCP Wrappers support])
1565 SSHDLIBS="$SSHDLIBS -lwrap"
1566 TCPW_MSG="yes"
1567 ], [
1568 AC_MSG_ERROR([*** libwrap missing])
1569
1570 ])
1571 LIBS="$saved_LIBS"
1572 fi
1573 ]
1574)
1575
1520# Check whether user wants to use ldns 1576# Check whether user wants to use ldns
1521LDNS_MSG="no" 1577LDNS_MSG="no"
1522AC_ARG_WITH(ldns, 1578AC_ARG_WITH(ldns,
@@ -5329,6 +5385,7 @@ echo " PAM support: $PAM_MSG"
5329echo " OSF SIA support: $SIA_MSG" 5385echo " OSF SIA support: $SIA_MSG"
5330echo " KerberosV support: $KRB5_MSG" 5386echo " KerberosV support: $KRB5_MSG"
5331echo " SELinux support: $SELINUX_MSG" 5387echo " SELinux support: $SELINUX_MSG"
5388echo " TCP Wrappers support: $TCPW_MSG"
5332echo " MD5 password support: $MD5_MSG" 5389echo " MD5 password support: $MD5_MSG"
5333echo " libedit support: $LIBEDIT_MSG" 5390echo " libedit support: $LIBEDIT_MSG"
5334echo " libldns support: $LDNS_MSG" 5391echo " libldns support: $LDNS_MSG"