summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2017-01-16 15:02:41 +0000
commit48fbb156bdc676fb6ba6817770e4e971fbf85b1f (patch)
treef35c67c09472bddc3337b1c74b0cb6a1d9b58670 /configure.ac
parent971a7653746a6972b907dfe0ce139c06e4a6f482 (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2017-01-16 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eb9f45dcc..5fdc696c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -623,6 +623,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
623 [Use tunnel device compatibility to OpenBSD]) 623 [Use tunnel device compatibility to OpenBSD])
624 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 624 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
625 [Prepend the address family to IP tunnel traffic]) 625 [Prepend the address family to IP tunnel traffic])
626 AC_MSG_CHECKING([if we have the Security Authorization Session API])
627 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
628 [SessionCreate(0, 0);],
629 [ac_cv_use_security_session_api="yes"
630 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
631 [platform has the Security Authorization Session API])
632 LIBS="$LIBS -framework Security"
633 AC_MSG_RESULT([yes])],
634 [ac_cv_use_security_session_api="no"
635 AC_MSG_RESULT([no])])
636 AC_MSG_CHECKING([if we have an in-memory credentials cache])
637 AC_TRY_COMPILE(
638 [#include <Kerberos/Kerberos.h>],
639 [cc_context_t c;
640 (void) cc_initialize (&c, 0, NULL, NULL);],
641 [AC_DEFINE([USE_CCAPI], [1],
642 [platform uses an in-memory credentials cache])
643 LIBS="$LIBS -framework Security"
644 AC_MSG_RESULT([yes])
645 if test "x$ac_cv_use_security_session_api" = "xno"; then
646 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
647 fi],
648 [AC_MSG_RESULT([no])]
649 )
626 m4_pattern_allow([AU_IPv]) 650 m4_pattern_allow([AU_IPv])
627 AC_CHECK_DECL([AU_IPv4], [], 651 AC_CHECK_DECL([AU_IPv4], [],
628 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 652 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])