summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2002-02-26 08:40:48 -0800
committerTim Rice <tim@multitalents.net>2002-02-26 08:40:48 -0800
commit4cec93faed6586dd48b02030b77c094e0730b62e (patch)
tree5aac3fe80d5d789508d21ebc8f230243fb83e188 /configure.ac
parentc004135b72ff934c2576f8dec4d35d53019bf239 (diff)
Bug 12 [configure.ac] add sys/bitypes.h to int64_t tests
based on patch by mooney@dogbert.cc.ndsu.nodak.edu (Tim Mooney) Bug 45 [configure.ac] modify skey test to work around conflict with autoconf reported by nolan@naic.edu (Michael Nolan) patch by Pekka Savola <pekkas@netcore.fi> Bug 74 [configure.ac defines.h] add sig_atomic_t test reported by dwd@bell-labs.com (Dave Dykstra) Bug 102 [defines.h] UNICOS fixes. patch by wendyp@cray.com [configure.ac Makefile.in] link libwrap only with sshd based on patch by Maciej W. Rozycki <macro@ds2.pg.gda.pl> Bug 123 link libpam only with sshd reported by peak@argo.troja.mff.cuni.cz (Pavel Kankovsky) [configure.ac defines.h] modify previous SCO3 fix to not break Solaris 7 [acconfig.h] remove unused HAVE_REGCOMP
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac98
1 files changed, 80 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index e342c974e..1f537868e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.20 2002/02/13 21:44:06 djm Exp $ 1# $Id: configure.ac,v 1.21 2002/02/26 16:40:49 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -320,6 +320,18 @@ AC_ARG_WITH(libs,
320 ] 320 ]
321) 321)
322 322
323# Checks for header files.
324AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h \
325 getopt.h glob.h lastlog.h limits.h login.h \
326 login_cap.h maillock.h netdb.h netgroup.h \
327 netinet/in_systm.h paths.h poll.h pty.h \
328 security/pam_appl.h shadow.h stddef.h stdint.h \
329 strings.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h \
330 sys/poll.h sys/queue.h sys/select.h sys/stat.h \
331 sys/stropts.h sys/sysmacros.h sys/time.h \
332 sys/ttcompat.h sys/un.h time.h ttyent.h usersec.h \
333 util.h utime.h utmp.h utmpx.h)
334
323# Checks for libraries. 335# Checks for libraries.
324AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match)) 336AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match))
325AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt)) 337AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt))
@@ -391,19 +403,6 @@ AC_CHECK_FUNCS(logout updwtmp logwtmp)
391 403
392AC_FUNC_STRFTIME 404AC_FUNC_STRFTIME
393 405
394# Checks for header files.
395AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h \
396 getopt.h glob.h lastlog.h limits.h login.h \
397 login_cap.h maillock.h netdb.h netgroup.h \
398 netinet/in_systm.h paths.h poll.h pty.h \
399 rpc/rpc.h \
400 security/pam_appl.h shadow.h stddef.h stdint.h \
401 strings.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h \
402 sys/poll.h sys/queue.h sys/select.h sys/stat.h \
403 sys/stropts.h sys/sysmacros.h sys/time.h \
404 sys/ttcompat.h sys/un.h time.h ttyent.h usersec.h \
405 util.h utime.h utmp.h utmpx.h)
406
407# Check for ALTDIRFUNC glob() extension 406# Check for ALTDIRFUNC glob() extension
408AC_MSG_CHECKING(for GLOB_ALTDIRFUNC support) 407AC_MSG_CHECKING(for GLOB_ALTDIRFUNC support)
409AC_EGREP_CPP(FOUNDIT, 408AC_EGREP_CPP(FOUNDIT,
@@ -469,9 +468,16 @@ AC_ARG_WITH(skey,
469 LIBS="-lskey $LIBS" 468 LIBS="-lskey $LIBS"
470 SKEY_MSG="yes" 469 SKEY_MSG="yes"
471 470
472 AC_CHECK_FUNC(skey_keyinfo, 471 AC_MSG_CHECKING([for s/key support])
473 [], 472 AC_TRY_RUN(
473 [
474#include <stdio.h>
475#include <skey.h>
476int main() { char *ff = skey_keyinfo(""); ff=""; return 0; }
477 ],
478 [AC_MSG_RESULT(yes)],
474 [ 479 [
480 AC_MSG_RESULT(no)
475 AC_MSG_ERROR([** Incomplete or missing s/key libraries.]) 481 AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
476 ]) 482 ])
477 fi 483 fi
@@ -508,7 +514,8 @@ AC_ARG_WITH(tcp-wrappers,
508 CPPFLAGS="-I${withval} ${CPPFLAGS}" 514 CPPFLAGS="-I${withval} ${CPPFLAGS}"
509 fi 515 fi
510 fi 516 fi
511 LIBS="-lwrap $LIBS" 517 LIBWRAP="-lwrap"
518 LIBS="$LIBWRAP $LIBS"
512 AC_MSG_CHECKING(for libwrap) 519 AC_MSG_CHECKING(for libwrap)
513 AC_TRY_LINK( 520 AC_TRY_LINK(
514 [ 521 [
@@ -519,12 +526,14 @@ AC_ARG_WITH(tcp-wrappers,
519 [ 526 [
520 AC_MSG_RESULT(yes) 527 AC_MSG_RESULT(yes)
521 AC_DEFINE(LIBWRAP) 528 AC_DEFINE(LIBWRAP)
529 AC_SUBST(LIBWRAP)
522 TCPW_MSG="yes" 530 TCPW_MSG="yes"
523 ], 531 ],
524 [ 532 [
525 AC_MSG_ERROR([*** libwrap missing]) 533 AC_MSG_ERROR([*** libwrap missing])
526 ] 534 ]
527 ) 535 )
536 LIBS="$saved_LIBS"
528 fi 537 fi
529 ] 538 ]
530) 539)
@@ -640,6 +649,7 @@ AC_ARG_WITH(pam,
640 PAM_MSG="yes" 649 PAM_MSG="yes"
641 650
642 AC_DEFINE(USE_PAM) 651 AC_DEFINE(USE_PAM)
652 AC_SUBST(LIBPAM, ["-lpam -ldl"])
643 fi 653 fi
644 ] 654 ]
645) 655)
@@ -956,6 +966,25 @@ AC_ARG_WITH(prngd-socket,
956 PRNGD_SOCKET="$withval" 966 PRNGD_SOCKET="$withval"
957 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET") 967 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET")
958 fi 968 fi
969 ],
970 [
971 # Check for existing socket only if we don't have a random device already
972 if test "$USE_RAND_HELPER" = yes ; then
973 AC_MSG_CHECKING(for PRNGD/EGD socket)
974 # Insert other locations here
975 for sock in /var/run/egd-pool /dev/egd-pool /etc/entropy; do
976 if test -r $sock && $TEST_MINUS_S_SH -c "test -S $sock -o -p $sock" ; then
977 PRNGD_SOCKET="$sock"
978 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET")
979 break;
980 fi
981 done
982 if test ! -z "$PRNGD_SOCKET" ; then
983 AC_MSG_RESULT($PRNGD_SOCKET)
984 else
985 AC_MSG_RESULT(not found)
986 fi
987 fi
959 ] 988 ]
960) 989)
961 990
@@ -1086,6 +1115,19 @@ if test -z "$have_int64_t" ; then
1086 ) 1115 )
1087fi 1116fi
1088 1117
1118if test -z "$have_int64_t" ; then
1119 AC_MSG_CHECKING([for int64_t type in sys/bitypes.h])
1120 AC_TRY_COMPILE(
1121 [ #include <sys/bitypes.h> ],
1122 [ int64_t a; a = 1],
1123 [
1124 AC_DEFINE(HAVE_INT64_T)
1125 AC_MSG_RESULT(yes)
1126 ],
1127 [ AC_MSG_RESULT(no) ]
1128 )
1129fi
1130
1089AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [ 1131AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [
1090 AC_TRY_COMPILE( 1132 AC_TRY_COMPILE(
1091 [ #include <sys/types.h> ], 1133 [ #include <sys/types.h> ],
@@ -1125,6 +1167,19 @@ if test "x$ac_cv_have_u_int64_t" = "xyes" ; then
1125 have_u_int64_t=1 1167 have_u_int64_t=1
1126fi 1168fi
1127 1169
1170if test -z "$have_u_int64_t" ; then
1171 AC_MSG_CHECKING([for u_int64_t type in sys/bitypes.h])
1172 AC_TRY_COMPILE(
1173 [ #include <sys/bitypes.h> ],
1174 [ u_int64_t a; a = 1],
1175 [
1176 AC_DEFINE(HAVE_U_INT64_T)
1177 AC_MSG_RESULT(yes)
1178 ],
1179 [ AC_MSG_RESULT(no) ]
1180 )
1181fi
1182
1128if test -z "$have_u_intxx_t" ; then 1183if test -z "$have_u_intxx_t" ; then
1129 AC_CACHE_CHECK([for uintXX_t types], ac_cv_have_uintxx_t, [ 1184 AC_CACHE_CHECK([for uintXX_t types], ac_cv_have_uintxx_t, [
1130 AC_TRY_COMPILE( 1185 AC_TRY_COMPILE(
@@ -1193,6 +1248,8 @@ fi
1193 1248
1194TYPE_SOCKLEN_T 1249TYPE_SOCKLEN_T
1195 1250
1251AC_CHECK_TYPES(sig_atomic_t)
1252
1196AC_CACHE_CHECK([for size_t], ac_cv_have_size_t, [ 1253AC_CACHE_CHECK([for size_t], ac_cv_have_size_t, [
1197 AC_TRY_COMPILE( 1254 AC_TRY_COMPILE(
1198 [ 1255 [
@@ -2191,6 +2248,11 @@ if test ! -z "$blibpath" ; then
2191 AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile]) 2248 AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile])
2192fi 2249fi
2193 2250
2251dnl remove pam and dl because they are in $LIBPAM
2252if test "$PAM_MSG" = yes ; then
2253 LIBS=`echo $LIBS | sed 's/-lpam -ldl //'`
2254fi
2255
2194AC_EXEEXT 2256AC_EXEEXT
2195AC_CONFIG_FILES([Makefile openbsd-compat/Makefile scard/Makefile ssh_prng_cmds]) 2257AC_CONFIG_FILES([Makefile openbsd-compat/Makefile scard/Makefile ssh_prng_cmds])
2196AC_OUTPUT 2258AC_OUTPUT
@@ -2240,7 +2302,7 @@ echo " Compiler: ${CC}"
2240echo " Compiler flags: ${CFLAGS}" 2302echo " Compiler flags: ${CFLAGS}"
2241echo "Preprocessor flags: ${CPPFLAGS}" 2303echo "Preprocessor flags: ${CPPFLAGS}"
2242echo " Linker flags: ${LDFLAGS}" 2304echo " Linker flags: ${LDFLAGS}"
2243echo " Libraries: ${LIBS}" 2305echo " Libraries: ${LIBWRAP} ${LIBPAM} ${LIBS}"
2244 2306
2245echo "" 2307echo ""
2246 2308