summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2017-10-04 13:54:43 +0100
commit4e70490950e5c5134df48848affaf73685bf0284 (patch)
tree59de097e770693fb1f81268e85f7802df32cb58e /configure.ac
parent62f54f20bf351468e0124f63cc2902ee40d9b0e9 (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2017-10-04 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 889f50637..84bfad8c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -621,6 +621,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
621 [Use tunnel device compatibility to OpenBSD]) 621 [Use tunnel device compatibility to OpenBSD])
622 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 622 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
623 [Prepend the address family to IP tunnel traffic]) 623 [Prepend the address family to IP tunnel traffic])
624 AC_MSG_CHECKING([if we have the Security Authorization Session API])
625 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
626 [SessionCreate(0, 0);],
627 [ac_cv_use_security_session_api="yes"
628 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
629 [platform has the Security Authorization Session API])
630 LIBS="$LIBS -framework Security"
631 AC_MSG_RESULT([yes])],
632 [ac_cv_use_security_session_api="no"
633 AC_MSG_RESULT([no])])
634 AC_MSG_CHECKING([if we have an in-memory credentials cache])
635 AC_TRY_COMPILE(
636 [#include <Kerberos/Kerberos.h>],
637 [cc_context_t c;
638 (void) cc_initialize (&c, 0, NULL, NULL);],
639 [AC_DEFINE([USE_CCAPI], [1],
640 [platform uses an in-memory credentials cache])
641 LIBS="$LIBS -framework Security"
642 AC_MSG_RESULT([yes])
643 if test "x$ac_cv_use_security_session_api" = "xno"; then
644 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
645 fi],
646 [AC_MSG_RESULT([no])]
647 )
624 m4_pattern_allow([AU_IPv]) 648 m4_pattern_allow([AU_IPv])
625 AC_CHECK_DECL([AU_IPv4], [], 649 AC_CHECK_DECL([AU_IPv4], [],
626 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 650 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])