summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2015-08-19 17:00:17 +0100
committerColin Watson <cjwatson@debian.org>2015-08-19 17:00:17 +0100
commit544df7a04ae5b5c1fc30be7c445ad685d7a02dc9 (patch)
tree33d2a87dd50fe5894ac6ec4579c83401b7ab00a4 /configure.ac
parentbaccdb349b31c47cd76fb63211f754ed33a9707e (diff)
parent7de4b03a6e4071d454b72927ffaf52949fa34545 (diff)
Import openssh_6.9p1.orig.tar.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 19 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b4d6598d5..bb0095f64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ AC_PROG_CPP
30AC_PROG_RANLIB 30AC_PROG_RANLIB
31AC_PROG_INSTALL 31AC_PROG_INSTALL
32AC_PROG_EGREP 32AC_PROG_EGREP
33AC_PATH_PROG([AR], [ar]) 33AC_CHECK_TOOLS([AR], [ar])
34AC_PATH_PROG([CAT], [cat]) 34AC_PATH_PROG([CAT], [cat])
35AC_PATH_PROG([KILL], [kill]) 35AC_PATH_PROG([KILL], [kill])
36AC_PATH_PROGS([PERL], [perl5 perl]) 36AC_PATH_PROGS([PERL], [perl5 perl])
@@ -140,12 +140,17 @@ else
140fi 140fi
141 141
142AC_ARG_WITH([ssh1], 142AC_ARG_WITH([ssh1],
143 [ --without-ssh1 Disable support for SSH protocol 1], 143 [ --without-ssh1 Enable support for SSH protocol 1],
144 [ 144 [
145 if test "x$withval" = "xno" ; then 145 if test "x$withval" = "xyes" ; then
146 if test "x$openssl" = "xno" ; then
147 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled])
148 fi
149 ssh1=yes
150 elif test "x$withval" = "xno" ; then
146 ssh1=no 151 ssh1=no
147 elif test "x$openssl" = "xno" ; then 152 else
148 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled]) 153 AC_MSG_ERROR([unknown --with-ssh1 argument])
149 fi 154 fi
150 ] 155 ]
151) 156)
@@ -776,14 +781,17 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
776 i*86-*) 781 i*86-*)
777 seccomp_audit_arch=AUDIT_ARCH_I386 782 seccomp_audit_arch=AUDIT_ARCH_I386
778 ;; 783 ;;
779 arm*-*) 784 arm*-*)
780 seccomp_audit_arch=AUDIT_ARCH_ARM 785 seccomp_audit_arch=AUDIT_ARCH_ARM
781 ;; 786 ;;
787 aarch64*-*)
788 seccomp_audit_arch=AUDIT_ARCH_AARCH64
789 ;;
782 esac 790 esac
783 if test "x$seccomp_audit_arch" != "x" ; then 791 if test "x$seccomp_audit_arch" != "x" ; then
784 AC_MSG_RESULT(["$seccomp_audit_arch"]) 792 AC_MSG_RESULT(["$seccomp_audit_arch"])
785 AC_DEFINE_UNQUOTED([SECCOMP_AUDIT_ARCH], [$seccomp_audit_arch], 793 AC_DEFINE_UNQUOTED([SECCOMP_AUDIT_ARCH], [$seccomp_audit_arch],
786 [Specify the system call convention in use]) 794 [Specify the system call convention in use])
787 else 795 else
788 AC_MSG_RESULT([architecture not supported]) 796 AC_MSG_RESULT([architecture not supported])
789 fi 797 fi
@@ -4351,7 +4359,7 @@ if test ! -z "$IPADDR_IN_DISPLAY" ; then
4351else 4359else
4352 DISPLAY_HACK_MSG="no" 4360 DISPLAY_HACK_MSG="no"
4353 AC_ARG_WITH([ipaddr-display], 4361 AC_ARG_WITH([ipaddr-display],
4354 [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY], 4362 [ --with-ipaddr-display Use ip address instead of hostname in $DISPLAY],
4355 [ 4363 [
4356 if test "x$withval" != "xno" ; then 4364 if test "x$withval" != "xno" ; then
4357 AC_DEFINE([IPADDR_IN_DISPLAY]) 4365 AC_DEFINE([IPADDR_IN_DISPLAY])
@@ -4397,7 +4405,7 @@ fi
4397# Whether to mess with the default path 4405# Whether to mess with the default path
4398SERVER_PATH_MSG="(default)" 4406SERVER_PATH_MSG="(default)"
4399AC_ARG_WITH([default-path], 4407AC_ARG_WITH([default-path],
4400 [ --with-default-path= Specify default \$PATH environment for server], 4408 [ --with-default-path= Specify default $PATH environment for server],
4401 [ 4409 [
4402 if test "x$external_path_file" = "x/etc/login.conf" ; then 4410 if test "x$external_path_file" = "x/etc/login.conf" ; then
4403 AC_MSG_WARN([ 4411 AC_MSG_WARN([