summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-09-22 12:09:17 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-09-22 12:09:17 +1000
commit7724e94d041d267b5b9915b37d44c0986b12fe6d (patch)
tree34a347388684277c2a11dd10b050355c150ef407 /configure.ac
parent2a2e64ea4004c879497b29466f8275a90d9cc009 (diff)
- (dtucker) [configure.ac openbsd-compat/fake-rfc2553.c
openbsd-compat/fake-rfc2553.h] Bug #659: Test for and handle systems with where gai_strerror is defined as "const char *". Part of patch supplied by bugzilla-openssh at thewrittenword.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5cf7d9097..c5f98468f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.154.2.6 2003/09/22 01:58:44 dtucker Exp $ 1# $Id: configure.ac,v 1.154.2.7 2003/09/22 02:09:18 dtucker Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -731,7 +731,7 @@ dnl Checks for library functions. Please keep in alphabetical order
731AC_CHECK_FUNCS(\ 731AC_CHECK_FUNCS(\
732 arc4random __b64_ntop b64_ntop __b64_pton b64_pton basename \ 732 arc4random __b64_ntop b64_ntop __b64_pton b64_pton basename \
733 bcopy bindresvport_sa clock fchmod fchown freeaddrinfo futimes \ 733 bcopy bindresvport_sa clock fchmod fchown freeaddrinfo futimes \
734 gai_strerror getaddrinfo getcwd getgrouplist getnameinfo getopt \ 734 getaddrinfo getcwd getgrouplist getnameinfo getopt \
735 getpeereid _getpty getrlimit getttyent glob inet_aton \ 735 getpeereid _getpty getrlimit getttyent glob inet_aton \
736 inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \ 736 inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \
737 mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \ 737 mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \
@@ -743,6 +743,21 @@ AC_CHECK_FUNCS(\
743 truncate utimes vhangup vsnprintf waitpid \ 743 truncate utimes vhangup vsnprintf waitpid \
744) 744)
745 745
746# IRIX has a const char return value for gai_strerror()
747AC_CHECK_FUNCS(gai_strerror,[
748 AC_DEFINE(HAVE_GAI_STRERROR)
749 AC_TRY_COMPILE([
750#include <sys/types.h>
751#include <sys/socket.h>
752#include <netdb.h>
753
754const char *gai_strerror(int);],[
755char *str;
756
757str = gai_strerror(0);],[
758 AC_DEFINE(HAVE_CONST_GAI_STRERROR_PROTO, 1,
759 [Define if gai_strerror() returns const char *])])])
760
746AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP)) 761AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP))
747 762
748dnl Make sure prototypes are defined for these before using them. 763dnl Make sure prototypes are defined for these before using them.