summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2018-10-23 17:10:41 +1100
committerDamien Miller <djm@mindrot.org>2018-10-23 17:10:41 +1100
commit859754bdeb41373d372e36b5dc89c547453addb3 (patch)
tree8255b9851d8fa6339f25e2044a1572624eebca8d /configure.ac
parentb9fea45a68946c8dfeace72ad1f6657c18f2a98a (diff)
remove remaining references to SSLeay
Prompted by Rosen Penev
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7379ab358..0d55bece5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2602,8 +2602,9 @@ if test "x$openssl" = "xyes" ; then
2602 if(fd == NULL) 2602 if(fd == NULL)
2603 exit(1); 2603 exit(1);
2604 2604
2605 if ((rc = fprintf(fd, "%08lx (%s)\n", (unsigned long)SSLeay(), 2605 if ((rc = fprintf(fd, "%08lx (%s)\n",
2606 SSLeay_version(SSLEAY_VERSION))) < 0) 2606 (unsigned long)OpenSSL_version_num(),
2607 OpenSSL_version(OPENSSL_VERSION))) < 0)
2607 exit(1); 2608 exit(1);
2608 2609
2609 exit(0); 2610 exit(0);
@@ -2645,7 +2646,7 @@ if test "x$openssl" = "xyes" ; then
2645 #include <openssl/opensslv.h> 2646 #include <openssl/opensslv.h>
2646 #include <openssl/crypto.h> 2647 #include <openssl/crypto.h>
2647 ]], [[ 2648 ]], [[
2648 exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); 2649 exit(OpenSSL_version_num() == OPENSSL_VERSION_NUMBER ? 0 : 1);
2649 ]])], 2650 ]])],
2650 [ 2651 [
2651 AC_MSG_RESULT([yes]) 2652 AC_MSG_RESULT([yes])
@@ -2673,7 +2674,7 @@ if test "x$openssl" = "xyes" ; then
2673 AC_MSG_CHECKING([if programs using OpenSSL functions will link]) 2674 AC_MSG_CHECKING([if programs using OpenSSL functions will link])
2674 AC_LINK_IFELSE( 2675 AC_LINK_IFELSE(
2675 [AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]], 2676 [AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]],
2676 [[ SSLeay_add_all_algorithms(); ]])], 2677 [[ OpenSSL_add_all_algorithms(); ]])],
2677 [ 2678 [
2678 AC_MSG_RESULT([yes]) 2679 AC_MSG_RESULT([yes])
2679 ], 2680 ],
@@ -2684,7 +2685,7 @@ if test "x$openssl" = "xyes" ; then
2684 AC_MSG_CHECKING([if programs using OpenSSL need -ldl]) 2685 AC_MSG_CHECKING([if programs using OpenSSL need -ldl])
2685 AC_LINK_IFELSE( 2686 AC_LINK_IFELSE(
2686 [AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]], 2687 [AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]],
2687 [[ SSLeay_add_all_algorithms(); ]])], 2688 [[ OpenSSL_add_all_algorithms(); ]])],
2688 [ 2689 [
2689 AC_MSG_RESULT([yes]) 2690 AC_MSG_RESULT([yes])
2690 ], 2691 ],