summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2018-07-20 13:18:28 +1000
committerDamien Miller <djm@mindrot.org>2018-07-31 12:59:30 +1000
commit87f08be054b7eeadbb9cdeb3fb4872be79ccf218 (patch)
tree80bfc724ddd93228b8571702a2f153787994022b /configure.ac
parent5d14019ba2ff54acbfd20a6b9b96bb860a8c7c31 (diff)
Remove support for S/Key
Most people will 1) be using modern multi-factor authentication methods like TOTP/OATH etc and 2) be getting support for multi-factor authentication via PAM or BSD Auth.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 0 insertions, 50 deletions
diff --git a/configure.ac b/configure.ac
index 8c6827a7b..c4c759d4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1495,55 +1495,6 @@ else
1495 AC_MSG_RESULT([no]) 1495 AC_MSG_RESULT([no])
1496fi 1496fi
1497 1497
1498# Check whether user wants S/Key support
1499SKEY_MSG="no"
1500AC_ARG_WITH([skey],
1501 [ --with-skey[[=PATH]] Enable S/Key support (optionally in PATH)],
1502 [
1503 if test "x$withval" != "xno" ; then
1504
1505 if test "x$withval" != "xyes" ; then
1506 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1507 LDFLAGS="$LDFLAGS -L${withval}/lib"
1508 fi
1509
1510 AC_DEFINE([SKEY], [1], [Define if you want S/Key support])
1511 LIBS="-lskey $LIBS"
1512 SKEY_MSG="yes"
1513
1514 AC_MSG_CHECKING([for s/key support])
1515 AC_LINK_IFELSE(
1516 [AC_LANG_PROGRAM([[
1517#include <stdio.h>
1518#include <skey.h>
1519 ]], [[
1520 char *ff = skey_keyinfo(""); ff="";
1521 exit(0);
1522 ]])],
1523 [AC_MSG_RESULT([yes])],
1524 [
1525 AC_MSG_RESULT([no])
1526 AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
1527 ])
1528 AC_MSG_CHECKING([if skeychallenge takes 4 arguments])
1529 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
1530#include <stdio.h>
1531#include <skey.h>
1532 ]], [[
1533 (void)skeychallenge(NULL,"name","",0);
1534 ]])],
1535 [
1536 AC_MSG_RESULT([yes])
1537 AC_DEFINE([SKEYCHALLENGE_4ARG], [1],
1538 [Define if your skeychallenge()
1539 function takes 4 arguments (NetBSD)])],
1540 [
1541 AC_MSG_RESULT([no])
1542 ])
1543 fi
1544 ]
1545)
1546
1547# Check whether user wants to use ldns 1498# Check whether user wants to use ldns
1548LDNS_MSG="no" 1499LDNS_MSG="no"
1549AC_ARG_WITH(ldns, 1500AC_ARG_WITH(ldns,
@@ -5219,7 +5170,6 @@ echo " PAM support: $PAM_MSG"
5219echo " OSF SIA support: $SIA_MSG" 5170echo " OSF SIA support: $SIA_MSG"
5220echo " KerberosV support: $KRB5_MSG" 5171echo " KerberosV support: $KRB5_MSG"
5221echo " SELinux support: $SELINUX_MSG" 5172echo " SELinux support: $SELINUX_MSG"
5222echo " S/KEY support: $SKEY_MSG"
5223echo " MD5 password support: $MD5_MSG" 5173echo " MD5 password support: $MD5_MSG"
5224echo " libedit support: $LIBEDIT_MSG" 5174echo " libedit support: $LIBEDIT_MSG"
5225echo " libldns support: $LDNS_MSG" 5175echo " libldns support: $LDNS_MSG"