summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-01-24 21:39:36 +0000
committerColin Watson <cjwatson@debian.org>2010-01-24 21:39:36 +0000
commit964476f91b66c475d5b8fa1e8b28d39a97a1b56e (patch)
treed12ff16d94cffc5d84dba0193eaaa616967c9c2c /configure.ac
parentcadac134eda6ed97478afdc528a68dd33f31dbc5 (diff)
parent1e4cfeee6c17b02af09418c5afe4a4d71aaaf0c8 (diff)
import openssh-5.3p1-gsskex-all-20100124.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac108
1 files changed, 87 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index bd393b592..2f1dfbaff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.415 2009/02/16 04:37:03 djm Exp $ 1# $Id: configure.ac,v 1.427 2009/09/11 04:56:08 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.415 $) 18AC_REVISION($Revision: 1.427 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -279,7 +279,6 @@ AC_CHECK_HEADERS( \
279 sys/cdefs.h \ 279 sys/cdefs.h \
280 sys/dir.h \ 280 sys/dir.h \
281 sys/mman.h \ 281 sys/mman.h \
282 sys/mount.h \
283 sys/ndir.h \ 282 sys/ndir.h \
284 sys/poll.h \ 283 sys/poll.h \
285 sys/prctl.h \ 284 sys/prctl.h \
@@ -326,6 +325,11 @@ AC_CHECK_HEADERS(login_cap.h, [], [], [
326#include <sys/types.h> 325#include <sys/types.h>
327]) 326])
328 327
328# older BSDs need sys/param.h before sys/mount.h
329AC_CHECK_HEADERS(sys/mount.h, [], [], [
330#include <sys/param.h>
331])
332
329# Messages for features tested for in target-specific section 333# Messages for features tested for in target-specific section
330SIA_MSG="no" 334SIA_MSG="no"
331SPC_MSG="no" 335SPC_MSG="no"
@@ -434,8 +438,6 @@ int main(void) { exit(0); }
434 AC_DEFINE(USE_PIPES, 1, [Use PIPES instead of a socketpair()]) 438 AC_DEFINE(USE_PIPES, 1, [Use PIPES instead of a socketpair()])
435 AC_DEFINE(DISABLE_SHADOW, 1, 439 AC_DEFINE(DISABLE_SHADOW, 1,
436 [Define if you want to disable shadow passwords]) 440 [Define if you want to disable shadow passwords])
437 AC_DEFINE(IP_TOS_IS_BROKEN, 1,
438 [Define if your system choked on IP TOS setting])
439 AC_DEFINE(NO_X11_UNIX_SOCKETS, 1, 441 AC_DEFINE(NO_X11_UNIX_SOCKETS, 1,
440 [Define if X11 doesn't support AF_UNIX sockets on that system]) 442 [Define if X11 doesn't support AF_UNIX sockets on that system])
441 AC_DEFINE(NO_IPPORT_RESERVED_CONCEPT, 1, 443 AC_DEFINE(NO_IPPORT_RESERVED_CONCEPT, 1,
@@ -444,9 +446,11 @@ int main(void) { exit(0); }
444 AC_DEFINE(DISABLE_FD_PASSING, 1, 446 AC_DEFINE(DISABLE_FD_PASSING, 1,
445 [Define if your platform needs to skip post auth 447 [Define if your platform needs to skip post auth
446 file descriptor passing]) 448 file descriptor passing])
449 AC_DEFINE(SSH_IOBUFSZ, 65536, [Windows is sensitive to read buffer size])
447 ;; 450 ;;
448*-*-dgux*) 451*-*-dgux*)
449 AC_DEFINE(IP_TOS_IS_BROKEN) 452 AC_DEFINE(IP_TOS_IS_BROKEN, 1,
453 [Define if your system choked on IP TOS setting])
450 AC_DEFINE(SETEUID_BREAKS_SETUID) 454 AC_DEFINE(SETEUID_BREAKS_SETUID)
451 AC_DEFINE(BROKEN_SETREUID) 455 AC_DEFINE(BROKEN_SETREUID)
452 AC_DEFINE(BROKEN_SETREGID) 456 AC_DEFINE(BROKEN_SETREGID)
@@ -692,6 +696,7 @@ mips-sony-bsd|mips-sony-newsos4)
692 after setsid()]) 696 after setsid()])
693 AC_DEFINE(PASSWD_NEEDS_USERNAME, 1, [must supply username to passwd 697 AC_DEFINE(PASSWD_NEEDS_USERNAME, 1, [must supply username to passwd
694 in case the name is longer than 8 chars]) 698 in case the name is longer than 8 chars])
699 AC_DEFINE(BROKEN_TCGETATTR_ICANON, 1, [tcgetattr with ICANON may hang])
695 external_path_file=/etc/default/login 700 external_path_file=/etc/default/login
696 # hardwire lastlog location (can't detect it on some versions) 701 # hardwire lastlog location (can't detect it on some versions)
697 conf_lastlog_location="/var/adm/lastlog" 702 conf_lastlog_location="/var/adm/lastlog"
@@ -1003,6 +1008,7 @@ AC_ARG_WITH(zlib,
1003 fi ] 1008 fi ]
1004) 1009)
1005 1010
1011AC_CHECK_HEADER([zlib.h], ,AC_MSG_ERROR([*** zlib.h missing - please install first or check config.log ***]))
1006AC_CHECK_LIB(z, deflate, , 1012AC_CHECK_LIB(z, deflate, ,
1007 [ 1013 [
1008 saved_CPPFLAGS="$CPPFLAGS" 1014 saved_CPPFLAGS="$CPPFLAGS"
@@ -1023,7 +1029,6 @@ AC_CHECK_LIB(z, deflate, ,
1023 ) 1029 )
1024 ] 1030 ]
1025) 1031)
1026AC_CHECK_HEADER([zlib.h], ,AC_MSG_ERROR([*** zlib.h missing - please install first or check config.log ***]))
1027 1032
1028AC_ARG_WITH(zlib-version-check, 1033AC_ARG_WITH(zlib-version-check,
1029 [ --without-zlib-version-check Disable zlib version check], 1034 [ --without-zlib-version-check Disable zlib version check],
@@ -1916,6 +1921,8 @@ AC_TRY_LINK_FUNC(RAND_add, AC_DEFINE(HAVE_OPENSSL, 1,
1916 LDFLAGS="-L/usr/local/ssl/lib ${saved_LDFLAGS}" 1921 LDFLAGS="-L/usr/local/ssl/lib ${saved_LDFLAGS}"
1917 fi 1922 fi
1918 CPPFLAGS="-I/usr/local/ssl/include ${saved_CPPFLAGS}" 1923 CPPFLAGS="-I/usr/local/ssl/include ${saved_CPPFLAGS}"
1924 AC_CHECK_HEADER([openssl/opensslv.h], ,
1925 AC_MSG_ERROR([*** OpenSSL headers missing - please install first or check config.log ***]))
1919 AC_TRY_LINK_FUNC(RAND_add, AC_DEFINE(HAVE_OPENSSL), 1926 AC_TRY_LINK_FUNC(RAND_add, AC_DEFINE(HAVE_OPENSSL),
1920 [ 1927 [
1921 AC_MSG_ERROR([*** Can't find recent OpenSSL libcrypto (see config.log for details) ***]) 1928 AC_MSG_ERROR([*** Can't find recent OpenSSL libcrypto (see config.log for details) ***])
@@ -2100,6 +2107,23 @@ int main(void) { exit(EVP_aes_192_cbc() == NULL || EVP_aes_256_cbc() == NULL);}
2100 ] 2107 ]
2101) 2108)
2102 2109
2110AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2111AC_LINK_IFELSE(
2112 [AC_LANG_SOURCE([[
2113#include <string.h>
2114#include <openssl/evp.h>
2115int main(void) { if(EVP_DigestUpdate(NULL, NULL,0)) exit(0); }
2116 ]])],
2117 [
2118 AC_MSG_RESULT(yes)
2119 ],
2120 [
2121 AC_MSG_RESULT(no)
2122 AC_DEFINE(OPENSSL_EVP_DIGESTUPDATE_VOID, 1,
2123 [Define if EVP_DigestUpdate returns void])
2124 ]
2125)
2126
2103# Some systems want crypt() from libcrypt, *not* the version in OpenSSL, 2127# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
2104# because the system crypt() is more featureful. 2128# because the system crypt() is more featureful.
2105if test "x$check_for_libcrypt_before" = "x1"; then 2129if test "x$check_for_libcrypt_before" = "x1"; then
@@ -2718,7 +2742,7 @@ AC_CHECK_TYPES([fsblkcnt_t, fsfilcnt_t],,,[
2718#endif 2742#endif
2719]) 2743])
2720 2744
2721AC_CHECK_TYPES(in_addr_t,,, 2745AC_CHECK_TYPES([in_addr_t, in_port_t],,,
2722[#include <sys/types.h> 2746[#include <sys/types.h>
2723#include <netinet/in.h>]) 2747#include <netinet/in.h>])
2724 2748
@@ -3088,15 +3112,41 @@ if test "x$ac_cv_have_accrights_in_msghdr" = "xyes" ; then
3088 file descriptor passing]) 3112 file descriptor passing])
3089fi 3113fi
3090 3114
3091AC_MSG_CHECKING(if f_fsid has val members) 3115AC_MSG_CHECKING(if struct statvfs.f_fsid is integral type)
3092AC_TRY_COMPILE([ 3116AC_TRY_COMPILE([
3093#include <sys/types.h> 3117#include <sys/types.h>
3118#include <sys/stat.h>
3119#ifdef HAVE_SYS_TIME_H
3120# include <sys/time.h>
3121#endif
3122#ifdef HAVE_SYS_MOUNT_H
3123#include <sys/mount.h>
3124#endif
3125#ifdef HAVE_SYS_STATVFS_H
3126#include <sys/statvfs.h>
3127#endif
3128], [struct statvfs s; s.f_fsid = 0;],
3129[ AC_MSG_RESULT(yes) ],
3130[ AC_MSG_RESULT(no)
3131
3132 AC_MSG_CHECKING(if fsid_t has member val)
3133 AC_TRY_COMPILE([
3134#include <sys/types.h>
3094#include <sys/statvfs.h>], 3135#include <sys/statvfs.h>],
3095[struct fsid_t t; t.val[0] = 0;], 3136 [fsid_t t; t.val[0] = 0;],
3096 [ AC_MSG_RESULT(yes) 3137 [ AC_MSG_RESULT(yes)
3097 AC_DEFINE(FSID_HAS_VAL, 1, f_fsid has members) ], 3138 AC_DEFINE(FSID_HAS_VAL, 1, fsid_t has member val) ],
3098 [ AC_MSG_RESULT(no) ] 3139 [ AC_MSG_RESULT(no) ])
3099) 3140
3141 AC_MSG_CHECKING(if f_fsid has member __val)
3142 AC_TRY_COMPILE([
3143#include <sys/types.h>
3144#include <sys/statvfs.h>],
3145 [fsid_t t; t.__val[0] = 0;],
3146 [ AC_MSG_RESULT(yes)
3147 AC_DEFINE(FSID_HAS___VAL, 1, fsid_t has member __val) ],
3148 [ AC_MSG_RESULT(no) ])
3149])
3100 3150
3101AC_CACHE_CHECK([for msg_control field in struct msghdr], 3151AC_CACHE_CHECK([for msg_control field in struct msghdr],
3102 ac_cv_have_control_in_msghdr, [ 3152 ac_cv_have_control_in_msghdr, [
@@ -3298,12 +3348,30 @@ AC_SEARCH_LIBS(getrrsetbyname, resolv,
3298 AC_SEARCH_LIBS(res_query, resolv) 3348 AC_SEARCH_LIBS(res_query, resolv)
3299 AC_SEARCH_LIBS(dn_expand, resolv) 3349 AC_SEARCH_LIBS(dn_expand, resolv)
3300 AC_MSG_CHECKING(if res_query will link) 3350 AC_MSG_CHECKING(if res_query will link)
3301 AC_TRY_LINK_FUNC(res_query, AC_MSG_RESULT(yes), 3351 AC_LINK_IFELSE([
3352#include "confdefs.h"
3353#include <sys/types.h>
3354#include <netinet/in.h>
3355#include <arpa/nameser.h>
3356#include <netdb.h>
3357#include <resolv.h>
3358int main()
3359{
3360 res_query (0, 0, 0, 0, 0);
3361 return 0;
3362}
3363 ],
3364 AC_MSG_RESULT(yes),
3302 [AC_MSG_RESULT(no) 3365 [AC_MSG_RESULT(no)
3303 saved_LIBS="$LIBS" 3366 saved_LIBS="$LIBS"
3304 LIBS="$LIBS -lresolv" 3367 LIBS="$LIBS -lresolv"
3305 AC_MSG_CHECKING(for res_query in -lresolv) 3368 AC_MSG_CHECKING(for res_query in -lresolv)
3306 AC_LINK_IFELSE([ 3369 AC_LINK_IFELSE([
3370#include "confdefs.h"
3371#include <sys/types.h>
3372#include <netinet/in.h>
3373#include <arpa/nameser.h>
3374#include <netdb.h>
3307#include <resolv.h> 3375#include <resolv.h>
3308int main() 3376int main()
3309{ 3377{
@@ -3311,8 +3379,7 @@ int main()
3311 return 0; 3379 return 0;
3312} 3380}
3313 ], 3381 ],
3314 [LIBS="$LIBS -lresolv" 3382 [AC_MSG_RESULT(yes)],
3315 AC_MSG_RESULT(yes)],
3316 [LIBS="$saved_LIBS" 3383 [LIBS="$saved_LIBS"
3317 AC_MSG_RESULT(no)]) 3384 AC_MSG_RESULT(no)])
3318 ]) 3385 ])
@@ -3378,10 +3445,10 @@ AC_ARG_WITH(kerberos5,
3378 AC_DEFINE(KRB5, 1, [Define if you want Kerberos 5 support]) 3445 AC_DEFINE(KRB5, 1, [Define if you want Kerberos 5 support])
3379 KRB5_MSG="yes" 3446 KRB5_MSG="yes"
3380 3447
3381 AC_MSG_CHECKING(for krb5-config) 3448 AC_PATH_PROG([KRB5CONF],[krb5-config],
3382 if test -x $KRB5ROOT/bin/krb5-config ; then 3449 [$KRB5ROOT/bin/krb5-config],
3383 KRB5CONF=$KRB5ROOT/bin/krb5-config 3450 [$KRB5ROOT/bin:$PATH])
3384 AC_MSG_RESULT($KRB5CONF) 3451 if test -x $KRB5CONF ; then
3385 3452
3386 AC_MSG_CHECKING(for gssapi support) 3453 AC_MSG_CHECKING(for gssapi support)
3387 if $KRB5CONF | grep gssapi >/dev/null ; then 3454 if $KRB5CONF | grep gssapi >/dev/null ; then
@@ -3407,7 +3474,6 @@ AC_ARG_WITH(kerberos5,
3407 AC_MSG_RESULT(no) 3474 AC_MSG_RESULT(no)
3408 ) 3475 )
3409 else 3476 else
3410 AC_MSG_RESULT(no)
3411 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include" 3477 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include"
3412 LDFLAGS="$LDFLAGS -L${KRB5ROOT}/lib" 3478 LDFLAGS="$LDFLAGS -L${KRB5ROOT}/lib"
3413 AC_MSG_CHECKING(whether we are using Heimdal) 3479 AC_MSG_CHECKING(whether we are using Heimdal)