summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-01-01 17:15:23 +0000
committerColin Watson <cjwatson@debian.org>2010-01-01 17:15:23 +0000
commit99b402ea4c8457b0a3cafff37f5b3410a8dc6476 (patch)
tree1d24ce54c9981ea8cbb4c5a9309964a0e4c4b320 /configure.ac
parent87552344215a38d3a2b0d4d63dc151e05978bbe1 (diff)
parent54af7a4ae8d455791a631bdfaade4b64436ae16a (diff)
import openssh-5.2p1-gsskex-all-20090726.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 34 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ba9d9a37a..bd393b592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.409 2008/07/09 11:07:19 djm Exp $ 1# $Id: configure.ac,v 1.415 2009/02/16 04:37:03 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.409 $) 18AC_REVISION($Revision: 1.415 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -126,7 +126,7 @@ int main(void){char b[10]; memset(b, 0, sizeof(b));}
126 126
127 # -fstack-protector-all doesn't always work for some GCC versions 127 # -fstack-protector-all doesn't always work for some GCC versions
128 # and/or platforms, so we test if we can. If it's not supported 128 # and/or platforms, so we test if we can. If it's not supported
129 # on a give platform gcc will emit a warning so we use -Werror. 129 # on a given platform gcc will emit a warning so we use -Werror.
130 if test "x$use_stack_protector" = "x1"; then 130 if test "x$use_stack_protector" = "x1"; then
131 for t in -fstack-protector-all -fstack-protector; do 131 for t in -fstack-protector-all -fstack-protector; do
132 AC_MSG_CHECKING(if $CC supports $t) 132 AC_MSG_CHECKING(if $CC supports $t)
@@ -136,8 +136,8 @@ int main(void){char b[10]; memset(b, 0, sizeof(b));}
136 LDFLAGS="$LDFLAGS $t -Werror" 136 LDFLAGS="$LDFLAGS $t -Werror"
137 AC_LINK_IFELSE( 137 AC_LINK_IFELSE(
138 [AC_LANG_SOURCE([ 138 [AC_LANG_SOURCE([
139#include <stdlib.h> 139#include <stdio.h>
140int main(void){return 0;} 140int main(void){char x[[256]]; snprintf(x, sizeof(x), "XXX"); return 0;}
141 ])], 141 ])],
142 [ AC_MSG_RESULT(yes) 142 [ AC_MSG_RESULT(yes)
143 CFLAGS="$saved_CFLAGS $t" 143 CFLAGS="$saved_CFLAGS $t"
@@ -145,8 +145,8 @@ int main(void){return 0;}
145 AC_MSG_CHECKING(if $t works) 145 AC_MSG_CHECKING(if $t works)
146 AC_RUN_IFELSE( 146 AC_RUN_IFELSE(
147 [AC_LANG_SOURCE([ 147 [AC_LANG_SOURCE([
148#include <stdlib.h> 148#include <stdio.h>
149int main(void){exit(0);} 149int main(void){char x[[256]]; snprintf(x, sizeof(x), "XXX"); return 0;}
150 ])], 150 ])],
151 [ AC_MSG_RESULT(yes) 151 [ AC_MSG_RESULT(yes)
152 break ], 152 break ],
@@ -501,6 +501,8 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
501 AC_CHECK_DECL(AU_IPv4, [], 501 AC_CHECK_DECL(AU_IPv4, [],
502 AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) 502 AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records])
503 [#include <bsm/audit.h>] 503 [#include <bsm/audit.h>]
504 AC_DEFINE(LASTLOG_WRITE_PUTUTXLINE, 1,
505 [Define if pututxline updates lastlog too])
504 ) 506 )
505 ;; 507 ;;
506*-*-dragonfly*) 508*-*-dragonfly*)
@@ -585,6 +587,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
585 AC_DEFINE(WITH_ABBREV_NO_TTY) 587 AC_DEFINE(WITH_ABBREV_NO_TTY)
586 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 588 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
587 ;; 589 ;;
590*-*-k*bsd*-gnu | *-*-kopensolaris*-gnu)
591 check_for_libcrypt_later=1
592 AC_DEFINE(PAM_TTY_KLUDGE)
593 AC_DEFINE(LOCKED_PASSWD_PREFIX, "!")
594 AC_DEFINE(SPT_TYPE,SPT_REUSEARGV)
595 AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts])
596 AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins])
597 ;;
588*-*-linux*) 598*-*-linux*)
589 no_dev_ptmx=1 599 no_dev_ptmx=1
590 check_for_libcrypt_later=1 600 check_for_libcrypt_later=1
@@ -752,7 +762,6 @@ mips-sony-bsd|mips-sony-newsos4)
752 ;; 762 ;;
753# UnixWare 7.x, OpenUNIX 8 763# UnixWare 7.x, OpenUNIX 8
754*-*-sysv5*) 764*-*-sysv5*)
755 check_for_libcrypt_later=1
756 AC_DEFINE(UNIXWARE_LONG_PASSWORDS, 1, [Support passwords > 8 chars]) 765 AC_DEFINE(UNIXWARE_LONG_PASSWORDS, 1, [Support passwords > 8 chars])
757 AC_DEFINE(USE_PIPES) 766 AC_DEFINE(USE_PIPES)
758 AC_DEFINE(SETEUID_BREAKS_SETUID) 767 AC_DEFINE(SETEUID_BREAKS_SETUID)
@@ -765,8 +774,14 @@ mips-sony-bsd|mips-sony-newsos4)
765 AC_DEFINE(BROKEN_LIBIAF, 1, 774 AC_DEFINE(BROKEN_LIBIAF, 1,
766 [ia_uinfo routines not supported by OS yet]) 775 [ia_uinfo routines not supported by OS yet])
767 AC_DEFINE(BROKEN_UPDWTMPX) 776 AC_DEFINE(BROKEN_UPDWTMPX)
777 AC_CHECK_LIB(prot, getluid,[ LIBS="$LIBS -lprot"
778 AC_CHECK_FUNCS(getluid setluid,,,-lprot)
779 AC_DEFINE(HAVE_SECUREWARE)
780 AC_DEFINE(DISABLE_SHADOW)
781 ],,)
768 ;; 782 ;;
769 *) AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 783 *) AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
784 check_for_libcrypt_later=1
770 ;; 785 ;;
771 esac 786 esac
772 ;; 787 ;;
@@ -1527,6 +1542,8 @@ AC_CHECK_FUNCS(utmpname)
1527dnl Checks for utmpx functions 1542dnl Checks for utmpx functions
1528AC_CHECK_FUNCS(endutxent getutxent getutxid getutxline pututxline ) 1543AC_CHECK_FUNCS(endutxent getutxent getutxid getutxline pututxline )
1529AC_CHECK_FUNCS(setutxent utmpxname) 1544AC_CHECK_FUNCS(setutxent utmpxname)
1545dnl Checks for lastlog functions
1546AC_CHECK_FUNCS(getlastlogxbyname)
1530 1547
1531AC_CHECK_FUNC(daemon, 1548AC_CHECK_FUNC(daemon,
1532 [AC_DEFINE(HAVE_DAEMON, 1, [Define if your libraries define daemon()])], 1549 [AC_DEFINE(HAVE_DAEMON, 1, [Define if your libraries define daemon()])],
@@ -2848,6 +2865,15 @@ AC_CACHE_CHECK([for struct in6_addr], ac_cv_have_struct_in6_addr, [
2848if test "x$ac_cv_have_struct_in6_addr" = "xyes" ; then 2865if test "x$ac_cv_have_struct_in6_addr" = "xyes" ; then
2849 AC_DEFINE(HAVE_STRUCT_IN6_ADDR, 1, 2866 AC_DEFINE(HAVE_STRUCT_IN6_ADDR, 1,
2850 [define if you have struct in6_addr data type]) 2867 [define if you have struct in6_addr data type])
2868
2869dnl Now check for sin6_scope_id
2870 AC_CHECK_MEMBERS([struct sockaddr_in6.sin6_scope_id],,,
2871 [
2872#ifdef HAVE_SYS_TYPES_H
2873#include <sys/types.h>
2874#endif
2875#include <netinet/in.h>
2876 ])
2851fi 2877fi
2852 2878
2853AC_CACHE_CHECK([for struct addrinfo], ac_cv_have_struct_addrinfo, [ 2879AC_CACHE_CHECK([for struct addrinfo], ac_cv_have_struct_addrinfo, [