summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-12-21 16:08:47 +0000
committerColin Watson <cjwatson@debian.org>2020-02-21 12:10:36 +0000
commita208834b2d1811dac7054d7fdcdd04672f8b19f6 (patch)
tree516663911b9ce2649973957bd359aae77dc82b8a /configure.ac
parent63da84c3570afb4fa6bab38fdac3e9af45d0ec54 (diff)
Add systemd readiness notification support
Bug-Debian: https://bugs.debian.org/778913 Forwarded: no Last-Update: 2017-08-22 Patch-Name: systemd-readiness.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cee7cbc51..5db3013de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4664,6 +4664,29 @@ AC_ARG_WITH([kerberos5],
4664AC_SUBST([GSSLIBS]) 4664AC_SUBST([GSSLIBS])
4665AC_SUBST([K5LIBS]) 4665AC_SUBST([K5LIBS])
4666 4666
4667# Check whether user wants systemd support
4668SYSTEMD_MSG="no"
4669AC_ARG_WITH(systemd,
4670 [ --with-systemd Enable systemd support],
4671 [ if test "x$withval" != "xno" ; then
4672 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4673 if test "$PKGCONFIG" != "no"; then
4674 AC_MSG_CHECKING([for libsystemd])
4675 if $PKGCONFIG --exists libsystemd; then
4676 SYSTEMD_CFLAGS=`$PKGCONFIG --cflags libsystemd`
4677 SYSTEMD_LIBS=`$PKGCONFIG --libs libsystemd`
4678 CPPFLAGS="$CPPFLAGS $SYSTEMD_CFLAGS"
4679 SSHDLIBS="$SSHDLIBS $SYSTEMD_LIBS"
4680 AC_MSG_RESULT([yes])
4681 AC_DEFINE(HAVE_SYSTEMD, 1, [Define if you want systemd support.])
4682 SYSTEMD_MSG="yes"
4683 else
4684 AC_MSG_RESULT([no])
4685 fi
4686 fi
4687 fi ]
4688)
4689
4667# Looking for programs, paths and files 4690# Looking for programs, paths and files
4668 4691
4669PRIVSEP_PATH=/var/empty 4692PRIVSEP_PATH=/var/empty
@@ -5476,6 +5499,7 @@ echo " libldns support: $LDNS_MSG"
5476echo " Solaris process contract support: $SPC_MSG" 5499echo " Solaris process contract support: $SPC_MSG"
5477echo " Solaris project support: $SP_MSG" 5500echo " Solaris project support: $SP_MSG"
5478echo " Solaris privilege support: $SPP_MSG" 5501echo " Solaris privilege support: $SPP_MSG"
5502echo " systemd support: $SYSTEMD_MSG"
5479echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 5503echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
5480echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 5504echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
5481echo " BSD Auth support: $BSD_AUTH_MSG" 5505echo " BSD Auth support: $BSD_AUTH_MSG"