summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2008-02-04 09:47:29 +0000
committerColin Watson <cjwatson@debian.org>2008-02-04 09:47:29 +0000
commita2418b21add72037f3f16163c13c8cfe246a1292 (patch)
tree67fc350946307bf161e0a7c94bf07a45f1f62ccb /configure.ac
parente0d15aa5dbdb9dc8f57f3550f4e9cde446fefc8c (diff)
* Fix configure detection of getseuserbyname and
get_default_context_with_level (LP: #188136).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 64ef3c67b..487a9d6ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3239,9 +3239,12 @@ AC_ARG_WITH(selinux,
3239 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) 3239 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
3240 SELINUX_MSG="yes" 3240 SELINUX_MSG="yes"
3241 AC_CHECK_HEADER([selinux/selinux.h], , 3241 AC_CHECK_HEADER([selinux/selinux.h], ,
3242 AC_MSG_ERROR(SELinux support requires selinux.h header)) 3242 AC_MSG_ERROR(SELinux support requires selinux.h header))
3243 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], 3243 AC_CHECK_LIB(selinux, setexeccon,
3244 AC_MSG_ERROR(SELinux support requires libselinux library)) 3244 [ LIBSELINUX="-lselinux"
3245 LIBS="$LIBS -lselinux"
3246 ],
3247 AC_MSG_ERROR(SELinux support requires libselinux library))
3245 SSHDLIBS="$SSHDLIBS $LIBSELINUX" 3248 SSHDLIBS="$SSHDLIBS $LIBSELINUX"
3246 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) 3249 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
3247 LIBS="$save_LIBS" 3250 LIBS="$save_LIBS"