summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2002-04-05 16:11:45 +0000
committerBen Lindstrom <mouring@eviladmin.org>2002-04-05 16:11:45 +0000
commita42694fa25683488b4dc44abc9dc8bb55414c99f (patch)
treeb642a80c3e482ed6a792d4f540719fd6af743212 /configure.ac
parent8a725a843d51b4fe43e9653eea5442c368290fe2 (diff)
- (bal) Patch for OpenSC SmartCard library; ok markus@; patch by
Juha Yrjölä <jyrjola@cc.hut.fi> - (bal) Minor documentation update to reflect smartcard library support changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 37 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 09607b07d..6bd29254e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.30 2002/03/31 19:23:07 tim Exp $ 1# $Id: configure.ac,v 1.31 2002/04/05 16:11:46 mouring Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1667,11 +1667,11 @@ if test "x$ac_cv_libc_defines_sys_nerr" = "xyes" ; then
1667 AC_DEFINE(HAVE_SYS_NERR) 1667 AC_DEFINE(HAVE_SYS_NERR)
1668fi 1668fi
1669 1669
1670
1671# Check whether user wants Kerberos support
1672SCARD_MSG="no" 1670SCARD_MSG="no"
1673AC_ARG_WITH(smartcard, 1671
1674 [ --with-smartcard Enable smartcard support], 1672# Check whether user wants sectok support
1673AC_ARG_WITH(sectok,
1674 [ --with-sectok Enable smartcard support using libsectok],
1675 [ 1675 [
1676 if test "x$withval" != "xno" ; then 1676 if test "x$withval" != "xno" ; then
1677 if test "x$withval" != "xyes" ; then 1677 if test "x$withval" != "xyes" ; then
@@ -1693,7 +1693,38 @@ AC_ARG_WITH(smartcard,
1693 AC_MSG_ERROR(Can't find libsectok) 1693 AC_MSG_ERROR(Can't find libsectok)
1694 fi 1694 fi
1695 AC_DEFINE(SMARTCARD) 1695 AC_DEFINE(SMARTCARD)
1696 SCARD_MSG="yes" 1696 AC_DEFINE(USE_SECTOK)
1697 SCARD_MSG="yes, using sectok"
1698 fi
1699 ]
1700)
1701
1702# Check whether user wants OpenSC support
1703AC_ARG_WITH(opensc,
1704 [ --with-opensc Enable smartcard support using OpenSC],
1705 [
1706 if test "x$withval" != "xno" ; then
1707 if test "x$withval" != "xyes" ; then
1708 CPPFLAGS="$CPPFLAGS -I${withval}"
1709 LDFLAGS="$LDFLAGS -L${withval}"
1710 if test ! -z "$need_dash_r" ; then
1711 LDFLAGS="$LDFLAGS -R${withval}"
1712 fi
1713 if test ! -z "$blibpath" ; then
1714 blibpath="$blibpath:${withval}"
1715 fi
1716 fi
1717 AC_CHECK_HEADERS(opensc-pkcs15.h)
1718 if test "$ac_cv_header_opensc_pkcs15_h" != yes; then
1719 AC_MSG_ERROR(Can't find opensc-pkcs15.h)
1720 fi
1721 AC_CHECK_LIB(opensc, sc_pkcs15_bind)
1722 if test "$ac_cv_lib_opensc_sc_pkcs15_bind" != yes; then
1723 AC_MSG_ERROR(Can't find libopensc)
1724 fi
1725 AC_DEFINE(SMARTCARD)
1726 AC_DEFINE(USE_OPENSC)
1727 SCARD_MSG="yes, using OpenSC"
1697 fi 1728 fi
1698 ] 1729 ]
1699) 1730)