summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-12-21 16:08:47 +0000
committerColin Watson <cjwatson@debian.org>2019-10-09 23:07:49 +0100
commitab765b2bd55062a704f09da8f8c1c4ad1d6630a7 (patch)
tree4666d70abf9be2304f2f7d882166f53b2812c490 /configure.ac
parent4360244ab2ed367bdb2c836292e761c589355950 (diff)
Add systemd readiness notification support
Bug-Debian: https://bugs.debian.org/778913 Forwarded: no Last-Update: 2017-08-22 Patch-Name: systemd-readiness.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e894db9fc..c119d6fd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4499,6 +4499,29 @@ AC_ARG_WITH([kerberos5],
4499AC_SUBST([GSSLIBS]) 4499AC_SUBST([GSSLIBS])
4500AC_SUBST([K5LIBS]) 4500AC_SUBST([K5LIBS])
4501 4501
4502# Check whether user wants systemd support
4503SYSTEMD_MSG="no"
4504AC_ARG_WITH(systemd,
4505 [ --with-systemd Enable systemd support],
4506 [ if test "x$withval" != "xno" ; then
4507 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4508 if test "$PKGCONFIG" != "no"; then
4509 AC_MSG_CHECKING([for libsystemd])
4510 if $PKGCONFIG --exists libsystemd; then
4511 SYSTEMD_CFLAGS=`$PKGCONFIG --cflags libsystemd`
4512 SYSTEMD_LIBS=`$PKGCONFIG --libs libsystemd`
4513 CPPFLAGS="$CPPFLAGS $SYSTEMD_CFLAGS"
4514 SSHDLIBS="$SSHDLIBS $SYSTEMD_LIBS"
4515 AC_MSG_RESULT([yes])
4516 AC_DEFINE(HAVE_SYSTEMD, 1, [Define if you want systemd support.])
4517 SYSTEMD_MSG="yes"
4518 else
4519 AC_MSG_RESULT([no])
4520 fi
4521 fi
4522 fi ]
4523)
4524
4502# Looking for programs, paths and files 4525# Looking for programs, paths and files
4503 4526
4504PRIVSEP_PATH=/var/empty 4527PRIVSEP_PATH=/var/empty
@@ -5305,6 +5328,7 @@ echo " libldns support: $LDNS_MSG"
5305echo " Solaris process contract support: $SPC_MSG" 5328echo " Solaris process contract support: $SPC_MSG"
5306echo " Solaris project support: $SP_MSG" 5329echo " Solaris project support: $SP_MSG"
5307echo " Solaris privilege support: $SPP_MSG" 5330echo " Solaris privilege support: $SPP_MSG"
5331echo " systemd support: $SYSTEMD_MSG"
5308echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 5332echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
5309echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 5333echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
5310echo " BSD Auth support: $BSD_AUTH_MSG" 5334echo " BSD Auth support: $BSD_AUTH_MSG"