summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2008-02-28 15:01:13 +1100
committerDarren Tucker <dtucker@zip.com.au>2008-02-28 15:01:13 +1100
commite1c4c542116fd41eec7dcb0d0b40d0797181c959 (patch)
treea638e699aa2896a7e521928606fb30a684e4eb4a /configure.ac
parent935e20a3f0b1bfbec50217d28983186cfd1ad203 (diff)
- (dtucker) [configure.ac] Add -fstack-protector to LDFLAGS too, fixes
linking problems on AIX with gcc 4.1.x.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f9e2d8b34..eaa1f845a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.390 2008/02/25 10:05:04 dtucker Exp $ 1# $Id: configure.ac,v 1.391 2008/02/28 04:01:13 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.390 $) 18AC_REVISION($Revision: 1.391 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -107,11 +107,15 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
107 107
108 AC_MSG_CHECKING(if $CC understands -fstack-protector-all) 108 AC_MSG_CHECKING(if $CC understands -fstack-protector-all)
109 saved_CFLAGS="$CFLAGS" 109 saved_CFLAGS="$CFLAGS"
110 saved_LDFLAGS="$LDFLAGS"
110 CFLAGS="$CFLAGS -fstack-protector-all" 111 CFLAGS="$CFLAGS -fstack-protector-all"
111 AC_TRY_COMPILE([], [ int main(void){return 0;} ], 112 LDFLAGS="$LDFLAGS -fstack-protector-all"
113 AC_TRY_LINK([], [ int main(void){return 0;} ],
112 [ AC_MSG_RESULT(yes) ], 114 [ AC_MSG_RESULT(yes) ],
113 [ AC_MSG_RESULT(no) 115 [ AC_MSG_RESULT(no)
114 CFLAGS="$saved_CFLAGS" ] 116 CFLAGS="$saved_CFLAGS"
117 LDFLAGS="$saved_LDFLAGS"
118 ]
115 ) 119 )
116 120
117 if test -z "$have_llong_max"; then 121 if test -z "$have_llong_max"; then