summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-03-17 16:52:20 -0800
committerTim Rice <tim@multitalents.net>2005-03-17 16:52:20 -0800
commiteae17cc80ec1083a06eaa062547b926d01b91798 (patch)
tree5caa56a255594544a6a3f9b6e25c2b153664349d /configure.ac
parent35cc69dcb49394f8ce5950e42adc90866901256d (diff)
- (tim) [configure.ac] remove trailing white space.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac60
1 files changed, 30 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index b3f7b5f22..9dce893a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.253 2005/03/18 00:44:26 tim Exp $ 1# $Id: configure.ac,v 1.254 2005/03/18 00:52:21 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -75,7 +75,7 @@ if test -z "$LD" ; then
75 LD=$CC 75 LD=$CC
76fi 76fi
77AC_SUBST(LD) 77AC_SUBST(LD)
78 78
79AC_C_INLINE 79AC_C_INLINE
80if test "$GCC" = "yes" || test "$GCC" = "egcs"; then 80if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
81 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized" 81 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized"
@@ -84,7 +84,7 @@ fi
84AC_ARG_WITH(rpath, 84AC_ARG_WITH(rpath,
85 [ --without-rpath Disable auto-added -R linker paths], 85 [ --without-rpath Disable auto-added -R linker paths],
86 [ 86 [
87 if test "x$withval" = "xno" ; then 87 if test "x$withval" = "xno" ; then
88 need_dash_r="" 88 need_dash_r=""
89 fi 89 fi
90 if test "x$withval" = "xyes" ; then 90 if test "x$withval" = "xyes" ; then
@@ -274,7 +274,7 @@ mips-sony-bsd|mips-sony-newsos4)
274 ;; 274 ;;
275*-*-netbsd*) 275*-*-netbsd*)
276 check_for_libcrypt_before=1 276 check_for_libcrypt_before=1
277 if test "x$withval" != "xno" ; then 277 if test "x$withval" != "xno" ; then
278 need_dash_r=1 278 need_dash_r=1
279 fi 279 fi
280 ;; 280 ;;
@@ -297,7 +297,7 @@ mips-sony-bsd|mips-sony-newsos4)
297 AC_DEFINE(BROKEN_SAVED_UIDS) 297 AC_DEFINE(BROKEN_SAVED_UIDS)
298 ;; 298 ;;
299*-*-solaris*) 299*-*-solaris*)
300 if test "x$withval" != "xno" ; then 300 if test "x$withval" != "xno" ; then
301 need_dash_r=1 301 need_dash_r=1
302 fi 302 fi
303 AC_DEFINE(PAM_SUN_CODEBASE) 303 AC_DEFINE(PAM_SUN_CODEBASE)
@@ -476,7 +476,7 @@ AC_ARG_WITH(cflags,
476 test "x${withval}" != "xyes"; then 476 test "x${withval}" != "xyes"; then
477 CFLAGS="$CFLAGS $withval" 477 CFLAGS="$CFLAGS $withval"
478 fi 478 fi
479 ] 479 ]
480) 480)
481AC_ARG_WITH(cppflags, 481AC_ARG_WITH(cppflags,
482 [ --with-cppflags Specify additional flags to pass to preprocessor] , 482 [ --with-cppflags Specify additional flags to pass to preprocessor] ,
@@ -494,7 +494,7 @@ AC_ARG_WITH(ldflags,
494 test "x${withval}" != "xyes"; then 494 test "x${withval}" != "xyes"; then
495 LDFLAGS="$LDFLAGS $withval" 495 LDFLAGS="$LDFLAGS $withval"
496 fi 496 fi
497 ] 497 ]
498) 498)
499AC_ARG_WITH(libs, 499AC_ARG_WITH(libs,
500 [ --with-libs Specify additional libraries to link with], 500 [ --with-libs Specify additional libraries to link with],
@@ -503,7 +503,7 @@ AC_ARG_WITH(libs,
503 test "x${withval}" != "xyes"; then 503 test "x${withval}" != "xyes"; then
504 LIBS="$LIBS $withval" 504 LIBS="$LIBS $withval"
505 fi 505 fi
506 ] 506 ]
507) 507)
508 508
509AC_MSG_CHECKING(compiler and flags for sanity) 509AC_MSG_CHECKING(compiler and flags for sanity)
@@ -734,7 +734,7 @@ int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));}
734 AC_MSG_RESULT(no) 734 AC_MSG_RESULT(no)
735 AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME) 735 AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
736 ], 736 ],
737 [ 737 [
738 AC_MSG_WARN([cross compiling: assuming BROKEN_ONE_BYTE_DIRENT_D_NAME]) 738 AC_MSG_WARN([cross compiling: assuming BROKEN_ONE_BYTE_DIRENT_D_NAME])
739 AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME) 739 AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
740 ] 740 ]
@@ -763,7 +763,7 @@ AC_ARG_WITH(skey,
763 AC_DEFINE(SKEY) 763 AC_DEFINE(SKEY)
764 LIBS="-lskey $LIBS" 764 LIBS="-lskey $LIBS"
765 SKEY_MSG="yes" 765 SKEY_MSG="yes"
766 766
767 AC_MSG_CHECKING([for s/key support]) 767 AC_MSG_CHECKING([for s/key support])
768 AC_TRY_RUN( 768 AC_TRY_RUN(
769 [ 769 [
@@ -1474,7 +1474,7 @@ int main(void) { exit(RAND_status() == 1 ? 0 : 1); }
1474 [ 1474 [
1475 AC_MSG_WARN([cross compiling: assuming yes]) 1475 AC_MSG_WARN([cross compiling: assuming yes])
1476 # This is safe, since all recent OpenSSL versions will 1476 # This is safe, since all recent OpenSSL versions will
1477 # complain at runtime if not seeded correctly. 1477 # complain at runtime if not seeded correctly.
1478 OPENSSL_SEEDS_ITSELF=yes 1478 OPENSSL_SEEDS_ITSELF=yes
1479 ] 1479 ]
1480) 1480)
@@ -1496,7 +1496,7 @@ AC_ARG_WITH(rand-helper,
1496 USE_RAND_HELPER=yes 1496 USE_RAND_HELPER=yes
1497 fi 1497 fi
1498 ], 1498 ],
1499) 1499)
1500 1500
1501# Which randomness source do we use? 1501# Which randomness source do we use?
1502if test ! -z "$OPENSSL_SEEDS_ITSELF" && test -z "$USE_RAND_HELPER" ; then 1502if test ! -z "$OPENSSL_SEEDS_ITSELF" && test -z "$USE_RAND_HELPER" ; then
@@ -1593,7 +1593,7 @@ AC_ARG_WITH(entropy-timeout,
1593 test "x${withval}" != "xyes"; then 1593 test "x${withval}" != "xyes"; then
1594 entropy_timeout=$withval 1594 entropy_timeout=$withval
1595 fi 1595 fi
1596 ] 1596 ]
1597) 1597)
1598AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout) 1598AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout)
1599 1599
@@ -1605,7 +1605,7 @@ AC_ARG_WITH(privsep-user,
1605 test "x${withval}" != "xyes"; then 1605 test "x${withval}" != "xyes"; then
1606 SSH_PRIVSEP_USER=$withval 1606 SSH_PRIVSEP_USER=$withval
1607 fi 1607 fi
1608 ] 1608 ]
1609) 1609)
1610AC_DEFINE_UNQUOTED(SSH_PRIVSEP_USER, "$SSH_PRIVSEP_USER") 1610AC_DEFINE_UNQUOTED(SSH_PRIVSEP_USER, "$SSH_PRIVSEP_USER")
1611AC_SUBST(SSH_PRIVSEP_USER) 1611AC_SUBST(SSH_PRIVSEP_USER)
@@ -2437,7 +2437,7 @@ AC_ARG_WITH(kerberos5,
2437 AC_DEFINE(HEIMDAL) 2437 AC_DEFINE(HEIMDAL)
2438 K5LIBS="-lkrb5 -ldes" 2438 K5LIBS="-lkrb5 -ldes"
2439 K5LIBS="$K5LIBS -lcom_err -lasn1" 2439 K5LIBS="$K5LIBS -lcom_err -lasn1"
2440 AC_CHECK_LIB(roken, net_write, 2440 AC_CHECK_LIB(roken, net_write,
2441 [K5LIBS="$K5LIBS -lroken"]) 2441 [K5LIBS="$K5LIBS -lroken"])
2442 ], 2442 ],
2443 [ AC_MSG_RESULT(no) 2443 [ AC_MSG_RESULT(no)
@@ -2456,7 +2456,7 @@ AC_ARG_WITH(kerberos5,
2456 $K5LIBS) 2456 $K5LIBS)
2457 ], 2457 ],
2458 $K5LIBS) 2458 $K5LIBS)
2459 2459
2460 AC_CHECK_HEADER(gssapi.h, , 2460 AC_CHECK_HEADER(gssapi.h, ,
2461 [ unset ac_cv_header_gssapi_h 2461 [ unset ac_cv_header_gssapi_h
2462 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include/gssapi" 2462 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include/gssapi"
@@ -2626,7 +2626,7 @@ AC_ARG_WITH(md5-passwords,
2626AC_ARG_WITH(shadow, 2626AC_ARG_WITH(shadow,
2627 [ --without-shadow Disable shadow password support], 2627 [ --without-shadow Disable shadow password support],
2628 [ 2628 [
2629 if test "x$withval" = "xno" ; then 2629 if test "x$withval" = "xno" ; then
2630 AC_DEFINE(DISABLE_SHADOW) 2630 AC_DEFINE(DISABLE_SHADOW)
2631 disable_shadow=yes 2631 disable_shadow=yes
2632 fi 2632 fi
@@ -2661,7 +2661,7 @@ else
2661 AC_ARG_WITH(ipaddr-display, 2661 AC_ARG_WITH(ipaddr-display,
2662 [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY], 2662 [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY],
2663 [ 2663 [
2664 if test "x$withval" != "xno" ; then 2664 if test "x$withval" != "xno" ; then
2665 AC_DEFINE(IPADDR_IN_DISPLAY) 2665 AC_DEFINE(IPADDR_IN_DISPLAY)
2666 DISPLAY_HACK_MSG="yes" 2666 DISPLAY_HACK_MSG="yes"
2667 fi 2667 fi
@@ -2707,7 +2707,7 @@ AC_ARG_WITH(default-path,
2707 AC_MSG_WARN([ 2707 AC_MSG_WARN([
2708--with-default-path=PATH has no effect on this system. 2708--with-default-path=PATH has no effect on this system.
2709Edit /etc/login.conf instead.]) 2709Edit /etc/login.conf instead.])
2710 elif test "x$withval" != "xno" ; then 2710 elif test "x$withval" != "xno" ; then
2711 if test ! -z "$external_path_file" ; then 2711 if test ! -z "$external_path_file" ; then
2712 AC_MSG_WARN([ 2712 AC_MSG_WARN([
2713--with-default-path=PATH will only be used if PATH is not defined in 2713--with-default-path=PATH will only be used if PATH is not defined in
@@ -2748,11 +2748,11 @@ main()
2748{ 2748{
2749 FILE *fd; 2749 FILE *fd;
2750 int rc; 2750 int rc;
2751 2751
2752 fd = fopen(DATA,"w"); 2752 fd = fopen(DATA,"w");
2753 if(fd == NULL) 2753 if(fd == NULL)
2754 exit(1); 2754 exit(1);
2755 2755
2756 if ((rc = fprintf(fd,"%s", _PATH_STDPATH)) < 0) 2756 if ((rc = fprintf(fd,"%s", _PATH_STDPATH)) < 0)
2757 exit(1); 2757 exit(1);
2758 2758
@@ -2826,7 +2826,7 @@ BSD_AUTH_MSG=no
2826AC_ARG_WITH(bsd-auth, 2826AC_ARG_WITH(bsd-auth,
2827 [ --with-bsd-auth Enable BSD auth support], 2827 [ --with-bsd-auth Enable BSD auth support],
2828 [ 2828 [
2829 if test "x$withval" != "xno" ; then 2829 if test "x$withval" != "xno" ; then
2830 AC_DEFINE(BSD_AUTH) 2830 AC_DEFINE(BSD_AUTH)
2831 BSD_AUTH_MSG=yes 2831 BSD_AUTH_MSG=yes
2832 fi 2832 fi
@@ -2836,7 +2836,7 @@ AC_ARG_WITH(bsd-auth,
2836# Where to place sshd.pid 2836# Where to place sshd.pid
2837piddir=/var/run 2837piddir=/var/run
2838# make sure the directory exists 2838# make sure the directory exists
2839if test ! -d $piddir ; then 2839if test ! -d $piddir ; then
2840 piddir=`eval echo ${sysconfdir}` 2840 piddir=`eval echo ${sysconfdir}`
2841 case $piddir in 2841 case $piddir in
2842 NONE/*) piddir=`echo $piddir | sed "s~NONE~$ac_default_prefix~"` ;; 2842 NONE/*) piddir=`echo $piddir | sed "s~NONE~$ac_default_prefix~"` ;;
@@ -2849,7 +2849,7 @@ AC_ARG_WITH(pid-dir,
2849 if test -n "$withval" && test "x$withval" != "xno" && \ 2849 if test -n "$withval" && test "x$withval" != "xno" && \
2850 test "x${withval}" != "xyes"; then 2850 test "x${withval}" != "xyes"; then
2851 piddir=$withval 2851 piddir=$withval
2852 if test ! -d $piddir ; then 2852 if test ! -d $piddir ; then
2853 AC_MSG_WARN([** no $piddir directory on this system **]) 2853 AC_MSG_WARN([** no $piddir directory on this system **])
2854 fi 2854 fi
2855 fi 2855 fi
@@ -2927,7 +2927,7 @@ AC_ARG_ENABLE(pututxline,
2927AC_ARG_WITH(lastlog, 2927AC_ARG_WITH(lastlog,
2928 [ --with-lastlog=FILE|DIR specify lastlog location [common locations]], 2928 [ --with-lastlog=FILE|DIR specify lastlog location [common locations]],
2929 [ 2929 [
2930 if test "x$withval" = "xno" ; then 2930 if test "x$withval" = "xno" ; then
2931 AC_DEFINE(DISABLE_LASTLOG) 2931 AC_DEFINE(DISABLE_LASTLOG)
2932 elif test -n "$withval" && test "x${withval}" != "xyes"; then 2932 elif test -n "$withval" && test "x${withval}" != "xyes"; then
2933 conf_lastlog_location=$withval 2933 conf_lastlog_location=$withval
@@ -2996,7 +2996,7 @@ fi
2996 2996
2997if test -n "$conf_lastlog_location"; then 2997if test -n "$conf_lastlog_location"; then
2998 AC_DEFINE_UNQUOTED(CONF_LASTLOG_FILE, "$conf_lastlog_location") 2998 AC_DEFINE_UNQUOTED(CONF_LASTLOG_FILE, "$conf_lastlog_location")
2999fi 2999fi
3000 3000
3001dnl utmp detection 3001dnl utmp detection
3002AC_MSG_CHECKING([if your system defines UTMP_FILE]) 3002AC_MSG_CHECKING([if your system defines UTMP_FILE])
@@ -3026,7 +3026,7 @@ if test -z "$conf_utmp_location"; then
3026fi 3026fi
3027if test -n "$conf_utmp_location"; then 3027if test -n "$conf_utmp_location"; then
3028 AC_DEFINE_UNQUOTED(CONF_UTMP_FILE, "$conf_utmp_location") 3028 AC_DEFINE_UNQUOTED(CONF_UTMP_FILE, "$conf_utmp_location")
3029fi 3029fi
3030 3030
3031dnl wtmp detection 3031dnl wtmp detection
3032AC_MSG_CHECKING([if your system defines WTMP_FILE]) 3032AC_MSG_CHECKING([if your system defines WTMP_FILE])
@@ -3056,7 +3056,7 @@ if test -z "$conf_wtmp_location"; then
3056fi 3056fi
3057if test -n "$conf_wtmp_location"; then 3057if test -n "$conf_wtmp_location"; then
3058 AC_DEFINE_UNQUOTED(CONF_WTMP_FILE, "$conf_wtmp_location") 3058 AC_DEFINE_UNQUOTED(CONF_WTMP_FILE, "$conf_wtmp_location")
3059fi 3059fi
3060 3060
3061 3061
3062dnl utmpx detection - I don't know any system so perverse as to require 3062dnl utmpx detection - I don't know any system so perverse as to require
@@ -3084,7 +3084,7 @@ if test -z "$conf_utmpx_location"; then
3084 fi 3084 fi
3085else 3085else
3086 AC_DEFINE_UNQUOTED(CONF_UTMPX_FILE, "$conf_utmpx_location") 3086 AC_DEFINE_UNQUOTED(CONF_UTMPX_FILE, "$conf_utmpx_location")
3087fi 3087fi
3088 3088
3089dnl wtmpx detection 3089dnl wtmpx detection
3090AC_MSG_CHECKING([if your system defines WTMPX_FILE]) 3090AC_MSG_CHECKING([if your system defines WTMPX_FILE])
@@ -3109,7 +3109,7 @@ if test -z "$conf_wtmpx_location"; then
3109 fi 3109 fi
3110else 3110else
3111 AC_DEFINE_UNQUOTED(CONF_WTMPX_FILE, "$conf_wtmpx_location") 3111 AC_DEFINE_UNQUOTED(CONF_WTMPX_FILE, "$conf_wtmpx_location")
3112fi 3112fi
3113 3113
3114 3114
3115if test ! -z "$blibpath" ; then 3115if test ! -z "$blibpath" ; then