summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2016-08-07 12:18:35 +0100
commiteecddf8b72fcad83ccca43b1badb03782704f6b7 (patch)
treefd0046825c8d42bd267afa7839d5603b130cf847 /configure.ac
parenta8ed8d256b2e2c05b0c15565a7938028c5192277 (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2016-08-07 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 373d21b34..894ec3b7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -632,6 +632,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
632 [Use tunnel device compatibility to OpenBSD]) 632 [Use tunnel device compatibility to OpenBSD])
633 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 633 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
634 [Prepend the address family to IP tunnel traffic]) 634 [Prepend the address family to IP tunnel traffic])
635 AC_MSG_CHECKING([if we have the Security Authorization Session API])
636 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
637 [SessionCreate(0, 0);],
638 [ac_cv_use_security_session_api="yes"
639 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
640 [platform has the Security Authorization Session API])
641 LIBS="$LIBS -framework Security"
642 AC_MSG_RESULT([yes])],
643 [ac_cv_use_security_session_api="no"
644 AC_MSG_RESULT([no])])
645 AC_MSG_CHECKING([if we have an in-memory credentials cache])
646 AC_TRY_COMPILE(
647 [#include <Kerberos/Kerberos.h>],
648 [cc_context_t c;
649 (void) cc_initialize (&c, 0, NULL, NULL);],
650 [AC_DEFINE([USE_CCAPI], [1],
651 [platform uses an in-memory credentials cache])
652 LIBS="$LIBS -framework Security"
653 AC_MSG_RESULT([yes])
654 if test "x$ac_cv_use_security_session_api" = "xno"; then
655 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
656 fi],
657 [AC_MSG_RESULT([no])]
658 )
635 m4_pattern_allow([AU_IPv]) 659 m4_pattern_allow([AU_IPv])
636 AC_CHECK_DECL([AU_IPv4], [], 660 AC_CHECK_DECL([AU_IPv4], [],
637 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 661 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])