summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-03-16 10:48:25 +1100
committerDamien Miller <djm@mindrot.org>2000-03-16 10:48:25 +1100
commit166bd448c92574b5fed88d24e9ca0af1481fe680 (patch)
tree937847826238c88a83ba698991bf75217433bd9b /configure.in
parent08c788a9b3cc9eb211c65c4b33868beb81a9cfd1 (diff)
- Propogate LD through to Makefile
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 27317bea6..81265f1e8 100644
--- a/configure.in
+++ b/configure.in
@@ -4,10 +4,6 @@ AC_CONFIG_HEADER(config.h)
4AC_PROG_CC 4AC_PROG_CC
5AC_CANONICAL_HOST 5AC_CANONICAL_HOST
6 6
7# C Compiler features
8if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi
9AC_C_INLINE
10
11# Checks for programs. 7# Checks for programs.
12AC_PROG_CPP 8AC_PROG_CPP
13AC_PROG_RANLIB 9AC_PROG_RANLIB
@@ -16,6 +12,17 @@ AC_CHECK_PROG(AR, ar, ar)
16AC_PATH_PROG(PERL, perl) 12AC_PATH_PROG(PERL, perl)
17AC_SUBST(PERL) 13AC_SUBST(PERL)
18 14
15if test -z "$LD" ; then
16 LD=$CC
17fi
18AC_SUBST(LD)
19
20# C Compiler features
21AC_C_INLINE
22if test "$GCC" = "yes"; then
23 CFLAGS="$CFLAGS -Wall"
24fi
25
19# Check for some target-specific stuff 26# Check for some target-specific stuff
20case "$host" in 27case "$host" in
21*-*-aix*) 28*-*-aix*)