summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2001-10-23 22:36:54 -0700
committerTim Rice <tim@multitalents.net>2001-10-23 22:36:54 -0700
commit17b93e5d65c29d6f03f99ad0118a2eb80e4443b7 (patch)
tree30734c7409a5ac571bdb29ec7b161ee62ad568ad /configure.in
parent95276711eb5b2c55788d2664b76cb2bd11f56251 (diff)
[configure.in] Fix test for broken dirname. Based on patch from
Dave Dykstra <dwd@bell-labs.com>. Remove un-needed test for zlib.h. [contrib/caldera/openssh.spec, contrib/redhat/openssh.spec, contrib/suse/openssh.spec] Update version to match version.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 373089cd5..627401e20 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.316 2001/10/23 17:14:01 mouring Exp $ 1# $Id: configure.in,v 1.317 2001/10/24 05:36:55 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -396,11 +396,7 @@ AC_ARG_WITH(zlib,
396 ] 396 ]
397) 397)
398 398
399AC_CHECK_HEADER(zlib.h, 399AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first or check config.log ***]))
400 AC_CHECK_LIB(z, gzread, ,
401 AC_MSG_ERROR([*** zlib missing. install first or check config.log ***])),
402 AC_MSG_ERROR([*** zlib missing. install first or check config.log ***]))
403
404 400
405# We don't want to check if we did an pcre override. 401# We don't want to check if we did an pcre override.
406if test -z "$no_comp_check" ; then 402if test -z "$no_comp_check" ; then
@@ -431,7 +427,7 @@ AC_FUNC_STRFTIME
431 427
432# Checks for header files. 428# Checks for header files.
433AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h \ 429AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h \
434 getopt.h glob.h lastlog.h libgen.h limits.h login.h \ 430 getopt.h glob.h lastlog.h limits.h login.h \
435 login_cap.h maillock.h netdb.h netgroup.h \ 431 login_cap.h maillock.h netdb.h netgroup.h \
436 netinet/in_systm.h paths.h poll.h pty.h regex.h \ 432 netinet/in_systm.h paths.h poll.h pty.h regex.h \
437 security/pam_appl.h shadow.h stddef.h stdint.h \ 433 security/pam_appl.h shadow.h stddef.h stdint.h \
@@ -581,10 +577,12 @@ AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_sa \
581 vhangup vsnprintf waitpid __b64_ntop _getpty) 577 vhangup vsnprintf waitpid __b64_ntop _getpty)
582 578
583dnl IRIX and Solaris 2.5.1 have dirname() in libgen 579dnl IRIX and Solaris 2.5.1 have dirname() in libgen
584AC_CHECK_FUNCS(dirname, ,[ 580AC_CHECK_FUNCS(dirname, [AC_CHECK_HEADERS(libgen.h)] ,[
585 AC_CHECK_LIB(gen, dirname,[ 581 AC_CHECK_LIB(gen, dirname,[
586 AC_CACHE_CHECK([for broken dirname], 582 AC_CACHE_CHECK([for broken dirname],
587 ac_cv_have_broken_dirname, [ 583 ac_cv_have_broken_dirname, [
584 save_LIBS="$LIBS"
585 LIBS="$LIBS -lgen"
588 AC_TRY_RUN( 586 AC_TRY_RUN(
589 [ 587 [
590#include <libgen.h> 588#include <libgen.h>
@@ -595,7 +593,7 @@ int main(int argc, char **argv) {
595 593
596 strncpy(buf,"/etc", 32); 594 strncpy(buf,"/etc", 32);
597 s = dirname(buf); 595 s = dirname(buf);
598 if (s && s[0] == '\0') { 596 if (!s || strncmp(s, "/", 32) != 0) {
599 exit(1); 597 exit(1);
600 } else { 598 } else {
601 exit(0); 599 exit(0);
@@ -605,10 +603,12 @@ int main(int argc, char **argv) {
605 [ ac_cv_have_broken_dirname="no" ], 603 [ ac_cv_have_broken_dirname="no" ],
606 [ ac_cv_have_broken_dirname="yes" ] 604 [ ac_cv_have_broken_dirname="yes" ]
607 ) 605 )
606 LIBS="$save_LIBS"
608 ]) 607 ])
609 if test "x$ac_cv_have_getopt_optreset" = "xno" ; then 608 if test "x$ac_cv_have_broken_dirname" = "xno" ; then
610 LIBS="$LIBS -lgen" 609 LIBS="$LIBS -lgen"
611 AC_DEFINE(HAVE_DIRNAME) 610 AC_DEFINE(HAVE_DIRNAME)
611 AC_CHECK_HEADERS(libgen.h)
612 fi 612 fi
613 ]) 613 ])
614]) 614])