summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2001-08-16 00:09:49 +0000
committerBen Lindstrom <mouring@eviladmin.org>2001-08-16 00:09:49 +0000
commit19d7b8d3fa2c73d68ed60250c091f70ec44edbec (patch)
treee63e6cb715a7dc5a22ed7a10e1ac53403ff8de34 /configure.in
parent14c62eb2beb36b2898187b89e6c5058f8942a693 (diff)
- (bal) QNX resync. OK tim@
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in103
1 files changed, 84 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 28843226d..007a95ee9 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.306 2001/08/07 22:29:08 tim Exp $ 1# $Id: configure.in,v 1.307 2001/08/16 00:09:50 mouring Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -271,6 +271,14 @@ mips-sony-bsd|mips-sony-newsos4)
271 fi 271 fi
272 fi 272 fi
273 ;; 273 ;;
274
275*-*-nto-qnx)
276 AC_DEFINE(USE_PIPES)
277 AC_DEFINE(NO_X11_UNIX_SOCKETS)
278 AC_DEFINE(MISSING_NFDBITS)
279 AC_DEFINE(MISSING_HOWMANY)
280 AC_DEFINE(MISSING_FD_MASK)
281 ;;
274esac 282esac
275 283
276# Allow user to specify flags 284# Allow user to specify flags
@@ -365,7 +373,7 @@ AC_CHECK_FUNC(utimes,
365AC_FUNC_STRFTIME 373AC_FUNC_STRFTIME
366 374
367# Checks for header files. 375# Checks for header files.
368AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h getopt.h glob.h lastlog.h libgen.h limits.h login.h login_cap.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h regex.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/queue.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h sys/un.h stddef.h time.h ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h) 376AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h getopt.h glob.h lastlog.h libgen.h limits.h login.h login_cap.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h regex.h shadow.h security/pam_appl.h stdint.h strings.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/queue.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h sys/un.h stddef.h time.h ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h)
369 377
370# Check for ALTDIRFUNC glob() extension 378# Check for ALTDIRFUNC glob() extension
371AC_MSG_CHECKING(for GLOB_ALTDIRFUNC support) 379AC_MSG_CHECKING(for GLOB_ALTDIRFUNC support)
@@ -770,7 +778,22 @@ if test "x$ac_cv_have_intxx_t" = "xyes" ; then
770 AC_DEFINE(HAVE_INTXX_T) 778 AC_DEFINE(HAVE_INTXX_T)
771 have_intxx_t=1 779 have_intxx_t=1
772fi 780fi
773 781
782if (test -z "$have_intxx_t" && \
783 test "x$ac_cv_header_stdint_h" = "xyes")
784then
785 AC_MSG_CHECKING([for intXX_t types in stdint.h])
786 AC_TRY_COMPILE(
787 [ #include <stdint.h> ],
788 [ int8_t a; int16_t b; int32_t c; a = b = c = 1;],
789 [
790 AC_DEFINE(HAVE_INTXX_T)
791 AC_MSG_RESULT(yes)
792 ],
793 [ AC_MSG_RESULT(no) ]
794 )
795fi
796
774AC_CACHE_CHECK([for int64_t type], ac_cv_have_int64_t, [ 797AC_CACHE_CHECK([for int64_t type], ac_cv_have_int64_t, [
775 AC_TRY_COMPILE( 798 AC_TRY_COMPILE(
776 [ #include <sys/types.h> ], 799 [ #include <sys/types.h> ],
@@ -784,6 +807,19 @@ if test "x$ac_cv_have_int64_t" = "xyes" ; then
784 have_int64_t=1 807 have_int64_t=1
785fi 808fi
786 809
810if test -z "$have_int64_t" ; then
811 AC_MSG_CHECKING([for int64_t type in sys/socket.h])
812 AC_TRY_COMPILE(
813 [ #include <sys/socket.h> ],
814 [ int64_t a; a = 1],
815 [
816 AC_DEFINE(HAVE_INT64_T)
817 AC_MSG_RESULT(yes)
818 ],
819 [ AC_MSG_RESULT(no) ]
820 )
821fi
822
787AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [ 823AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [
788 AC_TRY_COMPILE( 824 AC_TRY_COMPILE(
789 [ #include <sys/types.h> ], 825 [ #include <sys/types.h> ],
@@ -797,6 +833,19 @@ if test "x$ac_cv_have_u_intxx_t" = "xyes" ; then
797 have_u_intxx_t=1 833 have_u_intxx_t=1
798fi 834fi
799 835
836if test -z "$have_u_intxx_t" ; then
837 AC_MSG_CHECKING([for u_intXX_t types in sys/socket.h])
838 AC_TRY_COMPILE(
839 [ #include <sys/socket.h> ],
840 [ u_int8_t a; u_int16_t b; u_int32_t c; a = b = c = 1;],
841 [
842 AC_DEFINE(HAVE_U_INTXX_T)
843 AC_MSG_RESULT(yes)
844 ],
845 [ AC_MSG_RESULT(no) ]
846 )
847fi
848
800AC_CACHE_CHECK([for u_int64_t types], ac_cv_have_u_int64_t, [ 849AC_CACHE_CHECK([for u_int64_t types], ac_cv_have_u_int64_t, [
801 AC_TRY_COMPILE( 850 AC_TRY_COMPILE(
802 [ #include <sys/types.h> ], 851 [ #include <sys/types.h> ],
@@ -810,6 +859,35 @@ if test "x$ac_cv_have_u_int64_t" = "xyes" ; then
810 have_u_int64_t=1 859 have_u_int64_t=1
811fi 860fi
812 861
862if test -z "$have_u_intxx_t" ; then
863 AC_CACHE_CHECK([for uintXX_t types], ac_cv_have_uintxx_t, [
864 AC_TRY_COMPILE(
865 [
866#include <sys/types.h>
867 ],
868 [ uint8_t a; uint16_t b; uint32_t c; a = b = c = 1; ],
869 [ ac_cv_have_uintxx_t="yes" ],
870 [ ac_cv_have_uintxx_t="no" ]
871 )
872 ])
873 if test "x$ac_cv_have_uintxx_t" = "xyes" ; then
874 AC_DEFINE(HAVE_UINTXX_T)
875 fi
876fi
877
878if test -z "$have_uintxx_t" ; then
879 AC_MSG_CHECKING([for uintXX_t types in stdint.h])
880 AC_TRY_COMPILE(
881 [ #include <stdint.h> ],
882 [ uint8_t a; uint16_t b; uint32_t c; a = b = c = 1;],
883 [
884 AC_DEFINE(HAVE_UINTXX_T)
885 AC_MSG_RESULT(yes)
886 ],
887 [ AC_MSG_RESULT(no) ]
888 )
889fi
890
813if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \ 891if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \
814 test "x$ac_cv_header_sys_bitypes_h" = "xyes") 892 test "x$ac_cv_header_sys_bitypes_h" = "xyes")
815then 893then
@@ -832,22 +910,6 @@ then
832 ) 910 )
833fi 911fi
834 912
835if test -z "$have_u_intxx_t" ; then
836 AC_CACHE_CHECK([for uintXX_t types], ac_cv_have_uintxx_t, [
837 AC_TRY_COMPILE(
838 [
839#include <sys/types.h>
840 ],
841 [ uint8_t a; uint16_t b; uint32_t c; a = b = c = 1; ],
842 [ ac_cv_have_uintxx_t="yes" ],
843 [ ac_cv_have_uintxx_t="no" ]
844 )
845 ])
846 if test "x$ac_cv_have_uintxx_t" = "xyes" ; then
847 AC_DEFINE(HAVE_UINTXX_T)
848 fi
849fi
850
851AC_CACHE_CHECK([for socklen_t], ac_cv_have_socklen_t, [ 913AC_CACHE_CHECK([for socklen_t], ac_cv_have_socklen_t, [
852 AC_TRY_COMPILE( 914 AC_TRY_COMPILE(
853 [ 915 [
@@ -1772,6 +1834,9 @@ AC_TRY_COMPILE([
1772#ifdef HAVE_PATHS_H 1834#ifdef HAVE_PATHS_H
1773# include <paths.h> 1835# include <paths.h>
1774#endif 1836#endif
1837#ifdef HAVE_LOGIN_H
1838# include <login.h>
1839#endif
1775 ], 1840 ],
1776 [ char *lastlog = LASTLOG_FILE; ], 1841 [ char *lastlog = LASTLOG_FILE; ],
1777 [ AC_MSG_RESULT(yes) ], 1842 [ AC_MSG_RESULT(yes) ],