summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-01-23 10:32:03 +1100
committerDamien Miller <djm@mindrot.org>2000-01-23 10:32:03 +1100
commit1fa154bb1e06bfb4f8d6b95f09a6352d38577c57 (patch)
tree62678a152fab75d8062dff6eb85e72db6fb27acc /configure.in
parent6fe375dee4f0c5b81026d7eb9dc00cf75645b241 (diff)
- AIX patch from Matt Richards <v2matt@btv.ibm.com> and David Rankin
<drankin@bohemians.lexington.ky.us>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 42 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4d414573f..6f5cdafc7 100644
--- a/configure.in
+++ b/configure.in
@@ -518,13 +518,53 @@ dnl Compile with dante SOCKS library
518AC_ARG_WITH(dante, 518AC_ARG_WITH(dante,
519 [ --with-dante=DIR Use Dante SOCKS lib (default is system library path)], 519 [ --with-dante=DIR Use Dante SOCKS lib (default is system library path)],
520 [ 520 [
521 AC_DEFINE(HAVE_DANTE) 521 SAVELIBS="$LIBS"
522 SOCKSLIBS=""
523 SOCKSLIBPATH=""
522 if test "x$withval" != "xno" ; then 524 if test "x$withval" != "xno" ; then
523 if test -n $withval ; then 525 if test -n $withval ; then
524 LIBS="$LIBS -L$withval" 526 LIBS="$LIBS -L$withval"
527 SOCKSLIBPATH="-L$withval"
525 fi 528 fi
526 LIBS="$LIBS -lsocks" 529 AC_CHECK_LIB(socks, Rconnect, AC_DEFINE(HAVE_DANTE) SOCKSLIBS="$SOCKSLIBPATH -lsocks")
527 fi 530 fi
531 LIBS="$SAVELIBS $SOCKSLIBS"
532 ]
533)
534
535dnl Compile with SOCKS4 SOCKS library
536AC_ARG_WITH(socks4,
537 [ --with-socks4=DIR Use Socks4 SOCKS lib (default is system library path)],
538 [
539 SAVELIBS="$LIBS"
540 SOCKSLIBS=""
541 SOCKSLIBPATH=""
542 if test "x$withval" != "xno" ; then
543 if test -n $withval ; then
544 LIBS="$LIBS -L$withval"
545 SOCKSLIBPATH="-L$withval"
546 fi
547 AC_CHECK_LIB(socks, Rconnect, AC_DEFINE(HAVE_SOCKS4) SOCKSLIBS="$SOCKSLIBPATH -lsocks")
548 fi
549 LIBS="$SAVELIBS $SOCKSLIBS"
550 ]
551)
552
553dnl Compile with SOCKS5 SOCKS library
554AC_ARG_WITH(socks5,
555 [ --with-socks5=DIR Use Socks5 SOCKS lib (default is system library path)],
556 [
557 SAVELIBS="$LIBS"
558 SOCKSLIBS=""
559 SOCKSLIBPATH=""
560 if test "x$withval" != "xno" ; then
561 if test -n $withval ; then
562 LIBS="$LIBS -L$withval"
563 SOCKSLIBPATH="-L$withval"
564 fi
565 AC_CHECK_LIB(socks5, SOCKSconnect, AC_DEFINE(HAVE_SOCKS5) SOCKSLIBS="$SOCKSLIBPATH -lsocks5")
566 fi
567 LIBS="$SAVELIBS $SOCKSLIBS"
528 ] 568 ]
529) 569)
530AC_ARG_WITH(catman, 570AC_ARG_WITH(catman,