summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-25 10:11:29 +1100
committerDamien Miller <djm@mindrot.org>1999-12-25 10:11:29 +1100
commit2e1b082dfbc5dcdae80957a3d889abe9fa480d77 (patch)
treec2bfe8d4115d22146448ce829fb7b16e9b762b4f /configure.in
parent1b0c228ec48d54705474701b6486f1593539a88a (diff)
- Prepare for 1.2.1pre20
19991225 - More fixes from Andre Lucas <andre.lucas@dial.pipex.com> - Cleanup of auth-passwd.c for shadow and MD5 passwords - Cleanup and bugfix of PAM authentication code 19991223 - Merged later HPUX patch from Andre Lucas <andre.lucas@dial.pipex.com> - Above patch included better utmpx support from Ben Taylor <bent@clark.net>:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 36 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index b5ffee79e..7bb96270a 100644
--- a/configure.in
+++ b/configure.in
@@ -9,10 +9,25 @@ AC_PROG_CPP
9AC_PROG_RANLIB 9AC_PROG_RANLIB
10AC_PROG_INSTALL 10AC_PROG_INSTALL
11AC_CHECK_PROG(AR, ar, ar) 11AC_CHECK_PROG(AR, ar, ar)
12
13dnl Check for the path to xauth
14AC_PATH_PROG(xauth_path, xauth) 12AC_PATH_PROG(xauth_path, xauth)
15AC_DEFINE_UNQUOTED(XAUTH_PATH, "$xauth_path") 13
14dnl Use ip address instead of hostname in $DISPLAY
15AC_ARG_WITH(rsh,
16 [ --with-rsh=PATH Specify path to remote shell program ],
17 [
18 AC_DEFINE_UNQUOTED(RSH_PATH, "$withval")
19 ],
20 [
21 AC_PATH_PROG(rsh_path, rsh)
22 ]
23)
24
25if test ! -z "$xauth_path" ; then
26 AC_DEFINE_UNQUOTED(XAUTH_PATH, "$xauth_path")
27fi
28if test ! -z "$rsh_path" ; then
29 AC_DEFINE_UNQUOTED(RSH_PATH, "$rsh_path")
30fi
16 31
17dnl Checks for compiler characteristics 32dnl Checks for compiler characteristics
18if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi 33if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi
@@ -27,6 +42,7 @@ case "$host" in
27 fi 42 fi
28 CFLAGS="$CFLAGS -D_HPUX_SOURCE" 43 CFLAGS="$CFLAGS -D_HPUX_SOURCE"
29 AC_DEFINE(IPADDR_IN_DISPLAY) 44 AC_DEFINE(IPADDR_IN_DISPLAY)
45 AC_DEFINE(USE_UTMPX)
30 AC_MSG_CHECKING(for HPUX trusted system password database) 46 AC_MSG_CHECKING(for HPUX trusted system password database)
31 if test -f /tcb/files/auth/system/default; then 47 if test -f /tcb/files/auth/system/default; then
32 AC_MSG_RESULT(yes) 48 AC_MSG_RESULT(yes)
@@ -80,15 +96,22 @@ AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil")
80AC_CHECK_LIB(nsl, yp_match, , ) 96AC_CHECK_LIB(nsl, yp_match, , )
81AC_CHECK_LIB(socket, main, , ) 97AC_CHECK_LIB(socket, main, , )
82 98
83dnl libdl is needed by PAM on Redhat systems 99dnl Use ip address instead of hostname in $DISPLAY
84AC_CHECK_LIB(dl, dlopen, , ) 100AC_ARG_WITH(pam,
85AC_CHECK_LIB(pam, pam_authenticate, , ) 101 [ --without-pam Disable PAM support ],
102 [
103 if test "x$withval" != "xno" ; then
104 AC_CHECK_LIB(dl, dlopen, , )
105 AC_CHECK_LIB(pam, pam_authenticate, , )
106 fi
107 ]
108)
86 109
87dnl Checks for header files. 110dnl Checks for header files.
88AC_CHECK_HEADERS(endian.h lastlog.h login.h maillock.h netgroup.h paths.h poll.h pty.h shadow_h util.h utmp.h utmpx.h sys/bsdtty.h sys/poll.h sys/select.h sys/stropts.h sys/time.h) 111AC_CHECK_HEADERS(endian.h lastlog.h login.h maillock.h netgroup.h paths.h poll.h pty.h shadow.h util.h utmp.h utmpx.h sys/bsdtty.h sys/poll.h sys/select.h sys/stropts.h sys/time.h sys/ttcompat.h)
89 112
90dnl Checks for library functions. 113dnl Checks for library functions.
91AC_CHECK_FUNCS(arc4random mkdtemp openpty _getpty setenv seteuid setlogin setproctitle setreuid snprintf strlcat strlcpy vsnprintf) 114AC_CHECK_FUNCS(arc4random updwtmpx mkdtemp openpty _getpty innetgr setenv seteuid setlogin setproctitle setreuid snprintf strlcat strlcpy vsnprintf)
92 115
93AC_CHECK_FUNC(login, 116AC_CHECK_FUNC(login,
94 [AC_DEFINE(HAVE_LOGIN)], 117 [AC_DEFINE(HAVE_LOGIN)],
@@ -220,19 +243,21 @@ if test -z "$RANDOM_POOL" -a -z "$EGD_POOL"; then
220 AC_MSG_ERROR([No random device found, and no EGD random pool specified]) 243 AC_MSG_ERROR([No random device found, and no EGD random pool specified])
221fi 244fi
222 245
223dnl Check for ut_host field in utmp
224AC_MSG_CHECKING([whether utmp.h has ut_host field]) 246AC_MSG_CHECKING([whether utmp.h has ut_host field])
225AC_EGREP_HEADER(ut_host, utmp.h, 247AC_EGREP_HEADER(ut_host, utmp.h,
226 [AC_DEFINE(HAVE_HOST_IN_UTMP) AC_MSG_RESULT(yes); ], 248 [AC_DEFINE(HAVE_HOST_IN_UTMP) AC_MSG_RESULT(yes); ],
227 [AC_MSG_RESULT(no)] 249 [AC_MSG_RESULT(no)]
228) 250)
229
230dnl Check for ut_host field in utmpx
231AC_MSG_CHECKING([whether utmpx.h has ut_host field]) 251AC_MSG_CHECKING([whether utmpx.h has ut_host field])
232AC_EGREP_HEADER(ut_host, utmpx.h, 252AC_EGREP_HEADER(ut_host, utmpx.h,
233 [AC_DEFINE(HAVE_HOST_IN_UTMPX) AC_MSG_RESULT(yes); ], 253 [AC_DEFINE(HAVE_HOST_IN_UTMPX) AC_MSG_RESULT(yes); ],
234 [AC_MSG_RESULT(no)] 254 [AC_MSG_RESULT(no)]
235) 255)
256AC_MSG_CHECKING([whether utmpx.h has syslen field])
257AC_EGREP_HEADER(syslen, utmpx.h,
258 [AC_DEFINE(HAVE_SYSLEN_IN_UTMPX) AC_MSG_RESULT(yes); ],
259 [AC_MSG_RESULT(no)]
260)
236 261
237dnl Look for lastlog location 262dnl Look for lastlog location
238AC_ARG_WITH(lastlog, 263AC_ARG_WITH(lastlog,