summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-02-07 13:20:26 +1100
committerDamien Miller <djm@mindrot.org>2000-02-07 13:20:26 +1100
commit36143d785143daabda83962a0f34404a9abf0964 (patch)
tree7c25bfde7fae4a60484dde3782938f9155e83955 /configure.in
parent8b171bc4cd9367e9dc99e53ebabcb0d04f9ba7da (diff)
- Removed SOCKS code. Will support through a ProxyCommand.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in55
1 files changed, 2 insertions, 53 deletions
diff --git a/configure.in b/configure.in
index 1176bfc48..f2128d7f1 100644
--- a/configure.in
+++ b/configure.in
@@ -524,59 +524,6 @@ if test ! -z "$nolastlog" ; then
524 AC_DEFINE(DISABLE_LASTLOG) 524 AC_DEFINE(DISABLE_LASTLOG)
525fi 525fi
526 526
527dnl Compile with dante SOCKS library
528AC_ARG_WITH(dante,
529 [ --with-dante=DIR Use Dante SOCKS lib (default is system library path)],
530 [
531 SAVELIBS="$LIBS"
532 SOCKSLIBS=""
533 SOCKSLIBPATH=""
534 if test "x$withval" != "xno" ; then
535 if test -n $withval ; then
536 LIBS="$LIBS -L$withval"
537 SOCKSLIBPATH="-L$withval"
538 fi
539 AC_CHECK_LIB(socks, Rconnect, AC_DEFINE(HAVE_DANTE) SOCKSLIBS="$SOCKSLIBPATH -lsocks")
540 fi
541 LIBS="$SAVELIBS $SOCKSLIBS"
542 ]
543)
544
545dnl Compile with SOCKS4 SOCKS library
546AC_ARG_WITH(socks4,
547 [ --with-socks4=DIR Use Socks4 SOCKS lib (default is system library path)],
548 [
549 SAVELIBS="$LIBS"
550 SOCKSLIBS=""
551 SOCKSLIBPATH=""
552 if test "x$withval" != "xno" ; then
553 if test -n $withval ; then
554 LIBS="$LIBS -L$withval"
555 SOCKSLIBPATH="-L$withval"
556 fi
557 AC_CHECK_LIB(socks, Rconnect, AC_DEFINE(HAVE_SOCKS4) SOCKSLIBS="$SOCKSLIBPATH -lsocks")
558 fi
559 LIBS="$SAVELIBS $SOCKSLIBS"
560 ]
561)
562
563dnl Compile with SOCKS5 SOCKS library
564AC_ARG_WITH(socks5,
565 [ --with-socks5=DIR Use Socks5 SOCKS lib (default is system library path)],
566 [
567 SAVELIBS="$LIBS"
568 SOCKSLIBS=""
569 SOCKSLIBPATH=""
570 if test "x$withval" != "xno" ; then
571 if test -n $withval ; then
572 LIBS="$LIBS -L$withval"
573 SOCKSLIBPATH="-L$withval"
574 fi
575 AC_CHECK_LIB(socks5, SOCKSconnect, AC_DEFINE(HAVE_SOCKS5) SOCKSLIBS="$SOCKSLIBPATH -lsocks5")
576 fi
577 LIBS="$SAVELIBS $SOCKSLIBS"
578 ]
579)
580AC_ARG_WITH(catman, 527AC_ARG_WITH(catman,
581 [ --with-catman=man|cat Install preformatted manpages[no]], 528 [ --with-catman=man|cat Install preformatted manpages[no]],
582 [ 529 [
@@ -769,3 +716,5 @@ if test ! -z "$MAIL" ; then
769fi 716fi
770 717
771AC_OUTPUT(Makefile) 718AC_OUTPUT(Makefile)
719
720