summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-09-23 14:12:24 +1100
committerDamien Miller <djm@mindrot.org>2000-09-23 14:12:24 +1100
commit578783e6bfb3cb81a63aa580f5641af010d73c72 (patch)
treef9b01fb303b71973abf07ed4be4b62188fc293cd /configure.in
parent9600233f0ff7a15c41da766da2f62b9e76565d71 (diff)
- (djm) Seperate tests for int64_t and u_int64_t types
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 774529d30..305d9a493 100644
--- a/configure.in
+++ b/configure.in
@@ -487,6 +487,19 @@ if test "x$ac_cv_have_intxx_t" = "xyes" ; then
487 have_intxx_t=1 487 have_intxx_t=1
488fi 488fi
489 489
490AC_CACHE_CHECK([for int64_t type], ac_cv_have_int64_t, [
491 AC_TRY_COMPILE(
492 [ #include <sys/types.h> ],
493 [ int64_t a; a = 1;],
494 [ ac_cv_have_int64_t="yes" ],
495 [ ac_cv_have_int64_t="no" ]
496 )
497])
498if test "x$ac_cv_have_int64_t" = "xyes" ; then
499 AC_DEFINE(HAVE_INT64_T)
500 have_int64_t=1
501fi
502
490AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [ 503AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [
491 AC_TRY_COMPILE( 504 AC_TRY_COMPILE(
492 [ #include <sys/types.h> ], 505 [ #include <sys/types.h> ],
@@ -500,6 +513,19 @@ if test "x$ac_cv_have_u_intxx_t" = "xyes" ; then
500 have_u_intxx_t=1 513 have_u_intxx_t=1
501fi 514fi
502 515
516AC_CACHE_CHECK([for u_int64_t types], ac_cv_have_u_int64_t, [
517 AC_TRY_COMPILE(
518 [ #include <sys/types.h> ],
519 [ u_int64_t a; a = 1;],
520 [ ac_cv_have_u_int64_t="yes" ],
521 [ ac_cv_have_u_int64_t="no" ]
522 )
523])
524if test "x$ac_cv_have_u_int64_t" = "xyes" ; then
525 AC_DEFINE(HAVE_U_INT64_T)
526 have_u_int64_t=1
527fi
528
503if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \ 529if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \
504 test "x$ac_cv_header_sys_bitypes_h" = "xyes") 530 test "x$ac_cv_header_sys_bitypes_h" = "xyes")
505then 531then